Download

4.19 & 4.20 Editor & Packaged Games Have Hangs/Hiccups Constantly

4.20p1 is also leaking 2mb per second.

Oh no! please no… I’m going download and test it then, really hope the hitching isn’t as bad. If it is I guess I have no choice but to rollback and redo all my recent changes in 4.18, argh!

@Epic I haven’t had a chance to really dig in to the profiler but can say the hitching is much worse with either a lot of reflection capture’s or a planar reflection actor in a scene using fully dynamic lighting. In my ocean project which has a very large planar reflection actor the hitching can last ~100-200ms every 10 seconds when looking at the ocean, but is only slight hitching (less than 50ms) when looking at the landscape only.

That’s on a system with an i7 8700k & GTX 1080

Looks like 4.19.2 it’s no longer hangs here with the new NVIDIA driver but you know never say never… :slight_smile:

Which version is the new one ?

398.11

Just went on simple test and the hiccups are still there, with at least 20-25fps drop between them. Not even going to bother with memory leak testing, it is not a driver issue.

Thanks for input, but the leak and hitches are indeed still there on 398.11, just tested it, 4.19.2 and 4.20p1

Yep, same here, new drivers made no difference whatsoever.

I can also confirm that neither new driver nor 4.20p1 make any difference. The latter isn’t much of a surprise, since the issue is marked as being resolved only in 4.21. Still disappointing though.

I would also like to add, uninstalling my up to date NVIDIA driver and installing 385.69 fixed my editor lag/stutter issue which was happening every couple seconds.

Its ok, but 4.18 and previous releases the issue is not there with any driver version, so it is a engine bug, not driver bug. Also, target systems are more likely to have latest drivers, since they fix/improve game’s performance/quality, so rolling back is a no no alternative.

I tried the test project and my editor runs fine now after a long time keeping an eye on it (5 mins atleast). I do however have a maybe related issue. In my game that ofc ran fine in 4.18, it now shows these rather periodic stutters. I checked GameThread and RenderThread, and they both run fine within the 10-11ms threshold for VR (Vive), so something else i causing these stutters. And note, this is running it Packaged, so its most probably not the same issue as the OP, but nevertheless may be related.

I just tested the 385.69 drivers from Nvidia, and that did not resolve the hitching on my end. As others have mentioned, it is a very consistent hitch every other second which makes playing, testing, and optimizing my game nearly impossible. Very annoying and incredibly confused as to how this is not urgent and being addressed with a hotfix…?! It’s definitely an engine regression as it is not just the editor hitching when working, but also a packaged version of the game. This is game breaking, and needs more urgency in my honest opinion.

Mind sharing details about rig, on which reverting to 385.69 had no effect?

There is no proper ticker on public issue tracker, that would describe the issue in a sane manner so far.

System Info:
OS: Windows 10 Home Edition
CPU: i7 -7700k @ 4.20 GHz
GPU: Nvidia 1080
RAM: 32 GB

It’s a pretty nice machine, and I’ve never had issues like this before on any previous engine versions using the same computer throughout. I am convinced this is an engine regression and has little to nothing to do with graphics drivers in particular.

My team and I are honestly at this point considering reverting our project back to 4.18.3. This has been the most damaging and disastrous version of the editor I think I have ever used :frowning:

Wait till 4.20 then you will see that things can be even worst… Im getting in 3 different projects 40% of the frame rates I was experiencing from 4.16 to 4.19 (in packaged game, not in editor). I have expent 40+ hours digging into 4.20 source code and still not close to discover what is causing it.

Sure, but I think it’s reasonable to hope that if Epic could identify and fix the clearly related issues described in the public tracker, they might also have identified and fixed the underlying cause.
I guess we’ll find out in half a year or so. :smiley:

Sadly, so far there is zero indication of responsible personnel being aware of the issue.
I just can’t find any other explanation why catastrophic regression is not being addressed.

I could not find the change to blame either.

So after an entire day of running the profiler and almost giving up completely, I stumbled upon a setting nested in the Project Settings > Navigation Mesh > Do Fully Async Nav Data Gathering that resolved our constant hitching.

In our case, we are using a Persistent Level in which we stream all other levels in from, and our Nav Mesh is placed within the persistent. For some reason, having the navigation mesh not asynchronously gathering navigation data caused our project to have a hitch as if it were a heartbeat. A very consistent hitch that followed a pattern. I am not sure if this setting was reverted or changed during the upgrade between engine versions, but I do know it was not like this in 4.18.3 so whatever the case I still believe there is a bug here.

In any case, I do not know if this is going to help everyone else as we still notice some random hitching in the engine that doesn’t seem to have much of an explanation thus far. Hope this helped anyone struggling with hitching!

Thanks for providing a potential fix, I hope it will help some people struggling with this issue. For our project however this doesn’t seem to help. The project I’m working on is just a demo without any nav mesh volumes in the world but tried this out regardless, however I don’t see any difference in this project.

Seems to be somehow related to reflection capture in our case best I can tell, we use a very large planar reflection component on top of the ocean surface. I am assuming this is why the hitching is so bad in this project, it jumps from 11ms frametime to 100ms or more, it gets so bad sometimes the engine freezes for over a second on a PC with an 8700k and GTX1080.

And 4.20 is definitely worse.

Problem is I can’t figure out what triggers it and it doesn’t happen all the time making it next to impossible to create a bug report for it. Even if I could reproduce it regularly there are already 2 bug reports in this thread anyways. This is a critical issue. 4.19 and 4.20 are essentially unusable to create a game using this or any of the other projects discussed in this thread.

It’s frustrating not being able to solve this and not hearing anything from Epic on the matter doesn’t help the situation. This thread is a prime example of how the new bug reporting system is failing us end users. At least before we could go through and try the steps listed on AnswerHub by Epic staff to see if it helped our situation, now we have 10+ threads both here and on AnswerHub for the same issue without any visible support provided by Epic.

As someone who used to work in a support role this drives me crazy seeing the amount of support decrease when it should be the opposite. I really hope you guys take a look at the before and after from our perspective, including overall community sentiment stemming from this reduction in visible support, and try to remedy the situation in the near future.

Thank you