Download

4.19 & 4.20 Editor & Packaged Games Have Hangs/Hiccups Constantly

How much RAM do you have ? I had the same issue until I upgraded to 16Gb of RAM.

32GB on system and 8GB on GPU, processor at 3.9GHz - 8 cores/16 threads.

For the record, me:
24GB system, 980GTX 4GB GPU, i7-4790K @4.00Ghz+ 4 cores/ 8 threads

You have a nice machine Nilson!

I have not tried re-updating to 391.35 yet, not sure it will make a difference with 4.19.1

My Blueprint Compile times have also gone up, along with the Editor hangups. It seems worse in 4.19.1 somehow. But all of this is worse than 4.18. I know the BP Compile time issues are from the Compilation Manager.

Even hitting Play for PIE is gross

I’m glad others are able to somewhat verify my issues, but of course it saddens me that these issues exist for them. Victor and others are having a tougher time than me, getting rid of the two particles made my situation acceptable. Although I still get a crappier performance and occasional screen hangs that were not there in 4.18 and PIE.

Hello Motus Digital,

Thank you for reporting this issue. We got your bug submission and have entered a bug report which can be found here: Unreal Engine Issues and Bug Tracker (UE-57557)

If you have any further issues, please be sure to reach out with another submission through the form as before.

Thank you Matthew! Glad I was able to help with the process and that it was logged.

Cris

I am getting similar hanging / hitching specially when using any stat commands, including ‘stat startfile’, ‘stat gpu’, ‘stat rendering’ to name a few. I am running 4.19.1, and have a GTX960 with latest drivers. Happens in a blank project as well. Does not happen in 4.17.2.

Same card here, GTX960. Same issues. Going back to 4.16.3.

I see than I am not the only one with simillar issue. I have GTX 1080 with latest nvidia driver. The problem must be somwhere in drivers <-> UE. I got a simple scene with some BP meshes on the scene. After a while I got some laggs every half a second or so. The strange thing is that when I press G to hide all the lines etc. everything is normal (120 FPS constant), but just when I press G to get out of Game View it starts to lagging.
The exactly same scene in 4.18 is working like a charm.

Our BP have some Billboards attached with simple material and texture. After I hide this is helps a lot but not 100%.

I’d like to remind everyone the bug to vote for is here:

https://issues.unrealengine.com/issue/UE-57557

It has a whopping 5 votes so far, so doubt it will be fixed anytime soon and if it is, it’s slated for 4.20

But this has nothing to do with those two sprites. I guess this is something that we all have but the source of the problem is not the two objects. It must be an issue with the drivers or something simillar. I don’t have those assets in my project but still have the issue tho.

I agree, everyone has a different specific trigger shall we say, but similar symptoms, so I think it is a graphics/driver issue of crappy performance reacting to various otherwise benign things. I spent two days ripping my Project/Map apart for the answer - the moment I removed the rotating mesh particles it was fixed. Madness.

I found a solution for my problem (GeForce 1080 Ti). I just installed the oldest drivers from nVidia site and it is working fantastic now. No hiccups at all. Maybe this will help someone else.

How far back, what driver version number please?

I’ve downloaded the very first version for 1080. It is 382.53 for Windows 10 64 bit.

Hello,

I am joining the party. GTX1080Ti, latest nVidia drivers. I am getting hiccups and stuttering with increasing intensity the longer Unreal Editor is open. When it gets too bad, I have to close it down, restart, and then the performance again starts to degrade slowly.

My issue is definitely not related to those Engine default pickups, as they are not the part of my level or even my project.

I am wondering if there are some factors we have in common…?:

Oculus Rift headset
ESET Internet Security antivirus

Windows 10 Fall Creators Update
GTX1080Ti + 397.31 drivers + 2 Monitor setup
i7 5930K
64GB RAM
SoundBlaster Z sound card with latest drivers

It does not seem to be a common factor other hardware. We are having the issue with AMD processors, less RAM, no VR gear, no soundcard, different antiviruses, the only common ground besides the UE 4.19 seems to be NVidia cards and recent drivers. @Illusionray tested with old Nvidia driver and it seems to not have the issue (I myself can’t rollback to that version: 382.53 for Windows 10 64 bit)

I wonder if this commit going in 4.19.2 could be related. If I remember right, the editor uses the TBB allocator. https://github.com/EpicGames/UnrealEngine/commit/0c78b2e389e4fe73b19360c0494dd3df9bdebbdf

This issue Jira number is this: Unreal Engine Issues and Bug Tracker (UE-57557), but I see the Jira on the commit messing with stuff around this, it will be nice to see it fixed prior 4.20 thou