Download

4.11 Transition Guide

Is still here with usual right-click, the fun fact is if i launch the project via .uproject file or launcher all go fine.

If use UPROPERTY() 'UAnimBlueprintGeneratedClass* ’ in code

must change

UAnimBlueprintGeneratedClass* -> TSubclassOf<UAnimInstance>

I done a complete reinstall of the engine, the Generate Visual Studio project files problem persist but i can workaround it with the command line
<Path/To/UnrealEngine4>/UE4/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="<Path/To>/Unreal Projects/<Project Name>/<Project Name>.uproject" -game -engine -progress -2015

and now it not crash at start.

if i don’t have to regenerate project files all work fine but if i compile via editor the hot reload fail

and if i regenerate the project file i come back to previous problem and project crash at start

:frowning:

void UObject::LoadConfig( uint64 Flags, const TCHAR* InFilename, FConfigCacheIni* Config/=GConfig/ )
void UObject::SaveConfig( uint64 Flags, const TCHAR* InFilename, FConfigCacheIni* Config/=GConfig/ )

are no more virutal, so no more dirty config save/loading sumgling. :frowning:

Ok, maybe TMaps now can be serialized, so no need to do this… But still it changes some things.

RF_Unreachable - is moved to EInternalObjectFlags, now there is a function UObjectBaseUtility::IsPendingKillOrUnreachable() to check for such state

I’m having a major issue with including “Engine/DemoNetDriver.h” for my demo player.

https://answers.unrealengine.com/questions/397613/4110-migration-cant-compile-with-enginedemonetdriv.html

Error:
4.11\Engine\Source\Runtime\Engine\Classes\Engine/DemoNetDriver.h(6): fatal error C1083: Cannot open include file: ‘NetworkReplayStreaming.h’: No such file or directory

Anyone else seeing this?

FIXED************ New Module dependencies needed

Add this to your Build.CS file:

DynamicallyLoadedModuleNames.AddRange(
new string] {
“OnlineSubsystemNull”,
“NetworkReplayStreaming”,
“NullNetworkReplayStreaming”,
“HttpNetworkReplayStreaming”
}
);

    PrivateIncludePathModuleNames.AddRange(
        new string] {
            "NetworkReplayStreaming"
        }
    );

CollisionQueryParams.h

mutable IgnoreComponentsArrayType IgnoreComponents; has changed to private.

now use the accessor functions instead,

const IgnoreComponentsArrayType& GetIgnoredComponents() const;
void ClearIgnoredComponents()

Fyi: 4.11 will now break if you have liked named UMG widgets and variables.

You will need to avoid duplicates names across the board in the same UMG blueprint, which is a good practice anyways.

And Upgrade complete for me. Good luck =)

Does anyone know about a benchmark scene or a way to benchmark 4.11 against older versions of UE4?
We are interested in upgrading for the performance boost listed in the release notes, but there is no description of what can be expected on average for typical scenes.

Aye - we were running into FName problems with people using lots of symbols and such, so now we just slug the name you use (strip out symbols, spaces…etc, just becomes letters and numbers), for the actual variable name, but the visual name stays pretty and readable.

Unistalled NVIDIA AndroidWorks solved the problem :o

Just did a comparison with the only pre-4.11.0 package I could find (from the 15th) and my .pak file was 156 at that time. It’s 380 after the 4.11 release. The only resources or assets that have been added since that time are a few small speech .wav files (each only a few seconds of speech) and the splash screens and icon I mentioned. Code wise I’ve added some BP AI code, and updated a couple of CPP functions. These should both be Windows 32-bit Development packages.

You are the best.

Hello!

I’m also having an issue with making the transition from 4.10 to 4.11 my projects. It outputs this error in VS2013



1>------ Build started: Project: WeapTest, Configuration: Development_Editor x64 ------
1>  Creating makefile for WeapTestEditor (no existing makefile)
1>  Performing full C++ include scan (no include cache file)
1>  Parsing headers for WeapTestEditor
1>    Running UnrealHeaderTool "C:\Users\CHADALAK\Documents\Unreal Projects\WeapTest\WeapTest.uproject" "C:\Users\CHADALAK\Documents\Unreal Projects\WeapTest\Intermediate\Build\Win64\WeapTestEditor\Development\UnrealHeaderTool.manifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed
1>LogCompile : error : Failed to initialize the engine (PreInit failed).
1>Error : Failed to generate code for WeapTestEditor - error code: CrashOrAssert (3)
1>  UnrealHeaderTool failed for target 'WeapTestEditor' (platform: Win64, module info: C:\Users\CHADALAK\Documents\Unreal Projects\WeapTest\Intermediate\Build\Win64\WeapTestEditor\Development\UnrealHeaderTool.manifest).
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ""C:\Program Files\Unreal Engine\4.11\Engine\Build\BatchFiles\Build.bat" WeapTestEditor Win64 Development "C:\Users\CHADALAK\Documents\Unreal Projects\WeapTest\WeapTest.uproject" -waitmutex" exited with code -1.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========



I’m assuming its the Build.bat file?

Could be caused by the Substance plugin, try open your .uproject file and set “Enabled: false” like this



{
	"FileVersion": 3,
	"EngineAssociation": "4.11",
	"Category": "",
	"Description": "",
	"Modules": 
		{
			"Name": "TanksVSZombies",
			"Type": "Runtime",
			"LoadingPhase": "Default",
			"AdditionalDependencies": 
				"Engine"
			]
		}
	],
	"Plugins": 
		{
			"Name": "Substance",
			"Enabled": false
		}
	]
}


or wait the Substance plugin update for 4.11 :slight_smile:

Thanks for sharing this Devero!

:slight_smile:

Thank you for this update Nick!

Rama

I have 3 issues and workarounds in 4.11.

  1. The character no longer receives mouse movement when the show mouse cursor is active on PlayerController. Some games (RTS, wow-style 3rd person) require this because you need menu and character interaction. The fix for now is a pull request 2206 (yes, source only) or some naughty workarounds … More is discussed in show mouse cursor disables mouse events - UE4 AnswerHub . I hope they make a patch as soon as possible.

  2. Character blueprint has currupt networking replication. In my situation, I have class hierarchy Character -> A (in C++) -> B (Blueprints) -> C (Blueprints). Everything works ok until you try networked game, when an assertion happens. The replicated variables pool is outdated. Recompiling B solved the issue but you have to do it everytime you open the editor (a workaround for now). Maybe smarter people may have more insight in how to fix it permanently.

  3. On Windows, Lightmass does not build with VS2015 update 2 due to error: lightmasscore\math\LMMathSSE.h(586): error C3861: ‘_mm_cvtpu8_ps’: identifier not found. The workaround is to compile with previous version of visual studio.

I hope this is helpful, if anyone has additional comments, feel free to elaborate. I have found this thread (and answerhub) really helpfull in transition from 4.10 to 4.11!

Thanks!!! that solved my issue :)!! I noticed the notification about the Substance plugin wouldnt work for this version when updating it. Didnt know it would be the cause of it not executing :frowning:

Woohoo! great to hear! and thank you @ZioYuri78 for sharing!

:heart:

Rama

“Your Project” not found, pointing to GENERATED_BODY’s of various functions

Dear Community,

When I first switched engine versions and then tried to compile I was getting very disconcerting compile errors about MyProjectName not being found by any class, and the error pointing to GENERATED_BODY

Solution:

Just do a full rebuild, and if that doesnt work you can delete Intermediate folder, .sln, .sdf, .vs, and right click uproject and generate VS files again.

Was sufficiently dramatic of a series of errors I felt it was worth its own post :slight_smile:

Rama