4.10.3 Editor Bug, level switch runtime crash

The changelist only benefits our custom licensees with P4 access, but it is 2872339.

edit: Source code developers using Github can grab the fix with this commit: https://github.com/EpicGames/UnrealEngine/commit/e19e98f640e7de230b943453fb1acc9a96ea59b5 (you must be logged into GitHub with a connected account to view the link)

We will release a fix for the binary editor as soon as we can.


Until that time, is there any kind of workaround you guys have discovered? Can you shed some light on what is causing the crash? Would love to keep working on stuff.

Level switching should still work if you switch to standalone in the editor.

got it. thx

Is there a way to downgrade to 4.10.2 again? I tried standalone and it crashes as well for me.
Thank you in advance.

Crash only seems to occur if the map you are changing to is currently opened in the editor. Try an empty level with a keypress shortcut to the level you want to test or try to start from your menu level.

standalone doesn’t work for me. :frowning:

Hi everyone,

Please try updating to the 4.10.4 hotfix. This should resolve the error, if not, please post here so we can investigate further.


I think I might be experiencing the issue still, but only in a multiplayer environment. Please see: 4.10.4 - Still getting crashes on level change (Multiplayer) - Multiplayer & Networking - Epic Developer Community Forums

Apologies if this isn’t the same issue, but it’s very close to what’s listed here so I can only assume it’s the same problem, given we didn’t have issues prior to 4.10.3.


Hi Agent,

Thank you for the update. After looking at the other thread, I believe these two may be separate errors. We have assigned a technician to look into the specific error you are seeing.

I am using level streaming and have a top level then sub-levels.
It goes fine from main menu(Sub-Level1) to Level1(Sub-level2) and vice versa but when I again do this the the Level1 doesnt load.
I even tried doing → Exec Stat Levels
Though both menu level and Level1 showed red i.e. they are loaded but the game doesnt progress further.