4.10.2 - imported mesh causing iOS build to crash

hey folks,

I have this strange bug when building for iOS. Works pretty flawlessly overall, until I include one mesh in particular. It’s an extremely simple capsule mesh that I’m slightly scaling in a blue print which is a visual for our ammo. I have two versions of this ammo mesh. One that’s three planes crossing each other which works great but creates overdraw. Then I have another mesh which is a solid capsule mesh to remove that overdraw cost. For some reason this second mesh is causing the game to crash on my device.

So basically I have two questions - is there any way to profile a game live from a device to see what’s going on and two - are there any known limitations to importing mesh objects when they’re to be used with iOS?

FYI - this is not the only mesh I’ve imported. It’s the only one giving me a problem.

thank you in advance!

Hey Floggins,

Could you provide me with some screenshots of your mesh, or the triangle/poly/vert count of the mesh you are experiencing issues with?

I am sure you aren’t exceeding the count, but just for your own insight we have some mesh limitations in place for mobile devices. All mesh types can have up to 65k vertices due to the lack of 32 bit index support on mobile hardware.

Content Creation- Mobile Platforms


If you are able to bring up the console command, there are a few console commands you could use to debug things like mesh draw count and simple stats. Try ‘stat unit’ and ‘stat scenerendering’ to get some statistics on your project.

Let me know if you have further questions.


Hi Andrew,

unfortunately the game never gets to that point. I get the splash screen and then it crashes before the level shows up, I imagine when it gets to the point of loading that data.

I did notice something interesting though - I decided to check in my data and do a build of the same data from my Mac to see if it would work. My guess was that Windows Unreal was just not building the asset properly for iOS. Sure enough, the build worked just fine. Curiously enough though, I created a new mesh with the same issue and same fix when built from OSX. Could this be an issue with how my FBX from Maya 2016 is being read in and built in either OS? Or is there a particular setting that needs to be set for iOS usage (that I may have set without knowing it with the other objects I have that worked)?

Try setting your .FBX file version type to 2014 or 2015 as this is the version we use and what we have found to be most compatible. I would say, I know you are working with perforce and alternating between Mac and PC which might be causing issues in itself.

I’m still unsure why that would cause issues though. I’m not syncing the built data, only imported uassets - which I guess could be part of the issue, but shouldn’t that be a bug if it was true? I mean, Unreal is created and sold as multi-platform game dev after all.

Do you have the crash logs and repro steps from the crash so I can investigate this issue further?

Please take a look at the How to Report a Bug post to get an idea of the information we will need and how to properly provide it to us.


unfortunately no, because it only crashes on the device. That’s why I was asking if there was a way to generate a log from the console.

What kind of device are you deploying to?

Take a look at this Troubleshooting Guide below for Mobile.

iPhone 6

Hi Andrew, so it turns out that I’m already exporting using FBX 2014/2015 within Maya 2016.

Could you provide me with the .FBX file so I can test it on my end?

there you go -

btw - I imported another mesh with the same results. Build crashes on the device when built from my pc but works fine when built from my mac.

I have looped in some other teammates to confirm this mesh causes a crash when packaged from PC to the device, since we do not have the iPhone 6 at this particular location.

Was the mesh originally imported into the project from the Mac, and was the project then synced to perforce from which you packaged and built to the device via the PC?

It was created and imported on PC. Then I checked it in p4 on that same machine. This results in the build crashing on the device. I checked in to see what would happen when building from the MAC. Synced up the project in p4 and did a build from there that worked just fine. I’m syncing builds at all. I’m building from the platform itself.

So I decided to go back to exporting FBX 2016 on my pc with one of my problematic meshes, and this time around it worked. I’ll keep doing tests to see what’s going on and keep you posted.

This seems to be a project specific issue that is somewhat difficult to track down. If you find new information, I would be glad to help.

Just wanted to put an update here -

So I got the problem again, and after some trial and error it seems that the solution to his has nothing to do with FBX at all and everything to do with the “saved” folder in the project. Something’s going on in there that causes assets to not build properly. It looks like it’s an error with when it builds the nav meshes. Some assets create errors (in my case - cooking errors). When I get the problem now, i delete that folder and everything works again.