User Tag List

Results 1 to 6 of 6

Thread: [blender to UE4]Problem with animations

  1. #1
    0
    Infiltrator
    Join Date
    Jul 2014
    Posts
    12

    Unhappy [blender to UE4]Problem with animations

    Hi there since one week i have a problem with a skeletal mesh i've made on blender with the animation when importing it in unreal engine 4. After research it seams that nobody has my problems.

    The animation is "crush" in blender at some points.
    The skeletal mesh:

    An exemple i mage with rigify tool in unreal engine 4.

    In blender the animation is working great with no problems.
    First I tought it was due to rigify so i decided to make my own rig and armature under blender.
    But i still have this problem...

    The animation in blender, no problems:

    And it is crushed in UE


    Of course sometimes the animation is working great when it is only an arm which is moving. But when i move the torso everything crushed in UE4(but not in blender, i repeat). I have also a problem with the foot, everything works great in blender and in UE it doesn't work good.

    The .blend : http://www.partage-facile.com/71142526H5/reiv8_idle.blend.html

    I'm using the last version of the fbx exporter, blender 2.71 and UE 4.2

    Thanks for your attention, hoping there is some guys using blender around here!
    PS: And a very important point, i'm learning and i'm new to UE and blender, i started few month ago

  2. #2
    0
    Infiltrator
    Join Date
    Jul 2014
    Posts
    12
    No idea? I've update to UE 4.3 and still same problem. When i do animation moving only one IK bones it's working great but when i'm moving more than one it's starting to crush.

  3. #3
    1
    In Blender, open up your Armature modifier and uncheck "Preserve Volume".

    Do you get the same type of crushing?

    If so, then you have the same problem I had: Unreal does not support Dual Quaternion Skinning (which is what Preserve Volume does, toggles the linear blend skinning to DQS) and this causes mesh breakdown.

    You'll have to re-rig your mesh with Preserve Volume OFF. Try to only parent vertices to two bones rather than many (or one bone if the object must remain rigid, like a helmet or shoulder pad or belt buckle or something), this prevents the kind of complex deformation math that collapses vertices. Also avoid twisting bones too far past each other, linear blend tends to narrow cylinders as one edge rotates.
    Last edited by RhythmScript; 07-27-2014 at 11:17 AM.

  4. #4
    0
    Infiltrator
    Join Date
    Jul 2014
    Posts
    12
    Preserve Volume is already uncheck :/
    What is dual quaternion skinning? Never heard of it, but i'm a newbie here in 3d modeling/animation.
    So if i've understand each vertices must be in maximum two vertex groups? I've just applied automatic weight and it seems that no vertices is in more than two vertex group. Is there somewhere i can be sure of that?

    Thanks for your answer by the way.

    I saw some problems in the armature when I display the bones in the UE skeletal mesh editor. It seem that bones move. They have to be connect to their parents it's maybe the cause of my problems, i hope it is... I'm going to try to fix it.



    Another problem i've seen it's that bones that bones who do not deform the mesh have been imported(i've checked "only deform bones" in the fbx exporter)

  5. #5
    0
    Infiltrator
    Join Date
    Jul 2014
    Posts
    12
    Hi i'm coming back with my problem. The crush problem is fix, it seems that unreal engine does not support the keep offset in bones hierarchy, i added bones with deform option disable when i had a keep offset, but i still have problems with bones placement:
    For my character:
    Screenshot in ue: http://www.hostingpics.net/viewer.php?id=587903captureue4.png
    And the same thing in blender: http://www.hostingpics.net/viewer.php?id=445765capturebeldner.png

    And with a simple horrible stickman: http://www.hostingpics.net/viewer.php?id=860350captureue4.png
    http://www.hostingpics.net/viewer.php?id=150667capturebeldner.png

    A lot of people have done videos on youtube with armature in blender to UE4 so I don't know why it doesn't work for people because i'm doing the same thing. Maybe i've check a wrong option somewhere in blender?

    I'm using blender 2.71 with the last FBX exporter and UE 4.3

    Thanks a lot for answer!

  6. #6
    0

    Talking

    Quote Originally Posted by RhythmScript View Post
    In Blender, open up your Armature modifier and uncheck "Preserve Volume".

    Do you get the same type of crushing?

    If so, then you have the same problem I had: Unreal does not support Dual Quaternion Skinning (which is what Preserve Volume does, toggles the linear blend skinning to DQS) and this causes mesh breakdown.

    You'll have to re-rig your mesh with Preserve Volume OFF. Try to only parent vertices to two bones rather than many (or one bone if the object must remain rigid, like a helmet or shoulder pad or belt buckle or something), this prevents the kind of complex deformation math that collapses vertices. Also avoid twisting bones too far past each other, linear blend tends to narrow cylinders as one edge rotates.
    This is the single most important information I've read about the Blender to UE4 workflow. "Preserve Volume" in the Armature Modifier is not preserved during FBX export. I wish there was some way around this (other than using corrective shapekeys). Thanks RhythmScript for this super helpful post!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •