Announcement

Collapse
No announcement yet.

C4d to Unreal Maintain Texture Map and Alpha

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    C4d to Unreal Maintain Texture Map and Alpha

    Hi all, I am using using Datasmith to import models from c4d. In c4d, I am using a logo loaded into the Alpha channel, cubic projection. I save the c4d file as melange, and load it into Unreal, and I get just a solid black color where the logo alpha image is supposed to be. I tried remaking the alpha logo in Unreal and loading it into the respective Static Mesh Material element slot, bit it is not projected correctly. Does anybody know if there is a way to retain the projection settings and orientation of a material when using datasmith for c4d files? Thanks in advance!



    Original c4d model and material orientation (Square projected texture with alpha channel):

    Click image for larger version

Name:	c4D image.JPG
Views:	163
Size:	150.0 KB
ID:	1805823





    Object in Unreal after Datasmith import:

    Click image for larger version

Name:	Unreal Image 2.JPG
Views:	112
Size:	17.2 KB
ID:	1805824





    Object after trying to load new material into Static Mesh material slot

    Click image for larger version

Name:	Unreal Image.JPG
Views:	111
Size:	17.8 KB
ID:	1805825

    #2
    Jacob del Nero


    For the warped texture part, you probably have to create UV coords from that square projection to get the material into positon.



    For the actual alpha texture, I once was able to get this working like it was in C4D, but this required two things:

    - an altered material in UE, because for some reason, the UE default material that is created during import, didn´t work very well with Alphas, so i had to reconnect and change some things in the master material.
    - Material Layers... a still Beta feature, that solved big problem, if you got the first step working, however, in UE 4.24 and 4.25 it´s so buggy, that UE instantly crashes, as soon as i just look at my material layers or one of it´s required components, like the Layer blend functions. Sooo.... i am completely unable to use or even open them right now ^.^

    https://docs.unrealengine.com/en-US/...ers/index.html

    Forum thread, as it is announced to come back with 4.26, so there is hope to get it working again:

    https://forums.unrealengine.com/deve...19#post1805959

    The main problem, that happened, and which Material Layers fixed, was, as soon, as i had the Alpha working as intended (it worked with translucent mode, as masked was unable to give smooth gradients for semi transparent areas in textures), that it did not blend with the underlying main material. So my objects had overall the main material, f.e. metal, or glass in your case, and whereever the alpha texture with logo etc was, there was only that logo, and then just a cut out hole for the rest of the alpha texture.
    Material Layers wee able to close those holes with the underlying main material, as you would expect from an Alpha texture.

    I hope, 4.26 fixes layers, would solve several problems. Ok, Maerial Layers would still require some work (f.e. converting your materials to Material Layers, then assign those to all objects), but it might be worth it.

    Comment

    Working...
    X