Announcement

Collapse
No announcement yet.

Surfaces without smoothing / Phong after Import into UE4 from C4D

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Surfaces without smoothing / Phong after Import into UE4 from C4D

    Hi, to you all professionals!

    My name is Markus and i am new here with a small problem.

    I really love Datasmith, a dream comes true, cause now i can insert my models to UE4 without big problems.

    But one thing is strange with one of my objects. When i import this telescope into UE4, the phong tag on the cubes are missing :-(

    I dont know why but no matter how i export or convert it to ground object, everytime i get the same result. When creating a tube in the cinema 4d telescope scene and importing it with datasmith, it is showed normal, only the tubes for the telescope has these problems.

    I tried changing the name of the tubes, creating new phong tag, etc., merg it (convert to ground object) Please help me.

    Best Regards and thank you soo much from Germany, Markus
    Last edited by matrixxp89; 06-18-2020, 10:37 AM.

    #2
    We discussed this matter via PN in German, but in case anyone else runs into this problem:

    The reason for this can be found in the Mesh Editor under build settings.
    By default on import with Datasmith the normals and tangents are recomputed.
    Uncheck the recompute normals and recompute tangents checkboxes and apply changes, to solve the issue.

    While the fbx importer has an option for this in the import dialog box, datasmith doesn't have this.
    But it seems that after changing the settings like above, the new settings are applied to future datasmith imports as well.

    Comment

    Working...
    X