Announcement

Collapse
No announcement yet.

ISSUE - Unable to import Solidworks 2020 parts with Datasmith

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Did you ever figure this out?

    I have this issue too with some of the files I'm trying to import. I am able to import the files fully in Maya using the SimLab, but in Unreal I receive warnings in the Output Log that says
    LogDatasmithDispatcher: Warning: file not found: <redacted_file_name>.SLDASM
    Some files it's missing more than others. It's confusing as to what the cause is, because some of the model comes in, but some does not. I know I'm flying blind without being able to get into Solidworks, but I am able to vet the models with the SimLab plugin I'm evaluating.

    CMTech, do you know how I can check the version of the Solidwork file without having a Solidworks license?

    Leave a comment:


  • ISSUE - Unable to import Solidworks 2020 parts with Datasmith

    Hi,

    Not sure if this is the right place to post this but this is the issue...

    Using UE4.24.1 I imported a Solidworks assembly and some of the parts didn't come through (fasteners etc.). Tried importing again individual parts and nothing came through. Tried making a new part again in Solidworks 2020 and importing that.. still nothing came through. Made the same part in Solidworks 2019 and imported part with no issue.

    If there is a way to fix this would be great as when it works it works great for importing complex assemblies. Solidworks doesn't allow opening 2020 files in 2019 so we are a bit stuck at the moment. Will try exporting to a different format then import that, but will add an extra step.

    Thanks

    Mike
Working...
X