Announcement

Collapse
No announcement yet.

Asset “None”

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Asset “None”

    Hi, I have an a warning in output log:
    1. LogClass: Warning: In asset 'None', there is an enum property of type 'EDepthOfFieldMethod' with an invalid value of '('

    How to find this asset "None" to check his problem? I never created such.

    It is not listed in World Outliner, or any onther statistics.

    Please advice.

    (I'm using blueprint UE4 version, I'm not programmer.)


    #2
    I also have this warning come up. I have no idea how we're supposed to fix it.

    Comment


      #3
      We found the culprit in the collab template and that might be in another as well.

      The DefaultEditor.ini has a string like this: "DepthOfFieldMethod=(INVALID)". You can fix it by either editing it or changing the StaticMesh Editor environment settings to use another profile.

      We fixed it on our end.
      Pierre-Felix Breton

      Sr Technical Product Designer AEC, Unreal Engine
      Epic Games - LinkedIn

      Comment


        #4
        Originally posted by pf_breton View Post
        We found the culprit in the collab template and that might be in another as well.

        The DefaultEditor.ini has a string like this: "DepthOfFieldMethod=(INVALID)". You can fix it by either editing it or changing the StaticMesh Editor environment settings to use another profile.

        We fixed it on our end.

        Pierre,
        thank you.

        I did delete "DepthOfFieldMethod=(INVALID)" in the DefaultEditor.ini, hope this is what you meant.

        Where exactly is that StaticMesh Editor environment setting to change profile, could not find it?

        all the best

        Comment


          #5
          What i meant is that ini setting is defining what you see here:

          https://www.screencast.com/t/gvbqW9phlH

          In the development of 4.24 that ini section got corrupted somehow.
          Pierre-Felix Breton

          Sr Technical Product Designer AEC, Unreal Engine
          Epic Games - LinkedIn

          Comment


            #6
            O yes :-) thank you

            Comment


              #7
              pf_breton
              Pierre-Felix can you help me on an other on. I running building light map from command line. Starts well but after beginning I have this info on the log, and it stops?

              Code:
              ....
              [2019.12.13-13.57.58:467][ 0]LogDerivedDataCache: Display: Loaded Boot cache: C:/Users/ignac/AppData/Local/UnrealEngine/4.23/DerivedDataCache/Boot.ddc
              [2019.12.13-13.57.58:490][ 0]LogDerivedDataCache: Display: Pak cache opened for reading ../../../Engine/DerivedDataCache/Compressed.ddp.
              [2019.12.13-13.57.58:497][ 0]LogDerivedDataCache: Display: Pak cache opened for reading ../../../Enterprise/DerivedDataCache/Compressed.ddp.
              [2019.12.13-13.58.31:147][ 0]LogContentCommandlet: Display: Loading
              [2019.12.13-13.58.31:148][ 0]LogPackageName: Error: DoesPackageExist: DoesPackageExist FAILED: 'None' is not a standard unreal filename or a long path name. Reason: Path should start with a '/'
              [2019.12.13-13.58.31:148][ 0]LogUObjectGlobals: Warning: Failed to load '': Can't find file.
              [2019.12.13-13.58.31:216][ 0]LogContentCommandlet: Display: [REPORT] 0/1 packages required resaving
              [2019.12.13-13.58.31:216][ 0]LogInit: Display:
              [2019.12.13-13.58.31:217][ 0]LogInit: Display: Warning/Error Summary (Unique only)
              [2019.12.13-13.58.31:217][ 0]LogInit: Display: -----------------------------------
              [2019.12.13-13.58.31:217][ 0]LogInit: Display: LogPackageName: Error: DoesPackageExist: DoesPackageExist FAILED: 'None' is not a standard unreal filename or a long path name. Reason: Path should start with a '/'
              [2019.12.13-13.58.31:217][ 0]LogInit: Display: LogUObjectGlobals: Warning: Failed to load '': Can't find file.
              [2019.12.13-13.58.31:217][ 0]LogInit: Display:
              [2019.12.13-13.58.31:217][ 0]LogInit: Display: Failure - 1 error(s), 1 warning(s)

              Comment


                #8
                Originally posted by pf_breton View Post
                We found the culprit in the collab template and that might be in another as well.

                The DefaultEditor.ini has a string like this: "DepthOfFieldMethod=(INVALID)". You can fix it by either editing it or changing the StaticMesh Editor environment settings to use another profile.

                We fixed it on our end.
                Hi,
                I'm having same issue. So what do I need to do with that (INVALID) in the
                DefaultEditor.ini, just add a number?
                Raed Abbas
                Multiplayer Game System (MGS) | Nice Inventory System | Nice Lobby System
                Dynamic Shared Camera


                IMDB
                FACEBOOK

                Comment


                  #9
                  Originally posted by pf_breton View Post
                  We found the culprit in the collab template and that might be in another as well.

                  The DefaultEditor.ini has a string like this: "DepthOfFieldMethod=(INVALID)". You can fix it by either editing it or changing the StaticMesh Editor environment settings to use another profile.

                  We fixed it on our end.
                  Editing it to what exactly? I've got this issue present on 4.23.1

                  Comment


                    #10
                    I added "DepthOfFieldMethod=DOFM_CircleDOF" to my projects DefaultEditor.ini this fixed it for me! thx @pf_breton
                    to the others, you could also try to set it to one of these
                    DOFM_BokehDOF,
                    DOFM_Gaussian,
                    DOFM_CircleDOF,
                    DOFM_MAX,

                    Comment


                      #11
                      Originally posted by pf_breton View Post
                      We found the culprit in the collab template and that might be in another as well.

                      The DefaultEditor.ini has a string like this: "DepthOfFieldMethod=(INVALID)". You can fix it by either editing it or changing the StaticMesh Editor environment settings to use another profile.

                      We fixed it on our end.
                      Not work with shipping and with developmentEditor - still have the warning:

                      "LogClass: Warning: In asset 'None', there is an enum property of type 'EDepthOfFieldMethod' with an invalid value of '('"

                      Somethink overrides with (INVALID) in the DefaultEditor.ini each time when run the UE4Editor!!!
                      The mistake is maybe in "Enum.cpp", "EnumProperty.cpp", or in "PropertyByte.cpp")
                      UE4.23
                      Last edited by Angel Tsvetkov; 02-13-2020, 01:24 PM.
                      Luxocraft - [FREE] 3D Ray Tracing Block Construction Builder Game on Steam

                      Comment


                        #12
                        Originally posted by RenéB View Post
                        I added "DepthOfFieldMethod=DOFM_CircleDOF" to my projects DefaultEditor.ini this fixed it for me! thx @pf_breton
                        to the others, you could also try to set it to one of these
                        DOFM_BokehDOF,
                        DOFM_Gaussian,
                        DOFM_CircleDOF,
                        DOFM_MAX,
                        I have tried this, it did not fix the issue.

                        Comment

                        Working...
                        X