Announcement

Collapse
No announcement yet.

Corruption of Custom UV's Datasmith 4.23

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Corruption of Custom UV's Datasmith 4.23

    Hi,

    We're having some serious issues with UE4.23 with Datasmith and custom lightmaps. We're experienced in using datasmith and have only recently encountered issues. Although they've now become critical i'd say we first noticed this behaviour on some objects in 4.22.

    In short if we create custom lighmaps in 3DS Max they don't seem to make it across to UE (sporadically on some objects but not others), what's odd is the lightmap density preview in the editor appears to display the correct maps (can't be 100% sure but they look clean) however if you look in the mesh editor they're an overlapping mess and they bake as such. What's particularly annoying is because the maps look clean in the preview we would have to open every single mesh to check if they have an issue.

    See images below.

    Wondering if anyone else has experienced the same thing and/or if they have a fix.

    Just to clarify we're changing lightmap coordinate index post export.


    Last edited by SkitzFritz84; 09-12-2019, 05:26 AM.

    #2
    Update:

    Have tried a completely new scene, exported using the Datasmith Attributes modifier in 3DS Max with no warnings. However the objects that were encountering issues now present in the mesh editor of UE with only a single UV channel, other objects in the scene have all imported fine.

    Tried the standard UE FBX import pipeline and the objects all import without issue, UV's intact.

    Comment


      #3
      must be datasmith not exporting proper UV channel info of that particular object.
      Youtube - https://www.youtube.com/channel/UCHY...97QaoBbllHR4_g
      Behance - https://www.behance.net/UE4_Archviz

      My System
      Cpu - i9 7980XE
      MB - Asus X299 Pro Se Motherboard
      Gpu - Zotac GTX1060 AMP 6GB DDR5 Graphic Card
      Ram - Corsair Dual RGB 32 GB
      SSD - Samsung 860 EVO 2TB SSD

      Comment

      Working...
      X