Announcement

Collapse
No announcement yet.

How do I switch to GameNetworkManager's dynamically managed bandwidth system?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How do I switch to GameNetworkManager's dynamically managed bandwidth system?

    For some reason when I clicked post it did not post and my work got deleted so I'm going to make this short.
    Currently my server is using this method of bandwidth settings/restrictions which ultimately requires every client to edit their engine.ini to reach my goal. There are NO options for the server to force a minimum bandwidth limit.

    Player's set bandwidth limit in byte/s
    [/Script/Engine.Player]
    ConfiguredInternetSpeed=15000
    ConfiguredLanSpeed=20000

    Server's restriction of player's set bandwidth limit in byte/s
    [/Script/OnlineSubsystemUtils.IpNetDriver]
    MaxClientRate=15000
    MaxInternetClientRate=15000

    I would like to use the game network manager's system of dynamically managed bandwidth so that only the server has to edit settings.

    Total bandwidth limit of the server, and MINIMUM and maximum bandwidth limit of each client set by the game network manager. in byte/s
    [/Script/Engine.GameNetworkManager]
    TotalNetBandwidth=
    MaxDynamicBandwidth=
    MinDynamicBandwidth=

    I hope you do plan to add MinClientRate and MinInternetClientRate settings in the future. As somebody will very slow internet I would rather suffer udp offholds from having my bandwidth limit forced too high than see all other clients, and the server owner, choked by a default bandwidth limit that is too low.

    The game (ARK) does not plan to update the version of the UE4 it's using.
    How do I tell my server to use the game network manager's method of bandwidth limitation instead of the default?

    #2
    Sorry everyone. It turns out that the GAME network manager was in the game.ini not the engine.ini

    Now I just have to run tests on my server.

    Comment


      #3
      Originally posted by ELKR333 View Post
      Sorry everyone. It turns out that the GAME network manager was in the game.ini not the engine.ini

      Now I just have to run tests on my server.
      Did it work?

      Comment


        #4
        From testing, it appears that the below lines must go into DefaultGame.ini and NOT DefaultEngine.ini:
        PHP Code:
        [/Script/Engine.GameNetworkManager]
        TotalNetBandwidth=
        MaxDynamicBandwidth=
        MinDynamicBandwidth

        Comment

        Working...
        X