Announcement

Collapse
No announcement yet.

Play Mode: How to hide the sphere from the Spectator?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Play Mode: How to hide the sphere from the Spectator?

    I would need a step by step instruction how I can make sure, that the sphere that appears when activating the play mode disappears.

    I found some answers to create a new spectator pawn, exchanging the new spawn with the old one and also changing the project settings.
    I just can't figure out how to do it properly step by step.

    Is there any documentation that explains how to setup the new pawn blueprint?
    Plus all additional steps required to make sure the new pawn behaves like the original one?

    I just want to make sure that the sphere is NOT visible, once you are in the play mode.
    Is there any other simple solution for that?

    I also checked "Actor Hidden in Game" - but that didn't work and the sphere is still visible.

    Thanks for any little help,
    appreciate it!

    #2
    For me it was as simple as:
    • creating a new game mode
    • selecting 'None' in 'default pawn' drop-down in that game mode's details panel
    • setting this game mode as default in map's world settings panel
    You could use your existing game mode and, as long as you set the 'default pawn' to 'None' or your own character, the spectator sphere should disappear.

    Comment


      #3
      I also have this problem, not only with cameras, but also with lights and other actors, this grey sphere appears all over my scene during sequences, and creating a game mode doesn't hide those spheres.

      I really don't understand why Unreal creates this spheres for actors in sequences... there is no function for them... they don't even appear in the editor as you work, why adding them to sequences to just ruin the scene.

      Comment

      Working...
      X