No announcement yet.

Datasmith - AutoCad DWG import - model is mirrored

  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    We haven't spent more time on DWG import in 4.23.

    Leave a comment:

  • replied
    Any movement on this at all? Haven't tried the 4.23 importer, but 4.22 still seems to have the same issue.

    Leave a comment:

  • replied
    Hello Pierre-Felix

    thanks for the quick reply.

    Good that you are aware of the issue. Hopefully you will fix this soon, as I much prefer working in AutoCad (I actually really dislike the modeling in Sketchup) and only use Sketchup for the rendering.

    So looking forward to the hopefully soon coming update addressing this. Once the direct import from AutoCad works the intermediate step of Sketchup would be omitted. In the meantime I will grumbling use Sketchup "translation" ;-)

    Thanks again.


    Leave a comment:

  • replied

    You are right. Its not very usable at the moment. Since you are using Sketchup, I suggests that you use this as a bridge since we have spent much more time into making sketchup reliable, support instancing etc.

    Leave a comment:

  • Datasmith - AutoCad DWG import - model is mirrored


    I have been trying to import AutoCad DWG (version 2010) with Datasmith.

    The model imports, but it is mirrored.
    For illustration I made a simple house in AutoCad:
    Door on left, window on right.

    After the Datasmith import the the house in Unreal engine has the door on the right and the window on the left.

    Attached screenshots of both programs. I also atached the DWG file.

    My suspicion is that AutoCad has a right handed coordinate system and Unreal a left handed - (x and y are orientated differently in both programs).
    (See the different UCS icons in the screenshots)
    If the coordinates are imported into a flipped system 1 to 1 this results in a mirrored model.

    Is there somewhere a setting which can mirror 1 of the coordinates (is it an undiscovered bug)?



    P.S. if I Export the AutoCad model to Sketchup and then import that file, it comes to Unreal Engine the right way round.
    Attached Files