Announcement

Collapse
No announcement yet.

Different kinds of VR lag in both Product Viewer and Multi User template

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Different kinds of VR lag in both Product Viewer and Multi User template

    All of what I am reporting here can easily be seen by just creating a new project with each template. I'm running 4.21.1 on an Omen laptop with 32gb ram and 1070 graphics card + HTC Vive.

    1. Product Viewer Vive controller lags significantly behind in its tracking. The laser pointer on one of the controllers actually keeps up better. This is easily verified by bringing up the SteamVR Overlay and moving the controller around, comparing the Steam foreground to the Unreal background.

    2. Multi Viewer Vive view lags significantly behind in its tracking. This makes the multi viewer template unusable due to instant nausea. This doesn't happen in the product viewer or standard VR template. Again, it's easily verified by comparing it to the SteamVR overlay.

    It's weird that nobody else has reported this, because it's really major and easily noticeable, which makes me worry that it's this laptop I'm currently on, but everything else, including other Unreal templates, work fine...

    #2
    Sometimes, the SteamVR plug-in updates (not in our control) and creates problems. Double-check that.
    Sr. Product Manager
    Epic Games

    Comment


      #3
      Yes, maybe that is true, because when I made my own VR pawn from scratch, I noticed that the linetrace from the VR controller actually lagged behind the VR mesh itself, so perhaps in the Productviewer blueprint, the VR controller mesh use the linetrace result, I don't know.

      Also, I found an error in the Multiviewer blueprint when I went looking, so that's perhaps also why I'm seeing issues in it:

      Click image for larger version  Name:	Capture.JPG Views:	1 Size:	51.4 KB ID:	1569811

      Either way, as I said, I made my own VR pawn right now, and it has none of the issues I'm seeing with the Studio templates.

      Comment


        #4
        Can you report?


        If the issue you are experiencing doesn't match with one of the known issues logged here: https://issues.unrealengine.com/issu...mponent=&sort=

        Then please file a new bug report for our staff to investigate here: https://unrealstudiohelp.epicgames.c...community-page
        Sr. Product Manager
        Epic Games

        Comment


          #5
          Originally posted by roberteker View Post
          All of what I am reporting here can easily be seen by just creating a new project with each template. I'm running 4.21.1 on an Omen laptop with 32gb ram and 1070 graphics card + HTC Vive.

          2. Multi Viewer Vive view lags significantly behind in its tracking. This makes the multi viewer template unusable due to instant nausea. This doesn't happen in the product viewer or standard VR template. Again, it's easily verified by comparing it to the SteamVR overlay.

          It's weird that nobody else has reported this, because it's really major and easily noticeable, which makes me worry that it's this laptop I'm currently on, but everything else, including other Unreal templates, work fine...
          Thank you for your report.

          Can you please give me your hardware specs you're using : Oculus / HTC ?
          Can you run an Empty scene in this project and test with your VR Headset ?
          Do you do any change in the Multiplayer project ?

          Thank you.

          Marien

          Comment


            #6
            I'm experiencing the same problem with the multi viewer template, with 4.24.2 and HTC Vive. So the fix is to rebuild the VR Pawn?

            Comment

            Working...
            X