Announcement

Collapse
No announcement yet.

[SOLVED] Unreal don't see Visual Studio 2017

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Unreal don't see Visual Studio 2017

    I installed Visual Studio 2017, but Unreal don't see it. When i install 2015 Unreal sees it, but i need the 2017 Version.
    I have an issue with the registry key...How can i fix this?
    The others with15.* are empty too...only in 14.* there are entries.

    I found here something, but i don't know what to do:
    https://answers.unrealengine.com/que...to-change.html
    I got not these errors. igot, that unreal wants me to install visual studio, but it is allready.

    Can't create c++ Classes/Projects

    The Build is successfull: See Picture

    My Visual Studio Version: See Picture

    My C++ Version: See Picture

    where is this variable, and have it something to do with my problem? Have i problems with variables?
    %VsComnToolsPath%

    Global Variable is set: See Picture

    See the Pictures...there is my Project Settings for UE4 Source Build

    See Picture: My Folders on C:
    Last edited by MilliElektra; 08-25-2018, 12:21 PM.

    #2
    Yes, i really got a problem, and i don't know how to solve it...I deleted visual studio again with InstallCleanup.exe -full, i deleted folders that where left. The Installationfolder, the AppData Folder, the ProgramData Folder. I deleted the registry keys. Than i installed visual Studio from the supported Side.
    Unreal don't see it.
    When i run Generated.bat -2017 cmd says that visual studio is not installed. Than it tries to install with visual studio 2015, which is not installed.
    Here are the Pictures from gegedit. Only what you see is there. All the othher Folders are empty.

    Edit: when i try to run UnrealVS.vsix, than nothing happens. The cmd pops up extremly short. Than it closes again.
    I set the Environment Variable VS150COMNTOOLS (see picture)
    I installed Buildtools for 2017. Than a Folder 14.0 where created..i set the Variable VS140COMNTOOLS

    The Problem is with the registry Keys...
    Last edited by MilliElektra; 08-26-2018, 05:13 AM.

    Comment


      #3
      I found this: https://docs.microsoft.com/en-us/vis...7?view=vs-2017


      Visual Studio registry
      • Previously, Visual Studio installed many registry keys into the system's HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER hives under a Visual Studio-specific key:
        • HKLM\Software\Microsoft\VisualStudio{Version}: Registry keys created by MSI installers and per-machine extensions.
        • HKCU\Software\Microsoft\VisualStudio{Version}: Registry keys created by Visual Studio to store user-specific settings.
        • HKCU\Software\Microsoft\VisualStudio{Version}_Config: A copy of Visual Studio HKLM key above, plus the registry keys merged from .pkgdef files by extensions.
      • To reduce the impact on the registry, Visual Studio now uses the RegLoadAppKey function to store registry keys in a private binary file under [VSAPPDATA]\privateregistry.bin. Only a very small number of Visual Studio-specific keys remain in the system registry.
      • Existing code running inside the Visual Studio process is not impacted. Visual Studio will redirect all registry operations under the HKCU Visual Studio-specific key to the private registry. Reading and writing to other registry locations will continue to use the system registry.
      • External code will need to load and read from this file for Visual Studio registry entries.

      there are these changes in Visual Studio, so there is no problem with the registry keys...but where is the problem?
      Please help!

      Comment


        #4
        i will wait for an answer, and i will not delete this topic. This is a big issue...

        Comment


          #5
          Not sure what the problem is exactly but try running VsDevCmd.bat.
          \Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\Tools\VsDevCmd.bat

          Comment


            #6
            Thank you! ...I allready tried this.
            Now i setup up my computer completely new...i wil tell soon, if this finally works...

            Comment


              #7
              Wow...f..k... this was work! This really had to work, or i would ...????!!!

              IT WORKS...I installed the whole computer new...
              than visual studio 2017...with the installer, than from the laucher...Unreal 4.20.2 ...and it sees visual studio 2017!!!

              Now i hope it works with the source build too, and i can go on...puh...

              Comment


                #8
                Yeah! Everything is fine now! It works better than ever. Hotreload have no problems!

                Comment


                  #9
                  I know this is quite an old post, but I came across this recently due to having a new PC and it took me a while to work out what was causing the issue.

                  Essentially because Microsoft now no longer write Visual Studio registry keys to the system registry (As described in the link provided by MilliElectra) the code which searches for your local install is no longer correct. However it works fine if you have ever installed an older version of Visual Studio (or the community version it seems).

                  So if you're using Visual Studio Professional like I am you will need to add a registry key manually to get around it. Here are the steps I used:

                  1) Click on the Windows Start button and type run and hit enter
                  2) Execute this line %systemroot%\syswow64\regedit.exe.
                  3) Browse to this key location in the registry editor:

                  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\SxS\VS7

                  If that location doesn't exist, you need to create it.

                  Then create or edit a key called 15.0 and set its value to the path to your local Visual Studio install directory. So for example mine is set to:

                  "C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional"

                  Click image for larger version

Name:	CorrectReg.jpg
Views:	6650
Size:	113.8 KB
ID:	1591149

                  Once this is done, the dialogue no longer appears.

                  It would be ideal if Epic actually fixed the code properly though, instead of needing to do this....hint hint Epic!

                  Comment


                    #10
                    Thanks for your post MichaelBibby! It's 2019 now and I had the same Problem with UE 4.21.1 and Visual Studio 2017 community/enterprise editions.

                    In my case I switched from Visual Studio 2017 Community Edition to the Enterprise Edition. The community edition creates the registry key HKLM\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\SxS\VS7\15.0 with a path to it's install directory. But when I uninstalled the community edition the registry key wasn't removed. And when you install the Enterprise Edition it doesn't update the registry key (nor creates a new one where Unreal looks). So UE4Editor.exe still looks for Visual Studio in the (now empty) path of the old community edition. Of course the Enterprise Edition isn't there and the editor doesn't find Visual Studio.

                    To fix it I deleted the key HKLM\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\SxS\VS7\15.0 and created a the new key HKCU\SOFTWARE\Microsoft\VisualStudio\SxS\VS7\15.0 which contains the path to the enterprise edition (in my case "C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise"). Then it worked. I didn't test just updating the old registry key so that might work as well.

                    The full story:
                    • First installed VS2019 community edition because I couldn't find an installer for VS2017. Of course UE4 couldn't use it.
                    • VS2017 community edition didn't work because whoever used my system before me used up the 2 week trail license. So UE4 couldn't use it as well.
                    • Finally got the VS2017 Enterprise edition from my company. Uninstalled VS2017 community edition and installed VS2017 enterprise edition.
                    • UE4 now couldn't find the enterprise edition. At this point I started to get mad.
                    • Tried a few other desperate things, then found MichaelBibbys post above, tried it and it didn't work. Got really mad.
                    • Downloaded SysInternals Process Monitor (https://docs.microsoft.com/en-us/sys...nloads/procmon). With this you can log all registry activities from windows programs. Filtered the registry access to processes named UE4Editor.exe and then started the Unreal Editor.
                    • UE4Editor.exe does a whole lot of registry stuff. Filtered it down to all keys that contained "SxS" or "VisualStudio". That way I could see at which registry paths Unreal looks for Visual Studio. That way I also saw that VS2017 community edition didn't delete it's old registry key HKLM\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\SxS\VS7\15.0 and that UE4Editor.exe read the path from there.
                    • UE4Editor.exe first looks for the registry key HKCU\SOFTWARE\Microsoft\VisualStudio\SxS\VS7\15.0. So I created it with the path to the VS2017 enterprise edition. And it finally worked!
                    Only took me about two days. Maybe I just had bad luck. I guess everyone else just installed Visual Studio years ago (2015) and updated ever since. Or stuck to the community edition. Or just randomly tried stuff (including reinstalling Windows) until it worked. Seriously, installing Linux and compiling C code was way easier than getting UE4 and VS2017 enterprise edition to work (debugging and fixing the above mess). A documented configuration option to select the path to Visual Studio would have saved me a lot of frustration...

                    I just hope this post spares someone else from having the same bad days.

                    Comment


                      #11
                      Same type of issue, I tried all of the above... except formatting...

                      First install of UE4 crashed on computer #1 (dev machine), so switched computer #2 and also Visual Studio 2019 Community; since this machine was never used to do any dev stuff.

                      Everything seems ok, exception that the is no way to link UE4 to VS2019, did the registry trick, still nothing. By default tho, ALL the others VS years editions show up in the source editor options, while none of those ever got installed on this computer.

                      Up to this point, using Memaker on a Comodre XT to have 639k free RAM while keeping the CD-ROM accessible since the 24MB hard drive can't hold the data to run a game is WAY easier than getting UE4 to run with VS2019...

                      Any creative pointer that are not trying on a third computer or formatting would be appreciated.

                      Comment


                        #12
                        Was a solution found for this? I have tried everything above and had no luck.

                        Comment


                          #13
                          Wow. I spent 2 days trying to get this to work. I followed Stephan Soller Instructions to the T and finally figured out. For some reason 4.24.1 only tries to access:

                          HKLM\SOFTWARE\Microsoft\VisualStudio\SxS\VS7\12.0
                          and
                          HKLM\SOFTWARE\Microsoft\VisualStudio\SxS\VS7\14.0

                          It never even tries 15.0 even when I set it to look for vs2017.

                          After re-doing the keys, restart the editor, that fixed it for me.. finally...

                          I'll make a youtube video on how to fix this probably because it sucks to encounter, Epic please fix this.

                          Click image for larger version  Name:	unrealcodefix1.png Views:	0 Size:	360.5 KB ID:	1702138Click image for larger version  Name:	unrealcodefix2.PNG Views:	0 Size:	40.2 KB ID:	1702139
                          https://jollyrogerstudios.net/

                          Comment


                            #14
                            It seems like those didn't help for my newer version of VS 2019 Community. The solution is more simple than the registry hack. Find it published by Epic, here: https://docs.unrealengine.com/en-US/...lVS/index.html

                            Comment


                              #15
                              Originally posted by JonathanArmstrong View Post
                              It seems like those didn't help for my newer version of VS 2019 Community. The solution is more simple than the registry hack. Find it published by Epic, here: https://docs.unrealengine.com/en-US/...lVS/index.html
                              You're the best.

                              Comment

                              Working...
                              X