Announcement

Collapse
No announcement yet.

4.20.1 - Static Mesh Editing Changes not saved

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    4.20.1 - Static Mesh Editing Changes not saved

    When I make edits to a static mesh (migrated from an earlier version of Unreal) they aren't persisted when I reload the project, even after saving everything.

    There's nothing in the log indicating anything odd other than lots of:

    Code:
    LogEditableMesh: Verbose: DeletePolygons returned
    LogEditableMesh: Verbose: DeletePolygons: [45236]
    LogEditableMesh: Verbose: DeleteVertexInstances: [135708, 135709, 135710]
    LogEditableMesh: Verbose: DeleteVertexInstances returned
    LogEditableMesh: Verbose: DeleteEdges: [67864, 67862, 67863] true
    LogEditableMesh: Verbose: DeleteOrphanVertices: [22557, 22561, 22559]
    LogEditableMesh: Verbose: DeleteOrphanVertices returned
    LogEditableMesh: Verbose: DeleteEdges returned
    LogEditableMesh: Verbose: DeletePolygons returned
    LogEditableMesh: Verbose: DeletePolygons: [45223]
    LogEditableMesh: Verbose: DeleteVertexInstances: [135669, 135670, 135671]
    LogEditableMesh: Verbose: DeleteVertexInstances returned
    LogEditableMesh: Verbose: DeleteEdges: [67824, 67841, 67842] true
    LogEditableMesh: Verbose: DeleteOrphanVertices: [22550, 22555, 22549]
    LogEditableMesh: Verbose: DeleteOrphanVertices returned
    LogEditableMesh: Verbose: DeleteEdges returned
    LogEditableMesh: Verbose: DeletePolygons returned
    Edit: I managed to get the changes to persist by toggling "Compute Normals" for LOD0 (the only one for this mesh) and hitting build.
    Edit2: Forcing an LOD rebuild worked once but now either causes a crash or reverts all the edits.
    Last edited by rokel_race; 08-14-2018, 11:11 AM.

    #2
    It sounds like you are hitting a known issue - https://issues.unrealengine.com/issue/UE-61612

    It is fixed in the next upcoming update, which should be released soon.
    Stephen Ellis | Senior Engine Coordinator

    Comment


      #3
      Great, thanks Stephen! I also found that the keyboard shortcut for Delete in edit mode doesn't working, but that might be a peculiarity of my setup.
      Being able to box select elements would also be very useful.

      Comment

      Working...
      X