Announcement

Collapse
No announcement yet.

3dsMax Vray to UE4 via Datasmith = lights too bright

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    3dsMax Vray to UE4 via Datasmith = lights too bright

    Starting to dabble with UE4 since they announced Datasmith. First main problem is that it comes into UE4 way too bright. Anyone know why? Can do a PostProcessVolume to get exposure down, but would like to figure out everything the right way. Also, all my SelfIlluminated maps come in dark or black.

    Thanks - Chris

    UE4 - 4.19
    3dsMax 2016

    #2
    I'd also like a solution to this. I have to dial lights back after import from something like 30000000 back to 10 for intensity... Thanks!

    Comment


      #3
      I get the same issue with Corona.
      George Rolfe.
      Technical Coordinator at Orbit Solutions Pty Ltd.

      Comment


        #4
        I think you'll need to divide the intensity by 10000 or something. I think the problem is they made a mistake with the physical light intensity unit. At least when I tested it a while ago. They seem to be using the old "Unitless" value as "Candela".

        Comment


          #5

          Report Unreal Studio bugs here: https://unrealstudiohelp.epicgames.c...I-report-a-bug
          Sr. Product Manager
          Epic Games

          Comment


            #6
            Anyone still having this issue?
            I am importing a scene from Max to unreal via datasmith, which uses corona lights and daylight system
            Each imported corona light is paired with a DatasmithAreaLight actor and i am not sure why + the intensity is far too bright


            Comment


              #7
              I am still having this issue as of 8/13/2018. Using Max 2019 w/ Unreal 4.20 and latest Datasmith version as of today.

              Comment


                #8
                any updates on this topic?

                Comment


                  #9
                  We will need to check again. In theory, a high intensity might not be wrong - that goes hand in hand with exposure which in turn can be way off. So either the intensity of the light is too high, or the exposure settings is too low. But its true that this issue is brought up often and we have to revisit how its done.
                  Pierre-Felix Breton

                  Sr Technical Product Designer AEC, Unreal Engine
                  Epic Games - LinkedIn

                  Comment


                    #10
                    most of "too bright" issues are due to not use a physical Camera both in DCC and UE4.

                    Comment


                      #11
                      Has anyone tested the above comment? (viewing through scene cams?) As this did not resolve the issue for me ..

                      Originally posted by Feng.Li View Post
                      most of "too bright" issues are due to not use a physical Camera both in DCC and UE4.

                      Comment


                        #12
                        Originally posted by NoobNoodle5 View Post
                        Has anyone tested the above comment? (viewing through scene cams?) As this did not resolve the issue for me ..


                        You can adjust EV100 value to 11 or 12. See if the exposure is normal?

                        Comment


                          #13
                          I also met a similar problem

                          Comment


                            #14
                            I had this issue when I was working with V-Ray imported lights. My workflow to this was just to build the lighting and see how it looked baked (if you used baked lighting). If this still wasn't correct, I'd amend the views in Unreal and just have some separate values. Not sure if you're using the units on the lights to help you achieve real lighting or arbitrary values.
                            Have a great day,

                            Josh Bridger LinkedIn
                            Graphics Artist @ 3DLABS
                            ------------------------------------

                            Comment


                              #15
                              Also here, when importing from 3d max vray lights. All area lights have insane intensities :/

                              Comment

                              Working...
                              X