Announcement

Collapse
No announcement yet.

Ultimate Touch Components v2 – swipe, pinch to zoom, virtual joysticks and much more

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Originally posted by Ambrellich View Post
    Hello Acrossfy! Thank's for reply!

    Yes, but with functionality like in this video:
    https://www.youtube.com/watch?v=GAomDzu54vk&t=13s

    Nearest idea - is in your example scene "Test multi touch in editor".
    Hey Amberlich!

    Please take a look at update 3.0. There is new component "SwipeToMove" and usage examples for on V3 map. It will give you desired behavior.

    Comment


      #62
      Originally posted by WarpSpasm View Post
      Great Update Thanks for that, also the 3rd person shooter character is a great addition to the examples
      Thanks man! Just FYI: issue with using joystick components from controller was fixed. So you can remove "OnPawnPossessed" node, that was used as workaround.

      Comment


        #63
        Originally posted by Acrossfy View Post
        Thanks man! Just FYI: issue with using joystick components from controller was fixed. So you can remove "OnPawnPossessed" node, that was used as workaround.
        awesome...im loving the pack, im about to also release a driving game using a modified version of the first person character from the demo room, for over a year ive been using standard joysticks or umg buttons for the driving which just always feels bad to play on mobile but now ive managed to get something which is actually not soul destroying to try to control on mobile
        https://play.google.com/store/apps/d...m.CrazyRagdoll
        https://play.google.com/store/apps/d...sm.zombieultra
        https://play.google.com/store/apps/d...sm.cubecrawler
        https://play.google.com/store/apps/d...pspasm.turrets

        Comment


          #64
          Hello there! amazing pack so far! but im having a problem when i import a texture to the Widget and add it on the UTC Component it gives me a black screen? what can i do?

          THanks!

          Comment


            #65
            Originally posted by Arukaito View Post
            Hello there! amazing pack so far! but im having a problem when i import a texture to the Widget and add it on the UTC Component it gives me a black screen? what can i do?

            THanks!
            Hello, could you please explain which exact UTC Component you're using? About adding widget - how do you doing it? I need more details, screenshots and ideally test project.

            Comment


              #66
              Hi! I've just found and downloaded this asset and made a project, then I opened the project, there was an error.
              How can I fix this?
              Click image for larger version

Name:	2017-02-22_2154.png
Views:	1
Size:	15.1 KB
ID:	1123767

              Comment


                #67
                Originally posted by yuyuki View Post
                Hi! I've just found and downloaded this asset and made a project, then I opened the project, there was an error.
                How can I fix this?
                [ATTACH=CONFIG]130424[/ATTACH]
                Hello, it's the issue with texture that was failed to load, but this was already fixed. Looks like you have older version. Please try to redownload this asset, but clear UE4 Launcher cache before do it. Thanks.

                Comment


                  #68
                  Originally posted by Acrossfy View Post
                  Hello, it's the issue with texture that was failed to load, but this was already fixed. Looks like you have older version. Please try to redownload this asset, but clear UE4 Launcher cache before do it. Thanks.
                  Hello, I removed the asset with a drop-down menu ("Remove Local Content") in the Epic Game Launcher and redownloaded the asset, but still had the same error. I also tried manually deleting the asset content in the "VaultCache" folder but it also didn't help.

                  Comment


                    #69
                    Originally posted by yuyuki View Post
                    Hello, I removed the asset with a drop-down menu ("Remove Local Content") in the Epic Game Launcher and redownloaded the asset, but still had the same error. I also tried manually deleting the asset content in the "VaultCache" folder but it also didn't help.
                    What is your version of UE? Please try to find this texture (on hard drive) and reimport it to the project with the same name. And point CrosshairWidget to this reimported texture. By the way, this issue affects only one example that comes with this texture (TP Shooter Character from UTC V3 features map) and it affects only look of this example, not functionality.

                    Comment


                      #70
                      Hi, great product!.

                      I just bought it and I was wondering if you can restrain the pinch and rotate recognition gestures to a widget. My game have multiple windows that cna be dragged, zoomed and rotated and I was wondering if I can do this with your product.

                      Thanks!

                      Comment


                        #71
                        Originally posted by ExperienciaUmbra View Post
                        Hi, great product!.

                        I just bought it and I was wondering if you can restrain the pinch and rotate recognition gestures to a widget. My game have multiple windows that cna be dragged, zoomed and rotated and I was wondering if I can do this with your product.

                        Thanks!
                        Hi! Actually my realization of pinch to zoom gesture component is for actors only. So you can't use it for UMG. Maybe there is some hacky way to do it using my components, but I never tried and it never was my goal.

                        Comment


                          #72
                          Hi there!

                          The plugin is working great, but now I have a problem when nativizing blueprints. I've sent the question to "support@neowavegames.com" a few days ago. Is that email working as support channel?

                          Thank you!
                          Alejandro

                          Now on Google Play!

                          Comment


                            #73
                            Originally posted by Nomte View Post
                            Hi there!

                            The plugin is working great, but now I have a problem when nativizing blueprints. I've sent the question to "support@neowavegames.com" a few days ago. Is that email working as support channel?

                            Thank you!
                            Alejandro
                            Hey Alejandro! By some unknown reason, your mail was recognized as spam, so we didn't see it.

                            We can't do anything on our side to solve your issues with nativization. The issue that you had with regular header include after generated header include means that it's a bug in their nativization system, because in regular C++ programming for UE4 it's also restricted. And Epic Games developers know that for sure. So it would be better to write bug report on unreal answers portal, but please do not include any part of UTC in your public thread with Epic Games, because it violates marketplace rules.

                            Comment


                              #74
                              nativization worked fine with it in 4.15 but now ive upgraded to 4.16 it doesnt so its an engine issue although nativization actually made some stuff slower like lvl loading so im actually seeing a performance increase by not using it in 4.16 on android...game performance using UTC without nativization is exactly the same from my testing anyway
                              https://play.google.com/store/apps/d...m.CrazyRagdoll
                              https://play.google.com/store/apps/d...sm.zombieultra
                              https://play.google.com/store/apps/d...sm.cubecrawler
                              https://play.google.com/store/apps/d...pspasm.turrets

                              Comment


                                #75
                                Originally posted by Acrossfy View Post
                                Hey Alejandro! By some unknown reason, your mail was recognized as spam, so we didn't see it.

                                We can't do anything on our side to solve your issues with nativization. The issue that you had with regular header include after generated header include means that it's a bug in their nativization system, because in regular C++ programming for UE4 it's also restricted. And Epic Games developers know that for sure. So it would be better to write bug report on unreal answers portal, but please do not include any part of UTC in your public thread with Epic Games, because it violates marketplace rules.
                                Ok, I see. I'll wait for an update then.

                                Thanks for the quick reply!

                                Cheers!

                                Now on Google Play!

                                Comment

                                Working...
                                X