Announcement

Collapse
No announcement yet.

Kantan Charts - Free UMG chart/graph plugin

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    [RELEASED] Kantan Charts - Free UMG chart/graph plugin

    [shot]https://cdn1.epicgames.com/ue/item/KantanCharts_Screenshot1-1920x1080-523dd96e212bd3e1cf5e0b97981c3f36.png[/shot][shot]https://cdn1.epicgames.com/ue/item/KantanCharts_Screenshot2-1920x1080-8cb6c3ca6692bcc28cc8e42df0b965f8.png[/shot]

    More info | Marketplace page

    This is a simple, free plugin providing bar chart, line and scatter graph functionality in UMG. Fully Blueprint enabled.
    The intention is for development use but the plugin is tested in packaged builds too, so it's possible to use them in-game. Visually they're fairly basic though, with limited styling options.
    Last edited by kamrann; 08-31-2016, 12:59 PM.

    #2
    So apparently Epic have somehow managed to omit the plugin's content from the 4.10 & 4.11 downloads leading to an error on startup. I'm letting them know but most likely nothing will be done until Monday now.

    The 4.12 version is fine.
    Last edited by kamrann; 06-18-2016, 10:07 AM.

    Comment


      #3
      Thanks for clarifying that! I just got the error message, so it's good to know it's not something wrong with my project!
      Twitter: @zerofiftyone_
      Website: zerofiftyone.net - My game development blog
      Button Frenzy store page: http://store.steampowered.com/app/454630

      Comment


        #4
        This issue is now resolved, although 4.10 support has been removed due to a compatibility issue. It could be fixed but since that's now 2 versions old, it will probably remain 4.11+ unless someone specifically requests a 4.10 version.

        Comment


          #5
          This doesn't compile under 4.11, because none of the UProperties have been given categories; I get "Property is exposed to the editor or blueprints but has no Category specified" for each UProperty and am having to manually go through the plugin and add them all.

          Comment


            #6
            Dear [MENTION=27203]kamrann[/MENTION].

            Thank you for sharing this with us all in complimentary fashion!

            You're awesome!



            Rama
            100+ UE4 C++ Tutorials on the UE4 Code Wiki, including UE4 Multi-Threading!

            UE4 Marketplace: Melee Weapon Plugin & Compressed Binary Save System Plugin | Rama's C++ AI Jumping Videos | Vertex Snap Editor Plugin

            Visit www.ue4code.com to see lots of videos about my C++ Creations! ♥ Rama

            Comment


              #7
              [MENTION=552]Rama[/MENTION]: You're welcome. I learnt a lot from wiki articles by yourself and others, happy to give something back.

              [MENTION=251]ambershee[/MENTION]: First off, sorry I didn't see your post before now, I'm not sure how I missed it.
              There is an issue with the UE4 build system whereby this gets through when building a plugin/project, but shows up once the plugin is installed to the engine. I notified Epic of this a while back, and it seems they've taken note (even if it's not fixed) as it's now mentioned in their updated marketplace plugin guidelines.

              That said, I updated my plugins to correct this before release. I have just checked now and confirmed what you've said - Epic have evidently uploaded an older 4.11 build of this plugin to the marketplace rather than the latest version I sent them before release (this was fixed in a version I sent them on June 14th). So I've had a broken product available for over a month, which unfortunately I was unaware of since whilst I tested all versions locally, I only installed and tested via the marketplace installation procedure for 4.12.

              This is incredibly annoying, to the point that I'm considering just pulling my things from the MP. It's just added to a ridiculously long list of failures by Epic to actually reflect what I've submitted in what they put up online. Again, sorry for the delay and for the hassle of having to correct this yourself.

              Comment


                #8
                I should add that I'm using it in a source code version compiled from Github, rather than the binary version through the launcher - the issues should be the same in both versions though!

                Comment


                  #9
                  Yep. I presume you have it as an engine plugin rather than a project level plugin? I think that's what makes the difference in terms of this error showing up or not.

                  Comment


                    #10
                    Hey kamrann, is there any tutorial or guide regarding how to set up advanced charts (blueprints or C++) using your plugin? Or open source code? I'm new to UE. Also, fan of your work by the way!

                    Comment


                      #11
                      [MENTION=573962]fgjtombs[/MENTION]
                      Hi there. Unfortunately no, there aren't. I haven't really been able to dedicate any more time to it since releasing it, and to be honest have no idea to what extent it's even being used.

                      By advanced charts, I assume you mean using datasources? If you let me know specifically what you want to achieve, I'll do my best to help out.

                      Comment


                        #12
                        Hi, [MENTION=27203]kamrann[/MENTION]! Thanks a lot for this plugin! We're using it on medical applications. Is there a way to change the line thickness?
                        Freelancer Game Dev Generalist and Unreal Consultant | Portfolio
                        Unreal products: Dynamic Picture Frames, Neo Kinect

                        Comment


                          #13
                          [MENTION=30654]RVillani[/MENTION] I recently had the same request from someone and looked into it. It turns out this line here in the engine is ignoring the input thickness on lines. I am guessing (though I'm not sure as it was so long ago) that this may have been why I didn't expose a line thickness option in the first place.

                          I sent a message to the relevant Epic programmer about this, but didn't hear back. I don't know if it is like that for a good reason, or someone just disabled it at some point and forgot to change it back. When I get some time I may try uncommenting that line in a source build and seeing if it works, but I'm afraid I can't say when, and any change would take a while to get through to the release version of the engine anyway.

                          Comment


                            #14
                            Just to note, I uploaded an updated version for 4.15 & 4.16 recently, with a couple of small updates:

                            - Fixed a bug that would cause axis labels to disappear in extreme cases (when size of the data range was orders of magnitude smaller than the absolute values of the min/max).

                            C++ only:
                            - Exposed most functionality via interfaces so the plugin can be used as a dynamically loaded module if needed.
                            - More control over automatic calculation of axis ranges.

                            Comment


                              #15
                              [MENTION=27203]kamrann[/MENTION] I see. If the problem is on source it's much more complicated.. well, thanks for your response and the update anyways. The plugin is great ^_^
                              Freelancer Game Dev Generalist and Unreal Consultant | Portfolio
                              Unreal products: Dynamic Picture Frames, Neo Kinect

                              Comment

                              Working...
                              X