Announcement

Collapse
No announcement yet.

Character Stats Kit - Over 40 nodes to power your Skill point, Exp, Reputation and stats!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hello,

    You should remove the savefiles.

    And on the NULL reference, yes you certainly need to make sure you create the UMG before you call the setup node. Everyone who seems to have the null errors, please make sure you have a player controller(if you don't have any, just make a new one as every pawn has a player controller anyway, just the engine default if no custom one is made).

    We're going to work on making a clearer remove/adding of character stats that will avoid having to remove the savefile. It's rather simple to make, however it will only be in in a few weeks. For now just remove the savefile.
    Last edited by CelestialCel; 06-07-2017, 02:56 PM.

    Leave a comment:


  • replied
    Very weird, mine resolved itself as well. That's a little scary.

    I also had another question, I removed some skills from the list, but they still appear (although without their name, just as blank spaces) on the skills tab. So I have 4 skills I want to use, but there's like, upwards of 15 on there.
    How do I remove the deleted skills from the UMG?

    Leave a comment:


  • replied
    Hello
    the problem you have is coming from the StatUMG, ie the widget used by the component.

    Depending on WHEN you create the actor containing the Stat component, the setup may found a "null" reference to the Widget.
    To avoid this, ensure that you are creating the Stat widget BEFORE calling the setup function. Usually, it is a good idea to create the StatsUMG in the the player controller instance (in the begin play event for example), or in a game instance.

    Leave a comment:


  • replied
    Originally posted by Ubersoldat42 View Post
    Can someone please explain why I get these errors? I get two of them when I press "P" and "Enter" respectively (after following the tutorial).
    The only difference from the tutorial is that I had to create a PlayerController because I didn't have one prior, and added a function as the tutorial specified.
    I don't get what I'm doing wrong.
    Uber, I had the same issue with my project until it seemed to resolve itself. Try running the game in standalone, then in pie.

    Leave a comment:


  • replied
    Hey there,
    this seems to be a really good stats kit for my game. But i have one concern, is it compatible with https://www.unrealengine.com/marketp...-hunger-system becuase i have the system already implemented in my game.

    Thanks

    Leave a comment:


  • replied
    Can someone please explain why I get these errors? I get two of them when I press "P" and "Enter" respectively (after following the tutorial).
    The only difference from the tutorial is that I had to create a PlayerController because I didn't have one prior, and added a function as the tutorial specified.
    I don't get what I'm doing wrong.

    Click image for larger version

Name:	Errors.jpg
Views:	1
Size:	199.2 KB
ID:	1128592

    Leave a comment:


  • replied
    Question about the Bars / Bar Types in the Data Table and what the values are used for:

    - bCanObtainPassiveUsage
    - bHasPermanentUsage (guessing this is a bar that constantly "drains" ?)
    - RegenValuePerSecond and Value (vs the StartingValue / MaxValue) - curious how these values work with each other.

    Leave a comment:


  • replied
    Originally posted by Human Smoke View Post
    Okay, I've done so, and this was the end result I received.

    http://puu.sh/vGR93/8d034769b4.png

    Is this correct?
    That is correct, now drag the pin on the right from the "SET" node into the body of the return node.

    Leave a comment:


  • replied
    Originally posted by Panda Studios View Post
    Right click the graph and type "return", this will allow you to add a return node. Then drag the return value from the create widget or the return value of the "SET" node into the body of the return node.

    Okay, I've done so, and this was the end result I received.

    http://puu.sh/vGR93/8d034769b4.png

    Is this correct?

    Leave a comment:


  • replied
    Originally posted by Human Smoke View Post
    I'm not entirely sure as to how to do that.

    Currently, this is all I have:

    http://puu.sh/vGGmt/3053948cca.png

    This is on 4.14, by the way.
    Right click the graph and type "return", this will allow you to add a return node. Then drag the return value from the create widget or the return value of the "SET" node into the body of the return node.

    Leave a comment:


  • replied
    I'm not entirely sure as to how to do that.

    Currently, this is all I have:

    http://puu.sh/vGGmt/3053948cca.png

    This is on 4.14, by the way.
    Last edited by Human Smoke; 05-05-2017, 04:12 PM.

    Leave a comment:


  • replied
    Originally posted by Human Smoke View Post
    I was having issues with the return node part in the integration instructions with this. Essentially I couldn't get it set up the same way as it was in the picture. The Return Node was different in the sense that I couldn't even get a "Output get" part.
    Hello,

    You can drag the return value of the create Widget into the return node, this will automatically add this as an output variable.

    Leave a comment:


  • replied
    I was having issues with the return node part in the integration instructions with this. Essentially I couldn't get it set up the same way as it was in the picture. The Return Node was different in the sense that I couldn't even get a "Output get" part.

    Leave a comment:


  • replied
    i am getting these errors can anyone help with them?

    Error Blueprint Runtime Error: Accessed None trying to read property CallFunc_GetInterface_AsStats_Interface3 from function: 'ExecuteUbergraph_StatsComponent' from node: Buffs Resetted in graph: EventGraph in object: StatsComponent with description: Accessed None trying to read property CallFunc_GetInterface_AsStats_Interface3
    Error Blueprint Runtime Error: Accessed None trying to read property CallFunc_GetInterface_AsStats_Interface4 from function: 'ExecuteUbergraph_StatsComponent' from node: Nerfs Resetted in graph: EventGraph in object: StatsComponent with description: Accessed None trying to read property CallFunc_GetInterface_AsStats_Interface4
    Error Blueprint Runtime Error: Accessed None trying to read property StatSaveComponent from function: 'SaveGame' from node: Save ID in graph: SaveGame in object: StatsComponent with description: Accessed None trying to read property StatSaveComponent

    i am using version 4.15

    Thanks in advance
    Last edited by UselessGrandad; 04-30-2017, 06:16 AM.

    Leave a comment:


  • replied
    New documentation: https://docs.google.com/document/d/1...it?usp=sharing

    Leave a comment:

Working...
X