Announcement

Collapse
No announcement yet.

Physical Water Surface

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Theokoles View Post

    Actually, the Infinite Ocean System should do a fine job of creating the impression of an infinite ocean. The water plane is moved and scaled with the camera so that the horizon is always very far away. Did you enable the Follow Camera option (see here)?
    This is the default phsyical water pasted into the default beach cliffs scene.

    Also, the beach cliffs scene use a planar reflection, but the material isn't compatible with forward rendering. I saw a mention of of improving existing water shaders with the physical water movement, but I also need the distance field masking. Is this possible?
    Attached Files

    Comment


      Ok, so turns out that planar reflections was super easy (just tick the box in the material).

      Click image for larger version

Name:	Capture.jpg
Views:	1
Size:	172.8 KB
ID:	1664240

      I'm still interested in a way of fake extending the ocean all the way up to the skybox.

      Comment


        Originally posted by roberteker View Post

        I'm still interested in a way of fake extending the ocean all the way up to the skybox.
        Please try to increase the HeightZoomFactor parameter of the WaterPlane Blueprint. Changing this parameter from 1 to 10 will increase the size of the water plane by a factor of 10. After increasing this value you should have a look at the running game in Wireframe mode to check if the mesh size of the water plane is still appropriate.

        Comment


          Originally posted by Theokoles View Post

          Please try to increase the HeightZoomFactor parameter of the WaterPlane Blueprint. Changing this parameter from 1 to 10 will increase the size of the water plane by a factor of 10. After increasing this value you should have a look at the running game in Wireframe mode to check if the mesh size of the water plane is still appropriate.
          Thanks, that helped, but it made the water immediately around the boat very coarsely tesselated using any value above 5.

          I'm using quite calm waters right now, so it works for me, but it seems that unless I missed something, I wouldn't want to try this with larger waves.

          Comment


            Originally posted by roberteker View Post

            Thanks, that helped, but it made the water immediately around the boat very coarsely tesselated using any value above 5.

            I'm using quite calm waters right now, so it works for me, but it seems that unless I missed something, I wouldn't want to try this with larger waves.
            Please have a look at the water plane mesh, it has an area with higher triangle count in the middle. The camera is always above this area where the triangle count is high, resulting in good looking water under normal conditions.
            If you set HeightZoomFactor to 5, this means that the water plane mesh is scaled up by a factor of 5. As a result, the triangle size in the middle of the water plane becomes too large, resulting in the "coarsly tesselated" look that you describe.
            To fix this, you need to modify the water plane mesh or create your own water plane mesh where the triangle size in the middle of the water plane is five times smaller than in the original water plane mesh that comes with Physical Water Surface. Then the water will look normal again (with HeightZoomFactor set to 5).

            Comment


              Originally posted by Theokoles View Post

              Please have a look at the water plane mesh, it has an area with higher triangle count in the middle. The camera is always above this area where the triangle count is high, resulting in good looking water under normal conditions.
              If you set HeightZoomFactor to 5, this means that the water plane mesh is scaled up by a factor of 5. As a result, the triangle size in the middle of the water plane becomes too large, resulting in the "coarsly tesselated" look that you describe.
              To fix this, you need to modify the water plane mesh or create your own water plane mesh where the triangle size in the middle of the water plane is five times smaller than in the original water plane mesh that comes with Physical Water Surface. Then the water will look normal again (with HeightZoomFactor set to 5).
              Thanks, I will have a go at this when I get the time!

              Comment


                Originally posted by roberteker View Post

                Thanks, I will have a go at this when I get the time!
                Let me know if you have more questions!
                I've used Blender to make the water plane mesh. Just create a plane and then use the Subdivide tool to add more faces in the middle of the plane.

                Comment


                  Physical Water Surface - Quick Tips #3: Events for entering/leaving the water

                  Did you know that Physical Water Surface provides events in the Buoyancy Blueprint that are triggered when an objects enters or leaves the water?
                  This can be very useful for performance optimizations in case you have a large number of objects and only some of them are actually floating in the water. With this events you can easily disable any Blueprint code that doesn't need to run when an object is not floating.

                  Click image for larger version

Name:	events.PNG
Views:	1
Size:	20.2 KB
ID:	1673114

                  Comment

                  Working...
                  X