Announcement

Collapse
No announcement yet.

Code Plugin works on UE4 Binary version?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SUPPORT] Code Plugin works on UE4 Binary version?

    Hi,

    So, Ive built a plugin using the git release version 4.11.2, compiled my engine plugin and everything works well, but when I put it under UE4 Binary version, it says that my plugin needs to be recompiled, because of different engine versions...

    So, what am I missing?

    #2
    You're not missing anything - plugins have to be compiled for each specific engine version you want to use them with.
    Even if your source build is the same version (4.11.2) as your launcher install, I believe source builds get tagged as such by default (there is some UBT flag controlling this I think) which is I guess why it's claiming the versions are different.

    If you want to use your plugin with the launcher install, then you should just build the code against the launcher engine.

    Comment


      #3
      Good to know! Thank you! I'll try it!

      Comment


        #4
        Originally posted by kamrann View Post
        You're not missing anything - plugins have to be compiled for each specific engine version you want to use them with.
        Even if your source build is the same version (4.11.2) as your launcher install, I believe source builds get tagged as such by default (there is some UBT flag controlling this I think) which is I guess why it's claiming the versions are different.

        If you want to use your plugin with the launcher install, then you should just build the code against the launcher engine.
        I have try to do it but I have some problem..

        I have added my plugin folder on the Engine\Plugins directory for my binaries version. I have generate visual studio project file for my project and the plugin has appeared under UE4 project. Now I have try to build it but the build of my plugin was skipped (note that ue4 project seems to be rebuild correct) and my plugin binaries are not created.

        I have try another way creating a new Plugins folder on my project directory. At this time I have a lot of compile error with IInputDevice include (with my plugin I want control a custom device controller).

        Now, which is the correct way to do this?

        Comment

        Working...
        X