Announcement

Collapse
No announcement yet.

Closing Credits System - Support Thread

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SUPPORT] Closing Credits System - Support Thread

    This is the official support thread for Closing Credits System

    Click image for larger version

Name:	96826d2b96.jpg
Views:	1
Size:	829.6 KB
ID:	1179833

    This is the place to ask me any support-related questions for this package, and I will do my best to reply as soon as possible. I will be updating this thread with a general Q&A as questions are asked.

    Q: Where can I find the documentation for this package?
    A: The documentation is located -> here <-
    Last edited by Jamendxman3; 04-08-2016, 02:00 AM.
    Marketplace Assets

    Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
    Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
    Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

  • #2
    Hi

    Great system!

    I was using it in a persistent manner where the credits menu didn't lose reference. Every time it was added to the viewport the entire credits and roles were listed again such that:

    Open once:
    Main Title
    TitleA
    Name1

    Open twice:
    Main Title
    TitleA
    Name1
    Name1
    Main Title
    TitleA
    Name1
    Name1

    Open three times:
    Main Title
    TitleA
    Name1
    Name1
    Name1
    Main Title
    TitleA
    Name1
    Name1
    Name1
    Main Title
    TitleA
    Name1
    Name1
    Name1

    etc.
    I tried adding an internal bool that would disable the event construct after the first time but the data is still persisting somewhere can causing extra loops for everything.
    Thanks!

    Comment


    • #3
      Originally posted by Burnrate View Post
      Hi

      Great system!

      I was using it in a persistent manner where the credits menu didn't lose reference. Every time it was added to the viewport the entire credits and roles were listed again such that:

      etc.
      I tried adding an internal bool that would disable the event construct after the first time but the data is still persisting somewhere can causing extra loops for everything.
      Thanks!
      I spoke with the person you are working with, I'm glad to see you got that sorted out.
      Marketplace Assets

      Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
      Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
      Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

      Comment


      • #4
        Hi,

        I am having issues packaging the credits system (everything else in my game is error free and I double checked this by removing the credits system and packaging again - it succeeded)
        Click image for larger version

Name:	CreditSpawnerError.jpg
Views:	1
Size:	187.0 KB
ID:	1116813
        The deprecated node was an easy fix, just replaced it with a new one.
        Click image for larger version

Name:	CreditsPackagingError.png
Views:	1
Size:	113.1 KB
ID:	1116814
        The output logs showed some issues with the credits system that I have no clue about or how to fix.
        I even went into the blueprints where those errors seemed to originate from but could not find anything "wrong" per se - however I am unfamiliar with the inner workings of the system.

        Comment


        • #5
          Originally posted by Cmdr Xan View Post
          Hi,

          I am having issues packaging the credits system (everything else in my game is error free and I double checked this by removing the credits system and packaging again - it succeeded)
          The deprecated node was an easy fix, just replaced it with a new one.
          The output logs showed some issues with the credits system that I have no clue about or how to fix.
          I even went into the blueprints where those errors seemed to originate from but could not find anything "wrong" per se - however I am unfamiliar with the inner workings of the system.
          Apologies for the late response. Which version of the engine are you using? Do you only encounter issues like this when packaging?
          Marketplace Assets

          Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
          Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
          Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

          Comment


          • #6
            Originally posted by Jamendxman3 View Post
            Apologies for the late response. Which version of the engine are you using? Do you only encounter issues like this when packaging?
            Hi, thanks for getting back to me - I am using version 4.13.1 and yes it's only occurring in the packaging (using Windows 64-bit package).
            I'm mainly just in the testing phase making sure all my main assets work; I've put the credits roller into the level and tested that and it works just fine (using defaults).

            Comment


            • #7
              Originally posted by Cmdr Xan View Post
              Hi, thanks for getting back to me - I am using version 4.13.1 and yes it's only occurring in the packaging (using Windows 64-bit package).
              I'm mainly just in the testing phase making sure all my main assets work; I've put the credits roller into the level and tested that and it works just fine (using defaults).
              These errors are caused by engine bugs. Unreal has historically not been the most stable where Blueprint-created Structures are concerned. On my end, I was able to solve these errors by going into Credits Roller, and then going to file -> Refresh All Nodes. Let me know if this does not work for you, and if that's the case, please check if the number of errors was at least reduced.
              Marketplace Assets

              Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
              Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
              Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

              Comment


              • #8
                Originally posted by Jamendxman3 View Post
                These errors are caused by engine bugs. Unreal has historically not been the most stable where Blueprint-created Structures are concerned. On my end, I was able to solve these errors by going into Credits Roller, and then going to file -> Refresh All Nodes. Let me know if this does not work for you, and if that's the case, please check if the number of errors was at least reduced.
                Ok I have done this and the project packages successfully! Thanks a lot for this, I will have to remember this one

                Just a heads up in terms of errors this still pops up:
                LogProperty:Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/ClosingCreditsSystem/Blueprints/WidgetBlueprints/CreditsRoller.CreditsRoller_C:BuildCredits.CallFunc_GetDataTableRowFromName_OutRow'. Unknown structure.
                LogProperty:Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/ClosingCreditsSystem/Blueprints/WidgetBlueprints/CreditsRoller.CreditsRoller_C:BuildCredits.K2Node_MakeStruct_Overrides'. Unknown structure.
                LogProperty:Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/ClosingCreditsSystem/Blueprints/WidgetBlueprints/CreditsRoller.CreditsRoller_C:BuildCredits.CallFunc_Get_Overriden_Names_OverridenRoles.CallFunc_Get_Overriden_Names_OverridenRoles'. Unknown structure.
                LogProperty:Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/ClosingCreditsSystem/Blueprints/WidgetBlueprints/CreditsRoller.CreditsRoller_C:BuildCredits.CallFunc_Get_Overriden_Roles_OverridenRoles.CallFunc_Get_Overriden_Roles_OverridenRoles'. Unknown structure.


                I don't know if this will impact at all on anything but it seems to work fine now despite those errors.
                Your support has been much appreciated

                Comment


                • #9
                  I've tried to add the Closing Credits System thru the Unreal Launcher to my 4.14 project but it doesn't seem to be working at all. I attempted to add it to a separate 4.14 project and it didnt work. However a 4.12 project I was able to add it to a project. I've also added another bought package to my 4.14 and it worked, so I don't believe it is a local system issue. Any help?
                  Last edited by Bpop; 12-29-2016, 12:23 AM. Reason: Added new information

                  Comment


                  • #10
                    Originally posted by Bpop View Post
                    I've tried to add the Closing Credits System thru the Unreal Launcher to my 4.14 project but it doesn't seem to be working at all. I attempted to add it to a separate 4.14 project and it didnt work. However a 4.12 project I was able to add it to a project. I've also added another bought package to my 4.14 and it worked, so I don't believe it is a local system issue. Any help?
                    What occurs when attempting to add it to a 4.14 project? This is not something that I can do anything about on my end, as this is a user-end issue, but I need as much information as I can get so that the marketplace team can see what is wrong.
                    Marketplace Assets

                    Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
                    Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
                    Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

                    Comment


                    • #11
                      My apologies for leaving that info out. With no local files downloaded already. Open the unreal launcher. Inside Library/Vault section select Add To Project for Closing Credits System. Select a 4.14 Project to add to. Select Add to project. No download occurs, no local files added (will not allow me to delete local content for example). When you do this for a 4.12 project. When you select the final Add to Project, it downloads, and also allows you to delete local content.

                      So the download doesn't even occur.

                      Comment


                      • #12
                        Originally posted by Bpop View Post
                        My apologies for leaving that info out. With no local files downloaded already. Open the unreal launcher. Inside Library/Vault section select Add To Project for Closing Credits System. Select a 4.14 Project to add to. Select Add to project. No download occurs, no local files added (will not allow me to delete local content for example). When you do this for a 4.12 project. When you select the final Add to Project, it downloads, and also allows you to delete local content.

                        So the download doesn't even occur.
                        Hey Bpop, I informed Epic of this issue, and they were able to fix it. Cheers!
                        Marketplace Assets

                        Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
                        Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
                        Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

                        Comment

                        Working...
                        X