Announcement

Collapse
No announcement yet.

Dialogue Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by CodeSpartan View Post

    Not a problem. But unless I can experience the issue myself, there isn't much I can do. So if point 3 doesn't help, then I can only suggest one of the following
    - you attempt to create a small clean project that reproduces the issue, or
    - we can arrange some NDA to be signed so I can inspect the problematic project
    Well, I found the source of the problem; it was my first Dialogue, which contained some previous events (added within C++ in VS anno), and after I deleted that Dialogue asset (it was a Data Asset if I correct) puff, the warnings disappeared from my output log.

    Leave a comment:


  • replied
    Originally posted by JimPhoenix View Post

    Hey there,

    here are my answers for your list:
    1. Yes, they were customized (just as you wrote in your documentation and works fine with my custom events & conditions after a little C++ magic), but after the new version I deleted the old ones and replaced my Widgets with the new ones from your plugin's folder and set up as it should be
    2. I do that several times last night but without any success : /
    3. I think so, but after that I need to rebuild the full project in VS 2017 if I remember correctly, maybe?
    4. Unfortunately, I can't do that, because it's company material (and btw the whole project is about ~11 Gb massively) : ]

    Thank you, tonight I will give a try to the point 3, and we will see.
    Not a problem. But unless I can experience the issue myself, there isn't much I can do. So if point 3 doesn't help, then I can only suggest one of the following
    - you attempt to create a small clean project that reproduces the issue, or
    - we can arrange some NDA to be signed so I can inspect the problematic project

    Leave a comment:


  • replied
    Originally posted by CodeSpartan View Post

    Hi,

    The type was indeed changed, but I don't see why the engine complaining...

    1) Have you copied the dialogue/reply widgets into your project in order to customize them before updating? If yes, you need to do it again.

    2) Could you uninstall the plugin entirely (in epic launcher) and then reinstall it back again?

    3) Could you delete the Intermediate, Saved, Build, Binaries, DerivedDataCache folders in your project?

    4) If 2 and 3 don't work, could you send me your project to codespartan.supp@gmail.com so I could have a look at it?

    Thanks.
    Hey there,

    here are my answers for your list:
    1. Yes, they were customized (just as you wrote in your documentation and works fine with my custom events & conditions after a little C++ magic), but after the new version I deleted the old ones and replaced my Widgets with the new ones from your plugin's folder and set up as it should be
    2. I do that several times last night but without any success : /
    3. I think so, but after that I need to rebuild the full project in VS 2017 if I remember correctly, maybe?
    4. Unfortunately, I can't do that, because it's company material (and btw the whole project is about ~11 Gb massively) : ]
    Thank you, tonight I will give a try to the point 3, and we will see.

    Leave a comment:


  • replied
    The new version of the plugin has been released on the marketplace today. Make sure to backup your projects before updating, watch the new tutorial video on conditions/events, and I've uploaded the two sample projects - one is the project from the second video, and another a VR version with everything already set up. You can find them on the marketplace page.

    Leave a comment:


  • replied
    Originally posted by JimPhoenix View Post
    Ahoy CodeSpartan , after I updated the plugin today these ugly yellow lines appears in the output log (as warnings):

    Code:
    LogClass: Warning: Type mismatch in Events of DialogueNode - Previous (StructProperty) Current(ArrayProperty) for package: ../../../Engine/Plugins/Marketplace/DialoguePlugin/Content/UI/DemoReplyWidget.uasset
    LogClass: Warning: Type mismatch in Conditions of DialogueNode - Previous (StructProperty) Current(ArrayProperty) for package: ../../../Engine/Plugins/Marketplace/DialoguePlugin/Content/UI/DemoReplyWidget.uasset
    What should I do to fix this?
    Hi,

    The type was indeed changed, but I don't see why the engine complaining...

    1) Have you copied the dialogue/reply widgets into your project in order to customize them before updating? If yes, you need to do it again.

    2) Could you uninstall the plugin entirely (in epic launcher) and then reinstall it back again?

    3) Could you delete the Intermediate, Saved, Build, Binaries, DerivedDataCache folders in your project?

    4) If 2 and 3 don't work, could you send me your project to codespartan.supp@gmail.com so I could have a look at it?

    Thanks.
    Last edited by CodeSpartan; 01-10-2018, 09:34 PM.

    Leave a comment:


  • replied
    Hey Code latest update is now up. VR template needs an update too

    Leave a comment:


  • replied
    Ahoy CodeSpartan , after I updated the plugin today these ugly yellow lines appears in the output log (as warnings):

    Code:
    LogClass: Warning: Type mismatch in Events of DialogueNode - Previous (StructProperty) Current(ArrayProperty) for package:  ../../../Engine/Plugins/Marketplace/DialoguePlugin/Content/UI/DemoReplyWidget.uasset
    LogClass: Warning: Type mismatch in Conditions of DialogueNode - Previous (StructProperty) Current(ArrayProperty) for package:  ../../../Engine/Plugins/Marketplace/DialoguePlugin/Content/UI/DemoReplyWidget.uasset
    What should I do to fix this?

    Leave a comment:


  • replied
    Originally posted by CodeSpartan View Post
    Alright, I have submitted the new version to the marketplace, hopefully it'll be out in a few days.

    I also uploaded the new documentation, and recorded the new intro and a tutorial on the new conditions/events system.

    The first video is virtually the same, except you now create a dialogue like this:

    A BIG like for that "easy to find" UX update, thank you!

    Leave a comment:


  • replied
    weares

    I've looked at what you sent me, and it seems to me like you would benefit more from a sample project where VR is already set up.

    I'm uploading a sample VR project to this repository: https://gitlab.com/Glabrezu/VrDemoDialogue

    Here's what you'll get when you download it:


    It's still for the old version of the dialogue plugin. Once the new one comes out, I'll update it.

    Leave a comment:


  • replied
    Alright, I have submitted the new version to the marketplace, hopefully it'll be out in a few days.

    I also uploaded the new documentation, and recorded the new intro and a tutorial on the new conditions/events system.

    The first video is virtually the same, except you now create a dialogue like this:



    The rest is the same, so it's not worth watching for those already familiar the the basics of the plugin.

    The second video, on the other hand, is very important. It shows a completely new workflow for conditions and events, which eliminates all need for C++. Everything is now done in blueprints. Link: https://www.youtube.com/watch?v=qGFDMaO4FrM

    As soon as the new version comes out on the marketplace, I strongly recommend everyone to switch to it. It's vastly superior to the old one. It'll be available for UE 4.18 and higher.

    Your old dialogues will be compatible with it, but if you had old conditions/events, they will simply vanish in the new version, so be advised. I recommend switching to the new version, but if you already did a LOT of work on the old version, it's up to you whether to update or not.

    Once the new version comes out, I'll also provide a sample project from the video with everything set up.

    The new conditions/events systems is provided to you courtesy of Michael Brune from the Underflow Studios. He was very helpful in explaining a few things to me about how to bypass the ugly C++ list of variables, reorganized the plugin internally and provided a few new classes. A big shout out to him for this contribution.
    Last edited by CodeSpartan; 01-05-2018, 01:22 AM.

    Leave a comment:


  • replied
    weares I was on vacation, but I'm back and I'll have a look at your project shortly. Thanks for your patience.

    Originally posted by The Alpha Maiestro View Post
    I tried the tutorial video to set up the c++ it didnt give me access to anything that was in the video. The dialogue option doesnt even pop up in the editor to make new assets. Can we get a new one? I dont know how much of this is still necessary.
    Sorry, I didn't understand what you mean by that.

    But the new (easier) version should be submitted to the Marketplace tomorrow. It's out of my hands how much it'll take to get verified by Epic staff (don't know if they're back from vacation yet), but anyway the new version won't require you to fiddle with C++ anymore.

    Leave a comment:


  • replied
    Originally posted by weares View Post

    Hey I'll redone but in first person shooter to understand better the process and then I'll redone for vr. Anyway, is possible to implement directly VR dialogue widget into the plugin like an update or something? VR developers community is growing hahaha. Thanks.
    Hello?? Any solution?

    Leave a comment:


  • replied
    Originally posted by eliasfrost View Post
    Hi! I just purchased the plugin but it doesn't seem to work properly. The plugin is installed and enabled but I can't add dialogue assets? I don't have the option to add anything when I right click. Is there an additional step I need to take before I can add dialogues?

    I have version 4.18.2

    Thank you!

    EDIT: After looking around some more I saw in the old tutorial that you can add dialogues through the "data asset" asset.
    It's under "Miscellaneous", after rollovered on that type with your mouse choose "Data Asset" and from the Asset Classes pick up the "Dialogue" element and hit the green "Select" button. Yeah, it's a little hidy, if you ask me.

    Leave a comment:


  • replied
    Hi! I just purchased the plugin but it doesn't seem to work properly. The plugin is installed and enabled but I can't add dialogue assets? I don't have the option to add anything when I right click. Is there an additional step I need to take before I can add dialogues?

    I have version 4.18.2

    Thank you!

    EDIT: After looking around some more I saw in the old tutorial that you can add dialogues through the "data asset" asset.
    Last edited by eliasfrost; 01-01-2018, 05:36 PM.

    Leave a comment:


  • replied
    Not a problem. Sorry I can't seem to get it right. I'll post it up and let you know.

    Leave a comment:

Working...
X