Announcement

Collapse
No announcement yet.

Status Effects and Combat Text Blueprints

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Fix for " NO text" bug 4.16 +

    I have the fix for the 4.16 bug, I have uploaded a 4.17 version with the bug fixed.

    Here are the steps to fix the bug in 4.16


    you will need to open the combat text widget and the combat text component blueprints:

    Click image for larger version

Name:	step1.png
Views:	1
Size:	182.2 KB
ID:	1132654
    Click image for larger version

Name:	step2.png
Views:	1
Size:	277.2 KB
ID:	1132655
    Click image for larger version

Name:	step3.png
Views:	1
Size:	254.2 KB
ID:	1132656

    I'm not sure what had changed in 4.16 to make the input void and requiring a refresh but these steps will fix the problem.
    Robviously - Lone Pioneer Studios

    Marketplace Items:
    Mount and Taming Blueprint
    Status Effects and Combat Text Blueprint
    Laser Rangefinder Blueprint

    Comment


      #32
      Don't see anyone else reporting it, but this has been a continuing issue.
      https://www.youtube.com/watch?v=nZX_VIA7R7U

      The wiget in the upper left corner will flash the text briefly before moving over the character. I can't say it's related, but the effect is exasperated at higher frame-rates(it's way more noticeable on a 100hz+ monitor than a 60).

      Comment


        #33
        Originally posted by VFe View Post
        Don't see anyone else reporting it, but this has been a continuing issue.
        https://www.youtube.com/watch?v=nZX_VIA7R7U

        The wiget in the upper left corner will flash the text briefly before moving over the character. I can't say it's related, but the effect is exasperated at higher frame-rates(it's way more noticeable on a 100hz+ monitor than a 60).
        Hello,

        What version are you using?

        It looks more like it's a damage tick who's widget position is off the normal Vector coords, maybe the local Vector variable was reset to 0,0,0 for the position.

        I'll check it out in the editor and see what could be doing it. I'm out of town and on my laptop but I will post here when I have figured it out. Let me know if you find out what's causing it if you do before I get a chance to.

        Thank you,
        Last edited by Robviously; 08-27-2017, 10:11 PM.
        Robviously - Lone Pioneer Studios

        Marketplace Items:
        Mount and Taming Blueprint
        Status Effects and Combat Text Blueprint
        Laser Rangefinder Blueprint

        Comment


          #34
          Originally posted by Robviously View Post

          Hello,

          What version are you using?

          It looks more like it's a damage tick who's widget position is off the normal Vector coords, maybe the local Vector variable was reset to 0,0,0 for the position.

          I'll check it out in the editor and see what could be doing it. I'm out of town and on my laptop but I will post here when I have figured it out. Let me know if you find out what's causing it if you do before I get a chance to.

          Thank you,
          This happens in the 4.16(and 4.17 with the update guide you posted), and 4.15 versions. Don't have engines older than that to test atm, but the issue shows up reliably on multiple machines.


          Comment


            #35
            Robviously Any update on this? This asset is fundamentally unusable with this issue and it's been a few months.

            Comment


              #36
              Sorry, I've been away for work since the start of summer. I honestly don't know whats causing the issue. I thought maybe the widgets local variable - Vector3 was getting set to null but then it wouldn't show the numbers at the player. It looks to be a weird glitch and I'm probably going to need help figuring it out. It's got me scratching my head a bit. I'll keep trying to figure it out not that I finally have some free time for the next couple days.

              VFe
              Robviously - Lone Pioneer Studios

              Marketplace Items:
              Mount and Taming Blueprint
              Status Effects and Combat Text Blueprint
              Laser Rangefinder Blueprint

              Comment


                #37
                BUG FIX:

                The Bug was to do with the animations of the combat text. It would draw the text at 0.0.0 before moving it to the proper locations. It was supposed to be starting off screen like the "White text" had been doing (which was why that one didn't duplicate).

                Below are two pictures and a quick way to fix the bug, in less than 5 minutes:


                Step 1: change start location of text animation:

                https://i.imgur.com/tea3qbG.png

                 
                Spoiler
                .

                Step 2: Adjust text spawn location offset. I've included the offsets for the base project, you may need to do something different in your projects. This part is simple and can be done a number of ways.

                https://i.imgur.com/tpd32fX.png

                 
                Spoiler
                .

                I have submitted a new update for 4.18 to epic with the bug fixed.

                Thank you for your patients in this matter.
                Attached Files
                Last edited by Robviously; 11-03-2017, 06:10 AM.
                Robviously - Lone Pioneer Studios

                Marketplace Items:
                Mount and Taming Blueprint
                Status Effects and Combat Text Blueprint
                Laser Rangefinder Blueprint

                Comment


                  #38
                  Thanks for the update, it's appreciated. Glad it's fixed!

                  Comment


                    #39
                    Hi, so there is still no 4.18 support. We are almost at 4.19. Is this going to get updated?

                    Comment


                      #40
                      Please update it to 4.18. Thank you <3

                      Comment

                      Working...
                      X