Announcement

Collapse
No announcement yet.

Action RPG Inventory System

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Emrehan View Post
    How can i save different inventories? There are a lot of containers on the map and I want to save each one of them separately.
    Originally posted by Emrehan View Post
    I'm talking about saving items in a container. But I have a lot of containers in it, and I don't know how to save each of them separately. For example;

    In Level;
    Chest 1, Chest 2
    How can these two containers be stored differently in the same save file?

    Similarly, assume that there are two players in a multiplayer game. Both have different items. I want to collect each of these in the same savegame file.
    You can use the Find all actors of class node and loop through every Container_Actor (The base class used for all containers, loot actors etc) and save it's inventory into an array. But you will also want to save information like it's Class type(this will be the trickest to setup but you will need to know what type of actor to spawn when loading and creating all the actors in your world), InventorySize, SlotsPerRow, CanStoreItems and of course the actors world position.

    Loading the items would really just be the reverse of the save. It's really just going to be a loop through all the container actors at it's core.

    Originally posted by Emrehan View Post
    If you do not help, you do not have to answer me. I'm trying to get ideas from here, I can save the character's inventory. I ask how I can collect different players inventory in a single file.
    I am not always able to check the forums or my support email every few hours. I try my best to help and give advice in a timely matter and I appreciate your patience in the matter.

    Leave a comment:


  • replied
    Originally posted by DiziART View Post
    Hi! Help please. How set position to cursor for ToolTip widget? Thanks!
    It would be the same as updating any other UMG widget to your mouse position. I would recommend getting the cursor position and updating the widget in it's onTick (which only runs when the widget is visible) to the current mouse position.


    Originally posted by DiziART View Post

    And bug reported:
    Slot not clear, after drop item, from inventory
    [ATTACH=CONFIG]120371[/ATTACH]
    The HotBar isn't supposed to clear the item shortcut when the item is used/removed from the inventory.
    For example say you put an apple on the hotbar. When you eat all the apples the item is still linked in your hotbar. Then when you pick up more apples you can continue to eat them using the hotbar.
    Most games simply "grey" out the icon when none exist in the inventory so you don't have to keep rebinding your shortcuts.

    The Hotbar is not an inventory. You are free to change this design to wipe the item shortcut if no more of that item exist in your inventory.

    Leave a comment:


  • replied
    If you do not help, you do not have to answer me. I'm trying to get ideas from here, I can save the character's inventory. I ask how I can collect different players inventory in a single file.

    Leave a comment:


  • replied
    LOL. Read documentation. Question not this theme.

    Leave a comment:


  • replied
    I'm talking about saving items in a container. But I have a lot of containers in it, and I don't know how to save each of them separately. For example;

    In Level;
    Chest 1, Chest 2
    How can these two containers be stored differently in the same save file?

    Similarly, assume that there are two players in a multiplayer game. Both have different items. I want to collect each of these in the same savegame file.

    Leave a comment:


  • replied
    Is there an easy way to set Main/Off hand to use static meshes?

    Leave a comment:


  • replied
    Move container on the scene, and copy him (ctrl+w). Move - ready

    Leave a comment:


  • replied
    How can i save different inventories? There are a lot of containers on the map and I want to save each one of them separately.

    Leave a comment:


  • replied
    Bug? I create parameter in itemtable. And
    Click image for larger version

Name:	2016-12-06_10-51-42.png
Views:	1
Size:	158.9 KB
ID:	1119601
    if add slots to inventory == 0 add 10 slot (start count inventory size).
    if i parameter != 0
    Click image for larger version

Name:	2016-12-06_10-57-24.png
Views:	1
Size:	102.3 KB
ID:	1119602
    - all correct work. If i equip bag, my inventory slots add, unequipped - slots minus.

    And bug reported:
    Slot not clear, after drop item, from inventory
    Click image for larger version

Name:	2016-12-06_11-16-01.png
Views:	1
Size:	381.9 KB
ID:	1119603
    Last edited by DiziART; 12-06-2016, 04:17 AM.

    Leave a comment:


  • replied
    Hi! Help please. How set position to cursor for ToolTip widget? Thanks!
    Last edited by DiziART; 12-05-2016, 06:19 PM.

    Leave a comment:


  • replied
    Originally posted by Pirate View Post
    I would recommend deleting your Intermediate and Saved folders as well as cleaning up Re-directors in your project. Then try cooking again.


    Thats worked. Thanks

    Leave a comment:


  • replied
    Originally posted by Pirate View Post
    Do you remember what version of unreal you started the ARPGIS with for your project? and also what version of unreal is your project currently running?

    I haven't seen the issues you are running into with structs when I edit the InventoryItem nor have I heard of any other people having all their blueprints that have the structs cause errors when making changes to it. I have cooked builds just fine after making changes to the InventoryItem struct (But as well all know, not all engine bugs are 100% reproducible and usually the worst ones are a lower chance which unfortunately makes it harder to epic QA to even acknowledge the darn bugs). It has required me to save blueprints that use the struct but I never saw any errors or had to recompile any blueprint classes normally. I wonder if this is a result of upgrades through engine versions where structs have been drastically changed.

    Epic really has stuffed up structs royally but I thought they had made some good improvements lately in 4.12/4.13 with them that should have resolved the old issues.
    If we can gather some more information and get it posted on answer hub hopefully they can fix the bug you are experiencing.
    We began with whatever version of Unreal (4.8?) was current when the ARPGIS was published. We always upgrade to the current version of the engine (after a couple of weeks) and are using 4.14. Our ARPGIS code is more or less up to date. The errors do not occur when we change versions. They only occur on the infrequent occasions when we add a variable to the Inventory Item structure. There is no indication that anything untowards has occurred while using the editor. The cook always fails, however when Jenkins builds the client. An editor cook shows the errors (not as errors but as messages with error in the text) and these are always blueprints (including portions of the ARPGIS) that have not been recompiled since the addition.

    As I said, it is only necessary to recompile and save (even though none of them show any compile errors) each blueprint that uses the structure to remedy the problem. Unfortunately, at this stage, there are literally dozens of these as we have inventories or item references in all kinds of things: corpses, transport actors, and so forth.

    At this stage, we just accept it as part of the process. If we could learn to resist the urge to add just one more variable, the annoyance would disappear entirely.

    Leave a comment:


  • replied
    Originally posted by Rhynedahll View Post
    No, these are actually errors that cause cook failure in the editor and in Jenkins. I (and many others by the number of posts I have read concerning it) have encountered it on a consistent basis.

    This problem is a product of how Unreal handles structures and apparently will never be addressed by Epic.

    Additions to an existing structure (in this case the Inventory Item structure) do not propagate through blueprints. This may be by design but it is certainly annoying as the error does not show up in PIE, only when you attempt to cook the project.
    Do you remember what version of unreal you started the ARPGIS with for your project? and also what version of unreal is your project currently running?

    I haven't seen the issues you are running into with structs when I edit the InventoryItem nor have I heard of any other people having all their blueprints that have the structs cause errors when making changes to it. I have cooked builds just fine after making changes to the InventoryItem struct (But as well all know, not all engine bugs are 100% reproducible and usually the worst ones are a lower chance which unfortunately makes it harder to epic QA to even acknowledge the darn bugs). It has required me to save blueprints that use the struct but I never saw any errors or had to recompile any blueprint classes normally. I wonder if this is a result of upgrades through engine versions where structs have been drastically changed.

    Epic really has stuffed up structs royally but I thought they had made some good improvements lately in 4.12/4.13 with them that should have resolved the old issues.
    If we can gather some more information and get it posted on answer hub hopefully they can fix the bug you are experiencing.
    Last edited by Pirate; 12-04-2016, 04:17 PM.

    Leave a comment:


  • replied
    Originally posted by Cryptaline View Post
    Getting this warning when trying to build a project:

    LogCook:Warning: Found unparsable ini setting Windows.EditorPerProjectUserSettingsetailCategories:Muppet_C.Character Movement: Walking:0 for platform WindowsNoEditor, invalidating cook.
    I am not having any issues cooking the demo project in 4.10, 4.11, 4.12, 4.13 and 4.14. I just went though and tried on all the versions of unreal I have installed.
    Sometimes silly things can fail the cook process when working in unreal. It can be very frustrating as a lot of times the cook log makes you think certain things are whats causing it.

    I would recommend deleting your Intermediate and Saved folders as well as cleaning up Re-directors in your project. Then try cooking again.

    Please send me a support email if you continue to have cook issues with your project and I'll try my best to help you with your engine issue.
    Last edited by Pirate; 12-04-2016, 04:11 PM.

    Leave a comment:


  • replied
    *Bug Fix* There is a bug when you drop an equipped item where the player's stats aren't refreshing.

    To fix this bug simply edit the logic in the Drop Item() function located in the InventoryManagerComponent and add the following highlighted logic after the Client Clear Tool Tip node.

    Click image for larger version

Name:	update_stats_dropped_equipment.png
Views:	1
Size:	101.0 KB
ID:	1119511


    This fix will be included in the next update I submit to Epic.
    Last edited by Pirate; 12-04-2016, 04:24 PM.

    Leave a comment:

Working...
X