Announcement

Collapse
No announcement yet.

Action RPG Inventory System

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by unit23 View Post
    Hello OverRated, thanks for posting this screenshot, because i initially thought this REINST issue would show as an error, not in form of a sneaky hovering tooltip message. Yes i have this issue in my equipment widget, besides not touching that widget at all.
    What version of the inventory are you using? and have you added any logic into the inventory slot widget?

    Leave a comment:


  • replied
    Originally posted by OverRated_AU View Post
    When you hover over the child widget do you see a REINST?

    Hello OverRated, thanks for posting this screenshot, because i initially thought this REINST issue would show as an error, not in form of a sneaky hovering tooltip message. Yes i have this issue in my equipment widget, besides not touching that widget at all.

    Leave a comment:


  • replied
    I have little problem here plz help me around
    Click image for larger version

Name:	Untitled.png
Views:	1
Size:	6.1 KB
ID:	1120891

    Leave a comment:


  • replied
    Originally posted by Pirate View Post
    You can also cross reference the change log with a new project you create that already has the changes implemented.
    That should help you if the screenshots aren't enough to show you want to do in your own project where you already merged the previous version.
    I have removed the old version from the vault, and got the new one and can see that it has the 1.7 changes.
    I opened up my project and obviously nothing has changed, as expected.
    So now I'll have to go through your changelist and copy the new versions of the files over to my own project, right?
    I feel like I'm gonna miss some change somewhere doing it this manually. Am I missing something or is this just how it has to be?

    Thx, and sorry for the basic questions. I just wanna make sure I'm doing it right!
    For the record, I haven't made many changes to the default scripts anyway. I've just added a few new items etc.

    EDIT:
    For instance, here's a snippet from your changelog:
    Click image for larger version

Name:	inv1.JPG
Views:	1
Size:	109.7 KB
ID:	1120894

    So the bits where you say the file you've edited, and then the stuff you've changed/removed from it. Will I have to go into that and delete/change those too? It seems I will if I'm doing it manually? I could of course just wholesale migrate it all again but I'd have to go through all the Merge stuff again and spend a couple of hours doing it which I don't fancy.
    I'm probably making more of this than I need to (and I'm not complaining by the way) but as I said I want to make sure I'm not wasting more time than I need to and do it without errors due to manually editing lots of files etc
    Last edited by dazuk1978; 01-03-2017, 05:27 PM.

    Leave a comment:


  • replied
    Originally posted by Emrehan View Post
    Thanks a lot for your suggestion. I created a radio button for the crafting panel, and I connected it to the datatable so that the items automatically generated in the widget. In the same way, Crafting Informations come from the Data Table and Crafting progress starts when i press the button.

    http://i.imgur.com/UqcQ4VR.jpg

    How can I access the total amount value of item (example apple) that are scattered in different slots in the inventory?

    Leave a comment:


  • replied
    Originally posted by dazuk1978 View Post
    Ah I see. So I'll remove local content and re-get it to get the 1.7 version, then I can follow all your steps to get the latest changes working.
    Okay, that's cool.
    Just listen out for my cries of help when I inevitably **** things up

    Cheers
    You can also cross reference the change log with a new project you create that already has the changes implemented.
    That should help you if the screenshots aren't enough to show you want to do in your own project where you already merged the previous version.

    Leave a comment:


  • replied
    Originally posted by Pirate View Post
    I think you misunderstand. The update would be in new projects you create from the ARPGIS downloaded content.
    It won't update the code inside your own projects automatically if there is an update. It will only update the Local Content for the launcher for the asset. Sometimes you need to remove the Local Content and re-download it to get updates from Epic because the launcher is buggy. If you create a new project with the ARPGIS you should see the updated version.

    That's why you would need to follow the steps to make the changes you want if you had merged a previous version.

    The changes are quite simplistic and the steps are fully outlined so you shouldn't need to re-merge at all. But you will still have to do a little work yourself then.
    Ah I see. So I'll remove local content and re-get it to get the 1.7 version, then I can follow all your steps to get the latest changes working.
    Okay, that's cool.
    Just listen out for my cries of help when I inevitably **** things up

    Cheers

    Leave a comment:


  • replied
    Originally posted by dazuk1978 View Post
    So the option is 'Remove Local Content'?
    Will that cause any issues? I don't know if it will have lots of broken references etc when I do that and will I have to manually fix things up? If it works fine and I get the 1.7 version, will any edits I've done to any of the scripts be lost? I had to follow your tutorials to get it integrated into my project (4.14) in the first place and I wouldn't want to have to do any of that again!

    Cheers
    I think you misunderstand. The update would be in new projects you create from the ARPGIS downloaded content.
    It won't update the code inside your own projects automatically if there is an update. It will only update the Local Content for the launcher for the asset. Sometimes you need to remove the Local Content and re-download it to get updates from Epic because the launcher is buggy. If you create a new project with the ARPGIS you should see the updated version.

    That's why you would need to follow the steps to make the changes you want if you had merged a previous version.

    The changes are quite simplistic and the steps are fully outlined so you shouldn't need to re-merge at all. But you will still have to do a little work yourself then.

    Leave a comment:


  • replied
    Originally posted by Pirate View Post
    Not sure, sometimes the launcher caching is buggy. I would click on the ARPGIS in your vault and delete it so that the launcher has to redownload it. the 1.7 update is also only available for 4.13+ so if you don't have 4.13 or 4.14 installed maybe it won't let you download it?

    The manual steps are only for people who already merged into a project where it would be too much work for them to remerge.
    So I provide the steps so they can make the updates themselves.
    So the option is 'Remove Local Content'?
    Will that cause any issues? I don't know if it will have lots of broken references etc when I do that and will I have to manually fix things up? If it works fine and I get the 1.7 version, will any edits I've done to any of the scripts be lost? I had to follow your tutorials to get it integrated into my project (4.14) in the first place and I wouldn't want to have to do any of that again!

    Cheers

    Leave a comment:


  • replied
    Originally posted by dazuk1978 View Post
    No Weapon_Actor, and the tooltips are still at the bottom right.
    I actually looked at your 1.7 update post and there's a bit where you tell us how to make the tooltips appear on the object so I assumed even in the new version we'd have to do it manually? I guess not.
    I tried doing it manually anyway, and there were issues which I now can see will be due to me still being on on the 1.6 version.

    So next question, why do I not have the 1.7 version?
    Not sure, sometimes the launcher caching is buggy. I would click on the ARPGIS in your vault and delete it so that the launcher has to redownload it. the 1.7 update is also only available for 4.13+ so if you don't have 4.13 or 4.14 installed maybe it won't let you download it?

    The manual steps are only for people who already merged into a project where it would be too much work for them to remerge.
    So I provide the steps so they can make the updates themselves.

    Leave a comment:


  • replied
    Originally posted by Namesis View Post
    Hi
    I got it fixed, seemed like the Static Mesh or something on each of those "catbox" blueprints were set to NULL (weird? seems from the conversion to 1.14). However, I set that again and works as expected. I always wondered why those were showing as catboxes
    There is a bug with unreal and sometimes when the Editor crashes it can reset child blueprint values to the default values. So it looks like they all got set to the default NULL value in your case.

    Leave a comment:


  • replied
    Originally posted by Pirate View Post
    Do you have a wespon_actor and do the tooltips appear at the cursor/item or down in the ssme place in the bottom right.
    No Weapon_Actor, and the tooltips are still at the bottom right.
    I actually looked at your 1.7 update post and there's a bit where you tell us how to make the tooltips appear on the object so I assumed even in the new version we'd have to do it manually? I guess not.
    I tried doing it manually anyway, and there were issues which I now can see will be due to me still being on on the 1.6 version.

    So next question, why do I not have the 1.7 version?

    Leave a comment:


  • replied
    Originally posted by dazuk1978 View Post
    Hey, how do I check if I have 1.7 update?
    I haven't seen the orange exclamation mark and the 'Update' option on the launcher for ARPGIS so I don't think I am on the 1.7 version...but I could be wrong?
    Do you have a wespon_actor and do the tooltips appear at the cursor/item or down in the ssme place in the bottom right.

    Leave a comment:


  • replied
    in Unreal Editor all good. But after build app, UI don't visible.

    Leave a comment:


  • replied
    If I have somehow offended, then I apologize! I did not mean it! Just your first product, which had similar problems! I apologize to you for their sharpness, and I was wrong. Return means not see the point. Because I have a lot has changed and altered it in your system. Do not get me wrong, please.

    Leave a comment:

Working...
X