Announcement

Collapse
No announcement yet.

Action RPG Inventory System

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Anyone getting these warnings, after upgrade to 4.15?

    [2017.03.12-23.25.33:482][237]LogBlueprint:Warning: [Compiler InventoryManagerComponent] Warning 'Equipment Inventory Component' does not inherit from 'Inventory Component' ( Cast To EquipmentInventoryComponent would always fail).
    [2017.03.12-23.25.33:531][237]LogBlueprint:Warning: [Compiler InventoryManagerComponent] Warning 'Equipment Inventory Component' does not inherit from 'Inventory Component' ( Cast To EquipmentInventoryComponent would always fail).
    [2017.03.12-23.25.33:663][237]LogBlueprint:Warning: [Compiler InventoryManagerComponent] Warning [0077.58] Compile of InventoryManagerComponent successful, but with 2 Warning(s) [in 275 ms] (/Game/LOE/Components/Inventory/InventoryManagerComponent.InventoryManagerComponent)
    [2017.03.12-23.25.33:671][237]LogBlueprint:Warning: [Compiler InventoryManagerComponent] Warning [0077.59] Compile of InventoryManagerComponent successful, but with 3 Warning(s) [in 6 ms] (/Game/LOE/Components/Inventory/InventoryManagerComponent.InventoryManagerComponent)
    [2017.03.12-23.25.33:671][237]LogBlueprint:Warning: [Compiler InventoryManagerComponent] Warning [0077.59] Compile of InventoryManagerComponent successful, but with 4 Warning(s) [in 0 ms] (/Game/LOE/Components/Inventory/InventoryManagerComponent.InventoryManagerComponent)

    Leave a comment:


  • replied
    Originally posted by Pirate View Post
    I have seen this error displayed for enums in 4.15 in a few different projects. It's obvious the error being displayed itself is an error in these cases as everything continued to work fine.

    I found going into every place that uses the enum showing up in the buggy error message and clicking in the logic on the nodes that are accessing the enums and the enum variables (if there are any) and recompiling the blueprints managed to make the error go away when loading the project.

    But that is a pain in your project it caused an issue with the widget. I was seeing it in the ARPGIS for the visibility enum for the widgets and have recently updated the 4.15 version of ARPGIS with the method above to get rid of the error (which happened after upgrqding to 4.15). Again everything was working fine but it was annoying aeeing this enum error pop up on load.

    Hopefully they fix this 4.15 bug in an incremental release.

    Thanks for posting your info on it. Hopefully with your info and mine anyone seeing weird enum errors in 4.15 will have a better understanding of the new 4.15 bug

    Please re-save this asset to avoid issues with localization and determinstic cooking.

    This isn't a bug they changed the back end of Enum's in 4.15 all the warning is telling you to do is to re-save all your Enum's in the editor once you have done that the warning will clear it self.
    Last edited by OverRated_AU; 03-12-2017, 05:45 AM.

    Leave a comment:


  • replied
    Originally posted by unit23 View Post
    This bug may break InventoryLayout (removes Inventory content from main HUD widget) https://answers.unrealengine.com/que...um-broken.html

    Temp fix, upon project restart, remove and readd InventoryLayout (rename to Inventory), or use Preview 3 build from GitHub (speculative fix)

    Still investigating

    Added bug report

    https://answers.unrealengine.com/que...-to-break.html
    I have seen this error displayed for enums in 4.15 in a few different projects. It's obvious the error being displayed itself is an error in these cases as everything continued to work fine.

    I found going into every place that uses the enum showing up in the buggy error message and clicking in the logic on the nodes that are accessing the enums and the enum variables (if there are any) and recompiling the blueprints managed to make the error go away when loading the project.

    But that is a pain in your project it caused an issue with the widget. I was seeing it in the ARPGIS for the visibility enum for the widgets and have recently updated the 4.15 version of ARPGIS with the method above to get rid of the error (which happened after upgrqding to 4.15). Again everything was working fine but it was annoying aeeing this enum error pop up on load.

    Hopefully they fix this 4.15 bug in an incremental release.

    Thanks for posting your info on it. Hopefully with your info and mine anyone seeing weird enum errors in 4.15 will have a better understanding of the new 4.15 bug

    Leave a comment:


  • replied
    This bug may break InventoryLayout (removes Inventory content from main HUD widget) https://answers.unrealengine.com/que...um-broken.html

    Temp fix, upon project restart, remove and readd InventoryLayout (rename to Inventory), or use Preview 3 build from GitHub (speculative fix)

    Still investigating

    Added bug report

    https://answers.unrealengine.com/que...-to-break.html
    Last edited by unit23; 03-12-2017, 12:31 AM.

    Leave a comment:


  • replied
    Just added the inventory back in from the new version and it works perfectly. Thanks

    Leave a comment:


  • replied
    Originally posted by poke1103 View Post
    Hey what did you end up doing to get that working like that?
    A topic on this subject can be found here, see my reply there too https://forums.unrealengine.com/show...your-HUD-or-UI

    Leave a comment:


  • replied
    Originally posted by KrunkFu View Post
    I just started a new project in 4.15 with the latest version of the inventory. I'm using the inventory's player controller, HUD, and gamemode. Everything seems to work except I can't drag the inventory windows around. If I click and drag the mouse disappears and reappears where I last clicked when I release. I'm sure I'm overlooking something simple but if you can point me in the right direction that would be great.

    Also the inventory window appears off screen but I think I need to just change where the widget is anchored to fix that.
    Yes as Tylrin says.

    Also I have just had epic update the 4.15 files so starting now, new projects made in 4.15 and newer versions will have the windows drag-able by default again (now that the engine bug is fixed).

    Leave a comment:


  • replied
    Hey KrunkFu,

    Set the Bool IsWindowLocked in the Widgets to false. That will fix it, I think.

    Leave a comment:


  • replied
    I just started a new project in 4.15 with the latest version of the inventory. I'm using the inventory's player controller, HUD, and gamemode. Everything seems to work except I can't drag the inventory windows around. If I click and drag the mouse disappears and reappears where I last clicked when I release. I'm sure I'm overlooking something simple but if you can point me in the right direction that would be great.

    Also the inventory window appears off screen but I think I need to just change where the widget is anchored to fix that.

    Leave a comment:


  • replied
    Originally posted by poke1103 View Post
    Hey what did you end up doing to get that working like that?
    You will want to use render targets to render from a camera view to a texture. You will need to setup the camera to ignore other objects etc.

    A quick google search came up with this tutorial that might help get you started in the right direction.

    https://www.youtube.com/watch?v=BnLHBJMX0cE

    I know a few versions ago UE4 added some improvements to the Render to Texture tools but I don't recall exactly what has been changed.
    Maybe some others can chip in with any material online they might have seen that was useful in getting a good render target setup for a character paperdoll.

    Leave a comment:


  • replied
    Originally posted by poke1103 View Post
    Hey what did you end up doing to get that working like that?
    You should be able to google how to setup something similar, apart from networking support doubt theres any videos covering that.

    Leave a comment:


  • replied
    Originally posted by OverRated_AU View Post
    All of those features are fairly simple to add in on your own, just like adding in a character portrait :P.


    Hey what did you end up doing to get that working like that?

    Leave a comment:


  • replied
    Originally posted by poke1103 View Post
    Do you happen to have a video tutorial on how to setup items? Like picking them up...etc?
    All the video tutorials can be found listed in the first post. If you take a look at our youtube channel you will see all the tutorials for our 3 marketplace assets.

    Leave a comment:


  • replied
    Originally posted by Pirate View Post
    Glad you got it all working
    Do you happen to have a video tutorial on how to setup items? Like picking them up...etc?

    Leave a comment:


  • replied
    Originally posted by poke1103 View Post
    it was working after adding the Super::BeginPlay(); in C++
    The Inventory was anchored to the right side of the screen so I couldn't see it until I was in full screen mode.
    Glad you got it all working

    Leave a comment:

Working...
X