Announcement

Collapse
No announcement yet.

Action RPG Inventory System

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Darthlatte View Post
    Hello again, just a quick question - How do I go about adding a second icon type to my items, for example a larger one for the tooltip info? I have tried adding another column to the ItemList datatable (Texture2D) in Excel, but I can't seem to figure out how to get it into the tooltip... Thanks! :-)

    Btw. Thanks OverRated_AU, your suggestion worked like a charm and was a lot easier to implement ;-)
    Hi, The best way of doing this is just by passing the normal icon used for the slot to the tooltip, just create your icons larger to support the scale of the icon size you wish to use on your tooltop, from memory i use 128x128 and the slot size is 64x64 .

    Leave a comment:


  • replied
    Hello again, just a quick question - How do I go about adding a second icon type to my items, for example a larger one for the tooltip info? I have tried adding another column to the ItemList datatable (Texture2D) in Excel, but I can't seem to figure out how to get it into the tooltip... Thanks! :-)

    Btw. Thanks OverRated_AU, your suggestion worked like a charm and was a lot easier to implement ;-)
    Last edited by Darthlatte; 08-24-2017, 04:14 PM.

    Leave a comment:


  • replied
    Originally posted by OverRated_AU View Post

    Removing them will get messy because the inventory size sets the slots amount on the UI, i would recommend just collapsing them so there not visible.
    Thank you - I'll try it out :-)

    Leave a comment:


  • replied
    I made a 4.17 from scratch. However for some reason when I click a window and slighly (1 pixel?) move it to a side, like drag it, for some reason it moves alot, alot alot to the top or another location.. When I release the window it goes back to its position. Anyone with this? Kinda happens with all windows

    ---Edit---

    Ill take a guess and believe that the issue (change of engine version?) seems to be here (see attachment)... Changing from Pivot "Center Center" to "Mouse Down" seems to solve the issue..

    Dam those engine updates


    Attached Files
    Last edited by Namesis; 08-23-2017, 11:07 AM.

    Leave a comment:


  • replied
    Originally posted by Darthlatte View Post
    Hi, I'm trying to modify the inventory a little. I want the inventory to be empty (no slots) when there's no item in it, and when I add a new item the system automatically adds a new slot for that item - when equipping/consuming/destroying the item I want it to remove that slot again so that there's never an empty space in the inventory... Can someone with a greater knowledge of blueprint please help?

    I converted the uniform grid slot to a grid slot instead, and the adding of new slots and items works, but when I try to remove the item/slot again it doesn't remove the right one or removes to many slots - it seems that there's maybe an array somewhere that doesn't update or something else....

    I would be most grateful for any help :-) Thanks

    [ATTACH=CONFIG]15294[/ATTACH]

    [ATTACH=CONFIG]15265[/ATTACH]
    Removing them will get messy because the inventory size sets the slots amount on the UI, i would recommend just collapsing them so there not visible.

    Leave a comment:


  • replied
    Hi, I'm trying to modify the inventory a little. I want the inventory to be empty (no slots) when there's no item in it, and when I add a new item the system automatically adds a new slot for that item - when equipping/consuming/destroying the item I want it to remove that slot again so that there's never an empty space in the inventory... Can someone with a greater knowledge of blueprint please help?

    I converted the uniform grid slot to a grid slot instead, and the adding of new slots and items works, but when I try to remove the item/slot again it doesn't remove the right one or removes to many slots - it seems that there's maybe an array somewhere that doesn't update or something else....

    I would be most grateful for any help :-) Thanks

    Click image for larger version

Name:	Vertical_Inventory.png
Views:	1
Size:	321.4 KB
ID:	1132743

    Click image for larger version

Name:	InkedVertical_Inventory2_LI.jpg
Views:	1
Size:	669.8 KB
ID:	1132744
    Last edited by Darthlatte; 08-22-2017, 06:40 AM. Reason: Added image

    Leave a comment:


  • replied
    Are there specific render settings required for the focus colors to work?

    Leave a comment:


  • replied
    Originally posted by OverRated_AU View Post
    Pretty sure that was fixed what version are you using and did you pay for it?
    Yes ! i'm using latest version , but version 4.13 of the engine , because of my main project .

    Actually it doesnt go out of screen . i have 2 monitors , it only goes out of the screen from the side i extended my main monitor , not from the other 3 sides. and this is in the editor , i havent tested a built game yet.

    Leave a comment:


  • replied
    Got one thing to work (Creating items) by importing my own character and skeleton to set the created items to. Only problem I have now (which occured before I did this) is that Head items doesn't show up at all when you equip them. Can't seem to find anything wrong with the code, and I have not changed anything in the code that should change this.

    Edit: Oh my god. My friend laughed at this issue and it turns out he changed the scale in PlayerCharacter for head items to 0.04. Spent hours to fix this issue, holy cow.
    Last edited by Askyl; 08-20-2017, 02:17 PM.

    Leave a comment:


  • replied
    Originally posted by Kultured View Post
    Yeah its obviously something I have done to mess everything up and I am trying to hunt down where it is that I have messed something up to remove it and fix these "Accessed None" reference errors.
    Depending on the time you've spent tweaking it you mite be better off starting fresh? to me it looks like your broken the InitializePlayer for the inventory in your player controller.

    Leave a comment:


  • replied
    Your issue isn't to do with a REINST bug its to do with what you have changed.
    Yeah its obviously something I have done to mess everything up and I am trying to hunt down where it is that I have messed something up to remove it and fix these "Accessed None" reference errors.

    Leave a comment:


  • replied
    Hi, I've not really played around much in 3D programs. I've just learnt the basics in Blender. Can someone please explain to me how to create an item for the EU4 Mannequin? It works with weapon, rings and offhand but not with anything else.

    To test I just created a box. But it just disappear when you try to equip it? I really don't understand how you should build the skeleton for the hat. Or do I need to export the SK Mannequin skeleton to Blender and use? If someone could write a small guide / tutorial that'd be great!

    Edit: Created my own character using my own skeleton and got it to work!
    Last edited by Askyl; 08-20-2017, 11:18 AM.

    Leave a comment:


  • replied
    Originally posted by ShadowOf047 View Post
    Any one got any ideas for this question ?

    Pretty sure that was fixed what version are you using and did you pay for it?


    Originally posted by Kultured View Post
    Confirmed, they read"[Inventory Slot]"

    Your issue isn't to do with a REINST bug its to do with what you have changed.

    Leave a comment:


  • replied
    Originally posted by ShadowOf047 View Post
    Hello .
    I just started with this asset and i have to say it is great .

    Only problem i encountered was that i could drag widgets ( inventory , equipment,etc) out of the screen , and leave them there , which essentially makes them useless . is this intended ?
    Any one got any ideas for this question ?

    Leave a comment:


  • replied
    Originally posted by unit23 View Post
    When you hover over inventory slots of your equipment widget, the text just reads Inventory Slot?
    Confirmed, they read"[Inventory Slot]"

    Leave a comment:

Working...
X