Announcement

Collapse
No announcement yet.

Chameleon Post Process

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Rob McLachlan View Post
    I found it convenient to change the Blend Mask default in both the base AdvancedEffectFeatures structs from Null to T_White (from Chameleon/Textures), which saves having to add it every time to each postprocess category. I suspect this is what it's meant to be by default (especially going by screenshots in this thread) - the latest version doesn't seem to be correct.
    Yes, that was the intention. Did you tried to re-import Chameleon with clean download from the launcher? (AKA "Remove Local Content")
    SUMFX.net

    Chameleon Post ProcessSharp TextCamera TransitionsLOOK! Color Grading PackSciFi UI SoundsCensoredAnimated CrosshairsMinimalist Lower ThirdsCosmos - Procedural Space AssetsHitPoint

    Comment


      Originally posted by SumFX View Post

      Hi,

      I can't reproduce the problem. This was a known bug and it was fixed already. Below is the results of my tests with no artifacts. Can you (privately) send me a sample project which this problem occurs? I'm using 4.19.2 with Chameleon 10.0

      Click image for larger version

Name:	KOff.JPG
Views:	1
Size:	435.8 KB
ID:	1485193
      Click image for larger version

Name:	KOn.JPG
Views:	1
Size:	401.5 KB
ID:	1485194
      Ah I didn't know it had been fixed- I didn't see you mention it on the forum or the release notes.
      I will check again with the new version.

      Kind regards

      Comment


        Gotta say, this is the best Post Process addon I've seen.
        Discord: OP #5992

        Comment


          Originally posted by benmerrick3d View Post

          Ah I didn't know it had been fixed- I didn't see you mention it on the forum or the release notes.
          I will check again with the new version.

          Kind regards

          No problem. I think you missed it. It was mentioned in the changelog as "Fix: Kuwahara is now before tone mapping to prevent “black lines & dirt” in final image"
          Please let me know about the result.
          SUMFX.net

          Chameleon Post ProcessSharp TextCamera TransitionsLOOK! Color Grading PackSciFi UI SoundsCensoredAnimated CrosshairsMinimalist Lower ThirdsCosmos - Procedural Space AssetsHitPoint

          Comment


            Originally posted by SumFX View Post

            Yes, that was the intention. Did you tried to re-import Chameleon with clean download from the launcher? (AKA "Remove Local Content")
            I'm getting this too, I just updated from v9 to v10 hoping for a fix but it's showing the same behaviour. I've tried the suggestion on the previous page of replacing the null blend mask with T_White but this doesn't do anything, if I then drop T_White into the Blend Mask in the Chameleon BP it breaks it completely (no effects visible) and I have to revert the Structures to get it working again.

            Attached Files

            Comment


              Originally posted by triff View Post

              I'm getting this too, I just updated from v9 to v10 hoping for a fix but it's showing the same behaviour. I've tried the suggestion on the previous page of replacing the null blend mask with T_White but this doesn't do anything, if I then drop T_White into the Blend Mask in the Chameleon BP it breaks it completely (no effects visible) and I have to revert the Structures to get it working again.
              Thanks for reporting it. I'll have to look this deeper since for now, I couldn't reproduce it.
              SUMFX.net

              Chameleon Post ProcessSharp TextCamera TransitionsLOOK! Color Grading PackSciFi UI SoundsCensoredAnimated CrosshairsMinimalist Lower ThirdsCosmos - Procedural Space AssetsHitPoint

              Comment


                Originally posted by SumFX View Post

                Thanks for reporting it. I'll have to look this deeper since for now, I couldn't reproduce it.
                All that works for me is putting T_White in the individual mask inputs.

                On a related mask note, how would I go about layering two versions of an effect, say I want one mask on the monitor effects lines and a different mask on the distortion? I could duplicate/edit the base mat but that'd be a hassle every time I update. If there's a more sensible way, I'm all ears

                EDIT: Got as far as establishing I'd need to edit both the PP mat itself andf MF_SetBlending to add a second mask, and decided to give up before I get in a right old pickle Probably easier to just use another instance of the mat in a standard PostProcess volume.
                Last edited by triff; 06-07-2018, 02:00 PM.

                Comment


                  Originally posted by triff View Post

                  All that works for me is putting T_White in the individual mask inputs.

                  On a related mask note, how would I go about layering two versions of an effect, say I want one mask on the monitor effects lines and a different mask on the distortion? I could duplicate/edit the base mat but that'd be a hassle every time I update. If there's a more sensible way, I'm all ears

                  EDIT: Got as far as establishing I'd need to edit both the PP mat itself andf MF_SetBlending to add a second mask, and decided to give up before I get in a right old pickle Probably easier to just use another instance of the mat in a standard PostProcess volume.
                  Currently, single texture mask supported only. And please note that, if you update the Chameleon all your modifications would be overwritten.
                  SUMFX.net

                  Chameleon Post ProcessSharp TextCamera TransitionsLOOK! Color Grading PackSciFi UI SoundsCensoredAnimated CrosshairsMinimalist Lower ThirdsCosmos - Procedural Space AssetsHitPoint

                  Comment


                    Is there a way to get more screen detals to the Post Process chameleon ?
                    Discord: OP #5992

                    Comment


                      Originally posted by Coverop View Post
                      Is there a way to get more screen detals to the Post Process chameleon ?
                      I didn't understand the question. Can you be more specific?
                      SUMFX.net

                      Chameleon Post ProcessSharp TextCamera TransitionsLOOK! Color Grading PackSciFi UI SoundsCensoredAnimated CrosshairsMinimalist Lower ThirdsCosmos - Procedural Space AssetsHitPoint

                      Comment


                        Originally posted by SumFX View Post

                        I didn't understand the question. Can you be more specific?
                        Your Chameleon Post Process addon has over 60 presets.
                        One of them is called "Screen Decal" and It's limited 4 images.

                        Is there a way to increase that limit?
                        Discord: OP #5992

                        Comment


                          Originally posted by Coverop View Post

                          Your Chameleon Post Process addon has over 60 presets.
                          One of them is called "Screen Decal" and It's limited 4 images.

                          Is there a way to increase that limit?
                          It is not possible without altering the Chameleon blueprint and the related material(s). If you choose this path you must note that next update of the Chameleon would overwrite all your modifications unless you make these operations on the copies of all assets in question. It's in my plans to increase this hard-coded limit but no ETA yet.
                          SUMFX.net

                          Chameleon Post ProcessSharp TextCamera TransitionsLOOK! Color Grading PackSciFi UI SoundsCensoredAnimated CrosshairsMinimalist Lower ThirdsCosmos - Procedural Space AssetsHitPoint

                          Comment


                            I decided today to upgrade from 4.18.3 to 4.19.2 my Unreal Engine.
                            When I executed my project, a brick border become visible all the time. Investigating this weird thing, have noticed that is Chamaleon FX related with it. So If I active or enable any Effect, the brick border appears. If I disable it, it dissapears.

                            The weird brick border thing is this:
                            https://answers.unrealengine.com/sto...8+14.44.54.png

                            And more people had problems like this one in Unreal Forum which contains useful stuff:
                            https://answers.unrealengine.com/que...update-49.html
                            https://answers.unrealengine.com/que...fter-upgr.html

                            Attached Files
                            Last edited by gon.; 06-12-2018, 09:26 PM.

                            Comment


                              Originally posted by SumFX View Post

                              Yes, that was the intention. Did you tried to re-import Chameleon with clean download from the launcher? (AKA "Remove Local Content")
                              Cool, glad I was on the right track. I didn't try Remove Local Content however it did download the new version into a separate folder in my Marketplace Vault Cache so shouldn't have got any of the old stuff at that stage.

                              However I do have to import into a separate project and Migrate into my main project since I have a different folder structure in my main project. I checked out all files under Chameleon/ in source control (Perforce) then used Migrate to overwrite them. Possible there's something hanging around from the older version but I would have thought all the references would have been updated as well?

                              Might be some sort of struct weirdness, as they are pretty flaky at times... All is working fine for me now after replacing the missing default T_White in both the structs.

                              Comment

                              Working...
                              X