Announcement

Collapse
No announcement yet.

Quality Game Settings Menu, a good looking UI ready for use

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by BarisT View Post
    Hello;
    Here is my problem.
    The packed game doesn't crate "GameSaveSettings.sav" upon first running at the location of "C:\Users\UserName\AppData\Local\MyGame\Saved\SaveGames\SettingsSaveFile.sav"

    It does create the "GameSaveSettings.sav" only after I launch the game and press "apply" in the menu. I want to be able to launch the game with default settings that I adjust with BPGameSettings, but I can't.

    For instance, in my combobox I use "language options", since the settings are not applied, the game doesn't display any language options upon first launch of the game. I have to manually apply settings only after I launch the game.
    Any ideas?
    I tried the suggestion in the manual 8.1, since settings are not applied on game start but nothing changed.
    Everything is working in the editor, but not in packed game.
    Hi, I am a bit unsure why your language option is having trouble, but I can explain the start process of the menu.
    • Game starts the first time
    • It calls "Init Game Settings" from game instance
    • It looks for an existing GameSaveSettings.sav, but not finding it since its the first start time.
    • Then a new BP_GameSettings blueprint be created instead, and use its default values.
    • BP_GameSettings then overwrite some of its video settings from standard UE GameUserSettings.ini in function "Load ini Settings".
      • (You can disable this by disconnecting nodes in "Load ini Settings"
    • Then the PlayerController creates the menu widget
    • The menu widget applies all settings in BP_GameSettings so it works at game start.
      • (Settings are not applied as a part of "Init Game Settings", since it did not properly work in game instance. (I have not checked if it works in later UE releases))
    • An initial GameSaveSettings.sav will not be created until user press apply in settings menu
      • (This is to make it easier to test default values during development)
    So in short, if you only want to use all default settings in BP_GameSettings during first start and create a .sav file. then disconnect "Load ini Settings" in BP_GameSettings, and save settings during right after they are initialized.


    I do not know your blueprints on language combobox, but if you store the language selection as a part of BP_GameSettings (see part 5.1 of manual), you should be able to load selected language from the game settings object during your widget "Event Construct".


    Originally posted by BarisT View Post
    I have one more question : Isn't there no way to add game-pad support to buttons and sliders using the function "keyboard focus"?
    The engine system for keyboard focus was not good enough, I tried to solve it with my own flexible system for gamepad menu navigation, but it got too complex in blueprint and I hit upon weird engine issues .



    Originally posted by BarisT View Post
    Isn't this project supported anymore?
    Originally posted by gillechri0st View Post

    Ah ok, that would explain it then. Any rough ETA on a fix?
    I unfortunately can only provide customer support when I have time. A full time job does that to you. I had a large update I wanted to finish last year, but I could never get around the engine issues. If i have to update, I need to rewrite the system for a third/fourth time, and hope I can finally get it right. I want to recreate and finish it, (Since there are a lot of good stuff in it) but I don't have the time for it.
    Marketplace: Quality Game Settings

    Comment


      Hi Scraphead.
      How can i change the time that system waits a key to be pressed for remapping? thanks

      Comment


        In the manual, you mention that it doesn't compile on Nativized Assets. It seems there are a couple of variables that the log says are private and are throwing an error. The one that is halting the compiler is PreviousSettingState. If you unset the Private flag it should compile, although I don't know why.

        Comment


          Update ?

          Comment


            Hi, I'm getting a warning that I'm pretty sure is being caused by this plugin. When I run my game, "GetKeyValue cannot return a meaningful result for AnyKey" gets printed to the dev console (or error log, in packaged versions) every tick. I've already tried searching blueprints that use GetKeyValue, with no luck. Any advice?

            Comment


              What do I have to change to work in 4.21?

              Comment


                Originally posted by OsoArcade View Post
                What do I have to change to work in 4.21?
                It's pretty simple actually. Go to Qualitymenu\HUD_UMG_Classic\UtilWidgets
                Then open "WB_Classic_Keybinding_categoryItem".
                Rename the textbox "Category Name" to literally anything else. In my case I called it "Category Name 1". Then it should compile just fine. That was the only major issue I had with 4.21. It's still working just fine on 4.22 as well.
                Strife - 1996 - Remake

                Comment

                Working...
                X