Announcement

Collapse
No announcement yet.

[SUPPORT] Advanced Turn Based Tile Toolkit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by leo bar View Post
    ok after a lot of work manage to get it going. hope i wont have to go through all of that on every update

    cheers
    leo
    How about that! Sorry, I read your message pre-edit earlier today, but had to get done with work before I could get to it, since I felt I needed to give an in-depth answer. I had time now, but if you figured it all out on your own all the better
    The Advanced Turn Based Tile Toolkit (Marketplace page - Feedback thread)

    Comment


      hi knut

      i manage to do it but i am struggling with the reference to the grid index (its now not in my unit, only on the grid actor) and all the other blueprints need this value from the unit.
      what is the best way to do it?
      and its ok i understand you are busy so no problem at all

      cheers
      leo

      Comment


        Originally posted by leo bar View Post
        hi knut

        i manage to do it but i am struggling with the reference to the grid index (its now not in my unit, only on the grid actor) and all the other blueprints need this value from the unit.
        what is the best way to do it?
        and its ok i understand you are busy so no problem at all

        cheers
        leo
        I take it you've set it up so that you are using a custom made unit class that does not inherit from GridActor? I'm going to assume this. If so, you can make a new GridIndex variable for your custom unit blueprint. Take a look at the construction script of BP_GridActor to see how it is calculated. Then, for every place in the toolkit where GridIndex is normally gotten from BP_Unit you need to change it to instead get it from your custom unit class.
        The Advanced Turn Based Tile Toolkit (Marketplace page - Feedback thread)

        Comment


          i made the bp_unit re parent to character so noting from the gridactor. i did what you said and made GridIndex variable in my new bp_unit, but it just seem like i doplicate almost everything from the gridactor to my bp_unit. even the consturction script. am i out of it??

          Comment


            Originally posted by leo bar View Post
            i made the bp_unit re parent to character so noting from the gridactor. i did what you said and made GridIndex variable in my new bp_unit, but it just seem like i doplicate almost everything from the gridactor to my bp_unit. even the consturction script. am i out of it??
            Yep, that is basically how it worked a few updates ago and one of the reasons I decided to refactor it. You need to more or less copy over everything from BP_GridActor if you want it to work this way.
            The Advanced Turn Based Tile Toolkit (Marketplace page - Feedback thread)

            Comment


              yep got it, i feel so stupid its not so complicated but somehow i struggle for hours. but its good i learned few things.
              thank a lot

              cheers
              leo

              Comment


                Originally posted by leo bar View Post
                yep got it, i feel so stupid its not so complicated but somehow i struggle for hours. but its good i learned few things.
                thank a lot

                cheers
                leo
                No need to feel stupid. I've also struggled for ages to fix things up when I've changed something in one of the blueprints and forgot to change it in the other, or use the wrong GridIndex or whatever. Good riddance too it, and I'm happy I refactored it. It is unfortunate that it makes things a bit trickier for these kinds of corner cases, of course. All of this would not be necessary if Epic included things like the movement component etc. as components that are fully available to all blueprints, but oh well. A man can dream.
                The Advanced Turn Based Tile Toolkit (Marketplace page - Feedback thread)

                Comment


                  Hello
                  I have problem with animation in diffrent skeleton. I've setup new BP for animations, and Unit (I copied BP_Unit_Anim and change mesh, Animate Movement, Animate Ability and cast) and still my movement is not working. I don't know what else I must change.
                  Second problem that I have is when my new unit attacks enemy game stops in some kind of loop and nothing is happening.
                  Regards

                  Comment


                    Originally posted by sokolman View Post
                    Hello
                    I have problem with animation in diffrent skeleton. I've setup new BP for animations, and Unit (I copied BP_Unit_Anim and change mesh, Animate Movement, Animate Ability and cast) and still my movement is not working. I don't know what else I must change.
                    Second problem that I have is when my new unit attacks enemy game stops in some kind of loop and nothing is happening.
                    Regards
                    Could you be a bit more specific in how it is not working? Is the unit stuck in T-pose? Does it have an idle animation, but does not change to the move animation when moving? Something else? For the game stopping after attacking, I'm guessing EndAction is never called. Take a look at the included ABP. You'll see that the animations include notifies that call back to the event graph of the ABP to end the action. If you're not doing this or something similar the game will have no way of knowing the animation has ended after attacking, and so the game will not proceed.
                    The Advanced Turn Based Tile Toolkit (Marketplace page - Feedback thread)

                    Comment


                      Originally posted by Monokkel View Post

                      Could you be a bit more specific in how it is not working? Is the unit stuck in T-pose? Does it have an idle animation, but does not change to the move animation when moving? Something else? For the game stopping after attacking, I'm guessing EndAction is never called. Take a look at the included ABP. You'll see that the animations include notifies that call back to the event graph of the ABP to end the action. If you're not doing this or something similar the game will have no way of knowing the animation has ended after attacking, and so the game will not proceed.
                      Idle animation is working and it's not changing to move animation, but in BP when simulating speed float has value and it's passing to Animate Movement. I will check EndAction.

                      Comment


                        Originally posted by Monokkel View Post

                        Could you be a bit more specific in how it is not working? Is the unit stuck in T-pose? Does it have an idle animation, but does not change to the move animation when moving? Something else? For the game stopping after attacking, I'm guessing EndAction is never called. Take a look at the included ABP. You'll see that the animations include notifies that call back to the event graph of the ABP to end the action. If you're not doing this or something similar the game will have no way of knowing the animation has ended after attacking, and so the game will not proceed.
                        Hello, I found this events on animations, thanks for showing this! Now all is working good!
                        Regards

                        Comment


                          Originally posted by sokolman View Post

                          Hello, I found this events on animations, thanks for showing this! Now all is working good!
                          Regards
                          Great to hear! Let me know if you run into any other issues.
                          The Advanced Turn Based Tile Toolkit (Marketplace page - Feedback thread)

                          Comment


                            Hi Monokkel ! How makes unit do not shoot through each other ?
                            Last edited by Lexx; 10-08-2018, 02:39 AM.

                            Comment


                              Hey, Lexx ! Visibility is determined by whether or not the trace channel RangeTrace is blocked. You can make units block line of sight by adding a collision box to the unit that is set up to block RangeTrace in its collision settings. Other than this you need to make sure that the unit does not block its own line of sight, so on unit activation set collision to false for this collision box, and then set collision to true again on unit deactivation.
                              The Advanced Turn Based Tile Toolkit (Marketplace page - Feedback thread)

                              Comment


                                Originally posted by Monokkel View Post
                                Hey, Lexx ! Visibility is determined by whether or not the trace channel RangeTrace is blocked. You can make units block line of sight by adding a collision box to the unit that is set up to block RangeTrace in its collision settings. Other than this you need to make sure that the unit does not block its own line of sight, so on unit activation set collision to false for this collision box, and then set collision to true again on unit deactivation.

                                Unfortunately this not worck, in this way you can't shoot, enemy unit mark as wall.

                                Comment

                                Working...
                                X