Announcement

Collapse
No announcement yet.

[RELEASED] [SUPPORT] Female Hero: Action adventure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [RELEASED] [SUPPORT] Female Hero: Action adventure

    Hello. This asset support thread is Female Hero: Action adventure.

    Female Hero: Action adventure

    Update 10.06.20 (01)

    -
    Fixing up an body master material. Replacing the wrong texture sampler node.
    - Fixing up mistakes in the name of the morph targets.


    Update Guide:
    1. Before updating, backup your project. Add the updated asset to the new project and make a migration to your project.
    3. Confirm assets rewriting.


    A naked body available with quick guide.
    Link to textures below:

    https://drive.google.com/file/d/1h-WvioFGDv9t-r5BDmFQS57igIwjDFrG/view?usp=sharing



    1. Download and export *TGA textures to your asset wherever you want.
    2. Important! Disable sRGB checkbox in texture maps through Texture Properties Editor. The list of the maps:
    T_Body_Nudity_A_01_M
    T_Body_Nudity_A_02_M
    T_Body_Nudity_A_03_M
    3. Duplicate master material M_SkinBody_A_Master_01 and open it in the texture editor.
    4. Replace 5 texture samplers with similar ones without Nudity mark from the list:
    T_Body_Nudity_A_01_BC
    T_Body_Nudity_A_01_M
    T_Body_Nudity_A_01_N
    T_Body_Nudity_A_02_M
    T_Body_Nudity_A_03_M
    Save and compile material.

    5. * Advanced users can convert texture samplers to texture parameters in the original master material and replace this in the material instance.

    An asset with breast physics is available at the link below:
    https://drive.google.com/file/d/1L38...ew?usp=sharing
    Last edited by Daemon3d; 06-11-2020, 02:47 AM.

    #2
    Hey Daemon,

    Love the character!

    I'd love to ask about an issue I'm having with the neck, there seems to be some sort of artifacting while in the level (lighting issue?). It does not appear in the blueprint viewport it seems.

    EDIT: Same issue appears on fingers and toes.

    On the left, in the editor viewport (realtime), on the right, in the blueprint viewport:
    https://imgur.com/GVmJGCI

    The screenshot I made with BP_FemActHero_Variations_A_03.

    Sidenote, do you have a Discord available?

    Cheers
    Last edited by Mavmat; 06-02-2020, 02:18 PM.

    Comment


      #3
      Originally posted by Mavmat View Post
      Hey Daemon,

      Love the character!

      I'd love to ask about an issue I'm having with the neck, there seems to be some sort of artifacting while in the level (lighting issue?). It does not appear in the blueprint viewport it seems.

      EDIT: Same issue appears on fingers and toes.

      On the left, in the editor viewport (realtime), on the right, in the blueprint viewport:
      https://imgur.com/GVmJGCI

      The screenshot I made with BP_FemActHero_Variations_A_03.

      Sidenote, do you have a Discord available?

      Cheers
      Hey.
      There seems to be something with the lighting setup.

      Comment


        #4
        Originally posted by Daemon3d View Post

        Hey.
        There seems to be something with the lighting setup.
        Right, any idea how we can fix it? I'm using UltraDynamicSky. The moment I drop it in, this happens. I checked further, the issue disappears when I disable "CubeMap_SkyLight" within UDS, somehow there's an incompatibility with this.

        Comment


          #5
          Originally posted by Mavmat View Post

          Right, any idea how we can fix it? I'm using UltraDynamicSky. The moment I drop it in, this happens. I checked further, the issue disappears when I disable "CubeMap_SkyLight" within UDS, somehow there's an incompatibility with this.
          So the problem is in UltraDynamicSky.
          There can be many reasons. Maybe it is not compatible with sss shader
          Try to disable the SSS nodes in the master material and check it out.

          Comment


            #6
            Originally posted by Daemon3d View Post

            So the problem is in UltraDynamicSky.
            There can be many reasons. Maybe it is not compatible with sss shader
            Try to disable the SSS nodes in the master material and check it out.
            I had to do some more digging, but turns out it is not just UDS.

            To reproduce it:
            * Create a new level in Unreal (default preset)
            * Set the skylight to movable

            Notice how there's issues around the head, fingers, and toes.

            I tried the SSS thing but I don't think it solved it. Could you try to reproduce it on your end with the steps I listed?

            Comment


              #7
              Originally posted by Mavmat View Post

              I had to do some more digging, but turns out it is not just UDS.

              To reproduce it:
              * Create a new level in Unreal (default preset)
              * Set the skylight to movable

              Notice how there's issues around the head, fingers, and toes.

              I tried the SSS thing but I don't think it solved it. Could you try to reproduce it on your end with the steps I listed?
              Just checked on your request
              I did not notice such artifacts.

              What version of engine are you using? I checked in 4.19
              In new versions, something new may have appeared. Click image for larger version  Name:	Lighting_test Skylight movable.jpg Views:	0 Size:	326.1 KB ID:	1772466

              However, your artifacts are 100% related to the SSS (Subsurface Scattering) feature.
              This is easily verified by pressing Atl + F3 Unlit mode view.

              You can create new material without the SSS feature and check out these artifacts.
              Last edited by Daemon3d; 06-07-2020, 03:02 AM.

              Comment


                #8
                Originally posted by Daemon3d View Post

                Just checked on your request
                I did not notice such artifacts.
                I tried again in an empty test project, and noticed that the auto-exposure masks the issue. For it to be visible, try locking the EV100 to a value without the auto-exposure by disabling the Game Settings exposure parameter:


                (Here the issue is seen on the hands, for instance)

                Originally posted by Daemon3d View Post

                What version of engine are you using? I checked in 4.19
                In new versions, something new may have appeared.
                Good thinking, I'm on 4.24.3.

                Originally posted by Daemon3d View Post

                However, your artifacts are 100% related to the SSS (Subsurface Scattering) feature.
                This is easily verified by pressing Atl + F3 Unlit mode view.

                You can create new material without the SSS feature and check out these artifacts.
                I'd be very sad to have to disable SSS, can't we fix this issue somehow?

                I checked the Unlit move view for you, looks like this:

                Comment


                  #9
                  Originally posted by Mavmat View Post
                  The easiest way to solve the problem is to disable SSS.
                  I also wonder how to get around this problem.
                  Hope this can be resolved but I don’t know how.

                  upd:
                  It’s strange. I turned off the exposure and do not see artifacts.
                  Try checking on a different engine version. It seems your version is not stable. Click image for larger version  Name:	Exposure Disable.jpg Views:	0 Size:	175.2 KB ID:	1772552


                  Also checked on 4.24
                  everything is fine.
                  I can advise you to turn off plugins and check it out in a clean project.
                  And reinstall or verify the engine version.
                  Click image for larger version

Name:	4_24.jpg
Views:	502
Size:	168.1 KB
ID:	1772558
                  Last edited by Daemon3d; 06-07-2020, 09:46 AM.

                  Comment


                    #10
                    Hello Daemon3d

                    Thanks for putting this great model up on the marketplace!

                    I already have a character blueprint with animations/blendspaces, different interactions, shooting etc etc. all setup and working. Now I was trying to finally replace the UE4 default mannequin with your female-hero figure. My UE4 mannequin has 1 skeleton mesh. The female hero-figure however is comprised of many different skeleton meshes (for modularity) with the head mesh as the root. As your figure is scaled and rigged to the epic skeleton (as is my UE4 mannequin) it should be a matter of simply replacing the UE4 skeleton mesh with your figure skeleton-meshes, right?
                    I tried assigning my UE4 Skeleton to the female-figure head skeleton mesh for example following these instructions: https://answers.unrealengine.com/que...mesh-help.html
                    It shows that the female hero skeleton hat many more bones than my UE4 skeleton and throws a warning "Failed to merge bones" and asks if I would like to regenerate the skeleton from this.
                    I don't know how to proceed now because I fear this will mess up my existing skeleton... Could you please give me a hint how I could solve this?
                    My goal is to replace my single UE4 mannequin skeletal mesh with the female figure skeleton meshes and use my existing skeleton and animation blueprint.

                    Thanks in advance!

                    Best

                    Marian
                    Last edited by Nairam; 06-09-2020, 01:56 PM.

                    Comment


                      #11
                      Originally posted by Nairam View Post
                      Hello Daemon3d
                      Hello. You cannot just assign a skeleton. You need use retarget animation workflow.

                      Comment


                        #12
                        Originally posted by Daemon3d View Post

                        Hello. You cannot just assign a skeleton. You need use retarget animation workflow.
                        Ok, thanks I'll try that!
                        ​​​​​​​

                        Comment


                          #13
                          Hey, question! How did you set up her hair to have dynamics/physics? I'd like to have that working but I can't seem to figure it out.

                          Comment


                            #14
                            Originally posted by Xenosas View Post
                            Hey, question! How did you set up her hair to have dynamics/physics? I'd like to have that working but I can't seem to figure it out.
                            Hey.
                            Take a look at my other asset. This works the same way.
                            https://cdn1.epicgames.com/ue/produc...87bd8c0643.png

                            Comment


                              #15
                              Originally posted by Daemon3d View Post

                              Hey.
                              Take a look at my other asset. This works the same way.
                              https://cdn1.epicgames.com/ue/produc...87bd8c0643.png
                              Thanks! It worked. I knew I was probably missing a step somewhere.

                              Comment

                              Working...
                              X