Announcement

Collapse
No announcement yet.

Electronic Nodes - Wiring style for blueprint and material editors.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hey AndreasG, I try to improve it now and then (well, I admit I did not touch it in the past months).

    I wanted to make it stable, but the thing is the offset depends a bit on the order you plugged the wires. So I keep the word "experimental" because it's still not the way I wanted it to be.
    But I'm not event sure it's possible to make it fully stable without going crazily complex.

    In any case, even with the word "experimental", this feature should be perfectly usable and you'll hardly notice the problem, especially if you use the "Subway" wire style.
    Still, if you come across any weird behavior, feel free to create an issue on the github and I'll take a look at it

    Leave a comment:


  • replied
    How's the ribbon feature coming along? Is it still experimental?

    Leave a comment:


  • replied
    Roxford7 You can of course put the plugin in your project plugins directory so that the whole team have access to it!
    But they can't use it in another project though, like if they want to use it on some personal projects, they should buy the plugin.

    Leave a comment:


  • replied
    Can I share this plugin with team I am belonging to?

    Leave a comment:


  • replied
    Saiodin Sitrec Hey guys! Well, it was a real pain but the shortcut thing to make it compatible with NGA is happening (better late than never!).

    You'll have to set a shortcut in your Editor Settings and you will be able to activate/deactivate the plugin in a glimpse.

    Click image for larger version  Name:	2020-07-18_17-53.png Views:	0 Size:	18.4 KB ID:	1789895

    It will be available on the next update of the plugin coming next week (2.6).

    Bozarre_ Cool thing that you found it pretty quickely ! But that still should not happen... Maybe I should encapsulate the whole plugin in a big "#if WITH_EDITOR"...

    Leave a comment:


  • replied
    I found the issue, It requires the Engine sources to compile.

    Leave a comment:


  • replied
    Hi,

    I'm using your plugin in a cpp project. I want to use the plugin in my project only, so I moved the ElectronicNodes folder from the engine's /Plugins to my project's /Plugins

    It was working fine for some time, but recently i had this error when I try to build my project:

    Code:
    Severity Code Description Project File Line Suppression State
    Error C1083 Cannot open include file: 'AnimGraphConnectionDrawingPolicy.cpp': No such file or directory EndeavorUE420 E:\Projects\Unreal Engine 4\Endeavor\EndeavorUE420\Plugins\Marketplace\ElectronicNodes\Source\ElectronicNodes\Private\ENAnimGraphConnectionDrawingPolicy.h 8
    Do you know what could be the issue ?

    Click image for larger version

Name:	2020-07-07 17_34_27-Cortana.png
Views:	213
Size:	42.6 KB
ID:	1785345

    Leave a comment:


  • replied
    请问我下载的为什么只能装4.23的引擎?别的版本无法使用,要怎么修改?

    Leave a comment:


  • replied
    FanaticNinja Ooooh I'm sorry, I missed your message!

    You just have to make your project C++. Just create a C++ class et delete it right away. That won't change anything for you. (source: https://forums.unrealengine.com/comm...borting-solved)


    Saiodin Well, I admit I pushed back the idea as it was a bit more difficult than expected and forgot about it :/ ... I'll try to make the key binding happen! (I won't implement Lazy Nodes though, as it's not very fair to its original creator)

    Leave a comment:


  • replied
    Hey Herobrine.

    I once asked (on the marketplace) if it's possible to have the Node Graph Assistant work in tandem with Electric Nodes. Especially the Lazy Node feature of Node Graph Assistant. Back then you wanted to implement a shortcut to toggle Electric Nodes. I've seen you added an option to toggle it in the editor preferences, but I don't see an option to assign a key for a toggle. That would help make me revisit Electric Nodes. But Lazy Node is just too powerful, it would be amazing if Electric Nodes had its own implementation of a Lazy Node mode. Cheers

    Leave a comment:


  • replied
    When I make a build (4.24) of my project with the plugin enabled, it wont launch.

    Code:
    LogPluginManager: Error: Unable to load plugin 'ElectronicNodes'. Aborting
    LogCore: Engine Exit requested (reason: EngineExit() was called)
    LogExit: Preparing to exit.
    Using version 2.4 of plugin.

    Leave a comment:


  • replied
    Giakkons I just re-downloaded it for 4.24.1 from the marketplace and I got the correct 2.4 version... Could you try to uninstall it, close the Epic Games launcher, and re-download it?

    Btw, you can see the version of the plugin directly from the editor by going to the plugins window (Edit/Plugins). You should see the version of the plugin in the top right corner of the plugin.

    Click image for larger version

Name:	726725958cb07c003a5c11ea98c9d347e3f222d8.png
Views:	315
Size:	95.1 KB
ID:	1710427

    Leave a comment:


  • replied
    Originally posted by Herobrine20XX View Post
    BulleTime It should be fixed for more than a week now... Please make sure you have the last version of the plugin (2.4)!

    You can update it from the Epic Game launcher by clicking on "installed plugin" right under your engine version
    Hi, on ue4 4.24.1 I'm still getting logspammed with the updated Plugin any guess?

    EDIT: went to dig into the uplugin file and result as 2.3, sadly Epic Launcher won't let me download any other version, as far as it's concerned, 2.3 is the last one available for UE4 4.24.1
    Last edited by HeavyCoat Games; 01-17-2020, 09:53 PM.

    Leave a comment:


  • replied
    Thanks! Just updated any its gone.

    Leave a comment:


  • replied
    BulleTime It should be fixed for more than a week now... Please make sure you have the last version of the plugin (2.4)!

    You can update it from the Epic Game launcher by clicking on "installed plugin" right under your engine version

    Leave a comment:

Working...
X