Announcement

Collapse
No announcement yet.

Electronic Nodes - Wiring style for blueprint and material editors.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Short notice: Many people told me that the plugin was way too cheap ($5.99) and I don't want to miss a chance of financing a bit my game... But I don't want to be that guy who just higher the price without noticing anyone. So I'll let it to $5.99 for this week and then rise it up to $7.99-$11.99 (don't know yet).

    EDIT : I got some many people telling me to charge more, I may rise it up a bit quickely ^^'...
    Last edited by Herobrine20XX; 08-15-2019, 03:49 PM.

    Comment


      #17
      Even you say activating the plugin will not magically clean all your stuff for you, it actually did. Great work! I really like it.

      Comment


        #18
        Instant buy - after seeing that it affects the material nodes as well. Great work!

        Comment


          #19
          Thank you very much ! Quick note: the plugin is now compatible with 4.20 and 4.21 (I'm currently downloading the 4.18 and 4.19 version of the engine to make it compatible with it)
          Last edited by Herobrine20XX; 08-15-2019, 04:02 PM.

          Comment


            #20
            Well, that was quick. I saw your warning today that the price would rise starting next week, but going to the marketplace page, it has already gone up. Oh well. I guess I'll wait then.

            Comment


              #21
              Originally posted by ronm6667 View Post
              Well, that was quick. I saw your warning today that the price would rise starting next week, but going to the marketplace page, it has already gone up. Oh well. I guess I'll wait then.
              I'm really sorry, I thought people that saw my message either had already bought it or were not interested... I feel like I raised it a bit quickly now, but going back wouldn't be fair to those who bought it at that price. I promise the price won't evolve from now (unless I add some big features, but that's not planned in the short term).

              (And considering all the messages I got regarding the price, I think the new price is pretty fair)

              (But again, really sorry, it's all my fault, got a bit of pressure and I should have wait)
              Last edited by Herobrine20XX; 08-15-2019, 04:59 PM.

              Comment


                #22
                It's really not a big problem. I will probably still grab it when I make other purchases during the next sale (which is what I was planning on doing anyway). It's just that when you posted the warning, I thought there would be enough time to do the impulse buy and grab it at the original price (which is probably what you were aiming for with that post in the first place).

                Comment


                  #23
                  I bought this at the increased price, don't really care, it's still a good price imo... but how the heck do I get this installed in a source built engine 4.22.3
                  I added Marketplace -> Electronic Nodes folders to the Plugins folder & rebuilt the VS code, but those folders aren't appearing in VS. Is it a version thing or a build.cs line somewhere? Thanks.

                  Comment


                    #24
                    Hum, try this:
                    1 - Copy the "Electronic Nodes" folder from the "Marketplace" folder and paste it inside "[your game folder]/Plugins"
                    2 - Delete the folder "Binaries" and "Intermediate"
                    3 - Launch UE4 with your game (normally, it will build the plugin at this stage)
                    4 - Make sure the plugin is activated in the "Edit/Plugins" window

                    Hope this help, could you tell me if that worked?

                    (Sorry for the price...)

                    Comment


                      #25
                      1. When wire length is extensive, the rendering becomes wonky.
                      Click image for larger version  Name:	electronic_nodes_wonky_wires.png Views:	1 Size:	58.1 KB ID:	1653811
                      It's not unlike the default editor behavior but hope there's something that can be done about it.
                      The wire render styles in Node Graph Assistant, for example, seem to work better in this particular regard:
                      Click image for larger version  Name:	node_graph_assistant_wires.png Views:	1 Size:	76.2 KB ID:	1653812

                      2. Another suggestion - I really like how the anchor point for wires is outside the node:
                      Click image for larger version  Name:	electronic_nodes_anchor_point.png Views:	1 Size:	27.9 KB ID:	1653813
                      Would like to see a setting to make that distance variable and be able to extend it further:
                      Click image for larger version  Name:	electronic_nodes_anchor_point_extended.png Views:	1 Size:	150.1 KB ID:	1653814
                      I think it would improve readability for instances where the end point is behind the starting point (like in the image above).

                      3. Force Draw Bubbles: Would it be possible to customize the draw style of that feature?
                      I like the general idea, but it is too much by default. A variable to control the frequency/amount of animated "bubbles" would be great.

                      4. Was able to compile for 4.18 but can't get it to work in 4.18 with Node Graph Assistant.
                      Electronic Nodes just doesn't work at all as long as the other plugin is enabled.
                      In 4.22 though, it does render as expected.

                      4.18 is old and support for it might seem irrelevant, but it is still useful especially for other marketplace creators.
                      If you could try it on your end, It would be much appreciated.
                      Last edited by Cpt.Trips; 08-16-2019, 12:13 PM.
                      [Marketplace] Loading Screen System (ᴘʀᴏᴘᴇʀ ʟᴏᴀᴅɪɴɢ sᴄʀᴇᴇɴs, ɴᴏᴡ ᴡɪᴛʜ ᴘʀᴏɢʀᴇss ʙᴀʀs)
                      [Free][Script] Automate Download of Mixamo Animations
                      [VłĐɆØ] Performance: BP vs C++ vs Blueprint Nativization

                      Comment


                        #26
                        Thank you very much for the very comprehensive feedback !

                        1 - Hum, this comes from the engine optimization, I'll try to do something about it. Note that the NGA plugin seems to work but it's because the line are always straight (and that's not the case with electronic nodes)

                        2 - Really easy to do, going to do it right now

                        3 - I didn't think that people would actually use that feature, it was more of a fun challenge to me... But as you're not the first one, I'll improve this a bit

                        4 - Yeah, electronic nodes conflicts with NGA... I sent a message to the creator to discuss what we can do about it :/...
                        I actually have a 4.18 and 4.19 version ready for people stucked in those versions, but Epic wouldn't let me put it on the market as "Only latest 3 engine version is allowed for code plugin category". (I think it's for the reviewers not to have a lot of versions of Unreal ?)

                        So thanks again for all your feedbacks, I'm also working on a new secret feature which I expect to be greatly appreciated
                        I hope to release the new version this week (or at least some screen of it)

                        Comment


                          #27
                          Originally posted by Herobrine20XX View Post
                          Hum, try this:
                          1 - Copy the "Electronic Nodes" folder from the "Marketplace" folder and paste it inside "[your game folder]/Plugins"
                          2 - Delete the folder "Binaries" and "Intermediate"
                          3 - Launch UE4 with your game (normally, it will build the plugin at this stage)
                          4 - Make sure the plugin is activated in the "Edit/Plugins" window

                          Hope this help, could you tell me if that worked?

                          (Sorry for the price...)
                          Hey, I got around to fixing my issue. The problem was I didn't GenerateProjectFiles correctly, I just needed to run as administrator and it all worked out. I added it as an Engine plugin, not project plugin.

                          It's beautiful. I might shed a tear.

                          Comment


                            #28
                            Ravishingx: Good news !

                            Cpt. Tripfx: I think I covered everything with these settings, do you see something else? (It will be available on the next update)

                            Click image for larger version

Name:	new_settings.png
Views:	30
Size:	74.1 KB
ID:	1654025

                            By the way, if you're using "roundRadius: 0", I suggest you add some extra reroute-nodes to better control the style:

                            Click image for larger version

Name:	new_example.png
Views:	30
Size:	26.5 KB
ID:	1654026

                            Comment


                              #29
                              Awesome, looking forward to the update.

                              One more suggestion: optional toolbar buttons for "Force Draw Bubbles" and to toggle through disabled/simple/complex from within the blueprint graph (or just on/off toggle). Maybe even a hotkey to show/hide the bubbles.
                              [Marketplace] Loading Screen System (ᴘʀᴏᴘᴇʀ ʟᴏᴀᴅɪɴɢ sᴄʀᴇᴇɴs, ɴᴏᴡ ᴡɪᴛʜ ᴘʀᴏɢʀᴇss ʙᴀʀs)
                              [Free][Script] Automate Download of Mixamo Animations
                              [VłĐɆØ] Performance: BP vs C++ vs Blueprint Nativization

                              Comment


                                #30
                                I missed the cheap price too, oh well.

                                Is a line width setting something you are looking into adding?

                                Also, complex drawing with tweaked radius size seems to be having some issues:

                                Click image for larger version

Name:	Skärmklipp.PNG
Views:	28
Size:	19.4 KB
ID:	1654389

                                Also noted that when zoomed out (even with default settings), the corners aren't as nice anymore:

                                Click image for larger version

Name:	Skärmklipp2.PNG
Views:	29
Size:	77.3 KB
ID:	1654390

                                And this might be only me, but the "reset to defaults" button doesn't seem to work...

                                Comment

                                Working...
                                X