Announcement

Collapse
No announcement yet.

CAMERA 360 System (Blueprints)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by ElizzaRF View Post

    Good afternoon!
    You're right, it's very strange. I'm thinking about a solution now. This problem is for some reason only in version 4.25, in the rest of this problem is not present.

    The good news is that if you run rendering, there will be no artifacts.

    The problem for some reason in Screen Space Reflection in in editor.

    There are two solutions so far:
    1. Add the 360 camera to the project later;
    2. Work as is, the 360 camera is not affected by this and the artifacts will not be on the final rendering.

    I think today I will find a solution to fix it or contact Epic Games for help.
    I found a problem in Unreal engine 4.25.
    Which causes artifacts to appear in the scene.
    For smoothing, I use the command
    r. PostProcessAAQuality 0-without smoothing,
    r.PostProcessAAQuality 2 - smoothing.
    So that's the problem with the engine.
    I will create a query in Epic Games.

    Temporary solution:
    If you are bothered by artifacts and don't need smoothing:
    1. Open Actor Camera Rec 360 and open Construction script and destroy line 1.

    1. If this doesn't bother you, you can still work like this: there are no flickering artifacts in the final render.
    2. i think Using Raytraysing. This error Screen Space Reflection

      When you disable the line, save the changes and restart the project. The problem will disappear

    Leave a comment:


  • replied
    Originally posted by ElizzaRF View Post
    Hi, Pulsestudio!
    I hope this helps you.
    I can't figure out what's going on from the picture ​ .
    Can you show your camera settings? It looks like the post process settings are being reset.
    If you use auto post-process configuration, then the all settings in post-process may be reset.
    Click image for larger version

Name:	image_197167.png
Views:	29
Size:	207.7 KB
ID:	1785751
    Note:
    -Planar Reflection - is not supported.
    -Sometimes seams may be visible. Not recommended to use ScreenSpaceReflection since the all camera's in unreal egnine used screen space.
    -Recomended use Raytracing reflection.


    Good afternoon!
    You're right, it's very strange. I'm thinking about a solution now. This problem is for some reason only in version 4.25, in the rest of this problem is not present.

    The good news is that if you run rendering, there will be no artifacts.

    The problem for some reason in Screen Space Reflection in in editor.

    There are two solutions so far:
    1. Add the 360 camera to the project later;
    2. Work as is, the 360 camera is not affected by this and the artifacts will not be on the final rendering.

    I think today I will find a solution to fix it or contact Epic Games for help.

    Leave a comment:


  • replied
    Originally posted by Pulsestudio View Post
    thanks for the sequence video, I will look at this and see if it works for us. Another issue is that when I add your camera to my scene I get strange flickering on my glossy materials.
    Click image for larger version Name:	Screenshot_Before_Adding_Camera.jpg Views:	0 Size:	157.6 KB ID:	1785718Click image for larger version Name:	Screenshot_After_Adding_Camera.jpg Views:	0 Size:	152.8 KB ID:	1785717

    Any thoughts on why this is happening? It starts as soon as I add the 360 point camera to the scene. Working in 4.25.1 by the way
    Hi, Pulsestudio!
    I hope this helps you.
    I can't figure out what's going on from the picture ​ .
    Can you show your camera settings? It looks like the post process settings are being reset.
    If you use auto post-process configuration, then the all settings in post-process may be reset.
    Click image for larger version

Name:	image_197167.png
Views:	29
Size:	207.7 KB
ID:	1785751
    Note:
    -Planar Reflection - is not supported.
    -Sometimes seams may be visible. Not recommended to use ScreenSpaceReflection since the all camera's in unreal egnine used screen space.
    -Recomended use Raytracing reflection.


    Last edited by ElizzaRF; 07-08-2020, 12:29 PM.

    Leave a comment:


  • replied
    thanks for the sequence video, I will look at this and see if it works for us. Another issue is that when I add your camera to my scene I get strange flickering on my glossy materials.
    Click image for larger version  Name:	Screenshot_Before_Adding_Camera.jpg Views:	0 Size:	157.6 KB ID:	1785718Click image for larger version  Name:	Screenshot_After_Adding_Camera.jpg Views:	0 Size:	152.8 KB ID:	1785717

    Any thoughts on why this is happening? It starts as soon as I add the 360 point camera to the scene. Working in 4.25.1 by the way
    Attached Files
    Last edited by Pulsestudio; 07-08-2020, 11:32 AM.

    Leave a comment:


  • replied
    Originally posted by Pulsestudio View Post
    I am just rendering still 360 views. I would like to be able to setup several cameras in my scene and press render to render out all the cameras I have setup. Is this possible?
    Hi, Pulsestudio!
    If I understand correctly. You have several cameras in the scene and would you like them to take turns rendering? Right?
    This lesson shows how you can attach a camera to all cameras and start rendering via a sequencer.
    https://youtu.be/BO6LiAyHyaU​​​​​​​

    Leave a comment:


  • replied
    I am just rendering still 360 views. I would like to be able to setup several cameras in my scene and press render to render out all the cameras I have setup. Is this possible?

    Leave a comment:


  • replied
    NEWS 07/06/2020. I apologize for the erroneous update. Now the errors are fixed.

    1. Please Restart Epic Games Launcher
    2. Update Camera 360
    3. Add and replace Camera 360 in your project..

    Custom render passes was added as an experimental feature. This functional for HighResShot system.
    https://www.youtube.com/watch?v=eUlgjTN-4Qg

    Click image for larger version  Name:	WorldNormal_.jpg Views:	0 Size:	78.0 KB ID:	1784923Click image for larger version  Name:	Specular_.jpg Views:	0 Size:	63.8 KB ID:	1784924Click image for larger version  Name:	SceneDepth_.jpg Views:	0 Size:	428.2 KB ID:	1784925Click image for larger version  Name:	AO_.jpg Views:	0 Size:	57.4 KB ID:	1784926Click image for larger version  Name:	ImageFinal_.jpg Views:	0 Size:	204.2 KB ID:	1784927Click image for larger version  Name:	BaseColor_.jpg Views:	0 Size:	114.3 KB ID:	1784928

    Note:
    1. Does not work with raytracing
    2. Doesn't work with modes: 360 Mono (1 cam) , StereoPanorama mode, 360 Stereo (Omni)
    3. Not working in sequencer, movie render pipeline. Working for HighResShot System.

    This new interface. For working Custom render, you need
    1. Chose Mode projection
    2. Custom Render - True
    3. And select render pass.
    Click image for larger version  Name:	CustomRender.png Views:	0 Size:	71.6 KB ID:	1784930

    This is an experimental function. If you see any errors, please contact me. I can always return the previous version of the 360 Camera.
    Attached Files
    Last edited by ElizzaRF; 07-06-2020, 03:19 PM.

    Leave a comment:


  • replied
    Originally posted by Scripted View Post
    Hello,

    I'm running into a tricky artifact when using Camera 360 plugin. I have tried all the methods that I deemed interesting in the forum but with no luck:
    • Disabling the post-process
    • Disabling the fog and reflections
    • Capturing in all 360 model planes
    • Activating "use separate process and close the editor when capturing"
    • Using manual mode capture You can find attached a picture showcasing the problem.
    You can find below a picture of the artifact.

    Does anyone know how to resolve the problem please?

    Thanks a lot for your help !
    Good afternoon, Scripted!
    Thank you for purchasing the 360 camera.
    This artifact occurs when there is a lack of video memory. What computer do You have?

    To avoid such artifacts, there are several solutions:
    1. Try used HighResShot system - https://youtu.be/J7uEiOhkH8o
    2. Try used new system in UE4.25 - Movie Render Pipeline - https://youtu.be/a_vp7b5Blyg
    3. If used Sequencer https://youtu.be/HXADxhSp0To , try used Separate Process and Closed Editor
    Click image for larger version

Name:	SeparateProcess.jpg
Views:	75
Size:	130.2 KB
ID:	1784466
    4. Try reducing the size of the texture.
    Quality(Experimental) - True
    Quality Size = 2500-3000 px.
    Output Size = 6000x3000px.
    Click image for larger version

Name:	SizeTexture.jpg
Views:	54
Size:	221.6 KB
ID:	1784467
    5. If you use Omni Mode for Stereo. Size You need to change the texture size manually.
    Open folder Camera_360\Textures\RenderTargetStereo and open, and change 4096 px -> 2048 or 2500.
    In the next update, I will make this process automatic.

    If this doesn't help, please email me. Let's see what else we can do.
    Send me an email Lenina62-ivan@mail.ru.

    Leave a comment:


  • replied

    Hello,

    I'm running into a tricky artifact when using Camera 360 plugin. I have tried all the methods that I deemed interesting in the forum but with no luck:
    • Disabling the post-process
    • Disabling the fog and reflections
    • Capturing in all 360 model planes
    • Activating "use separate process and close the editor when capturing"
    • Using manual mode capture You can find attached a picture showcasing the problem.
    You can find below a picture of the artifact.

    Does anyone know how to resolve the problem please?

    Thanks a lot for your help !

    Leave a comment:


  • replied
    NEWS 07/02/2020. New update.

    1. Please Restart Epic Games Launcher
    2. Update Camera 360
    3. Add and replace Camera 360 in your project..

    Changes were made to the name of the modes. There will now be two modes available for rendering 360 images.

    Click image for larger version  Name:	Modes_.jpg Views:	0 Size:	25.5 KB ID:	1783494

    1. Mono 360 (Use 6 cameras) - uses 6 rendering render targets in the rig of 6 cameras. In this mode, if necessary, you can disable unnecessary cameras.
    Old name Mono (Left Eye)
    2. Mono 360 (Use 1 camera) - used 1 render target and 1 camera. Now there are no distortions at the bottom and top.

    The format of the equilateral projection is slightly different for the two cameras.
    Choose the one that suits you best.

    Example image:
    Use 1 camara.
    Click image for larger version  Name:	Image_1cam_00001.jpg Views:	0 Size:	642.1 KB ID:	1783495
    Used 6 cameras.
    Click image for larger version  Name:	Image_6cam_00001.jpg Views:	0 Size:	657.2 KB ID:	1783496
    Click image for larger version  Name:	Modes.jpg Views:	0 Size:	67.5 KB ID:	1783497

    If you have any errors, please let me know. The update has been sent to the store and will be available soon.

    Last edited by ElizzaRF; 07-02-2020, 12:27 PM.

    Leave a comment:


  • replied
    Originally posted by corentin-dpt View Post

    Ok Great!
    Unfortunately, blurring the problematic part of the image is not a valid solution for our project.
    When can we expect a new version with this bug fixed?
    Hi!
    I'll give you an answer tomorrow. I hope I can resolve this issue quickly.

    Leave a comment:


  • replied
    Originally posted by ElizzaRF View Post

    Good afternoon, corentin-dpt!
    I am currently working on fixing this problem.
    This is not related to the post-process.

    As a temporary solution:
    1.you can blur the lower part of the background in any video editor program;
    2. Place a sphere or object with a blur material at the bottom, or darken the area.
    Ok Great!
    Unfortunately, blurring the problematic part of the image is not a valid solution for our project.
    When can we expect a new version with this bug fixed?

    Leave a comment:


  • replied
    Originally posted by corentin-dpt View Post
    Hi, we have a stitching issue.

    We've captured using the CAMERA 360 System with :
    - Post-process Volume and Chameleon post-process
    - No vignette
    - No bloom
    - PNG format

    After capturing we've encoded the images using Adobe Media Encoder to H264 then we used Spatial Media Metadata Injector to play the video in 360 mode using common video players.
    But we have this issue with almost all tested video players : GoPro VR Player 2.3, VLC 3.0.11 and Vimeo (Only "Movies & TV" from Windows have a different result)

    Click image for larger version

Name:	360Addon-360Capture-IssueVisible.JPG
Views:	110
Size:	53.8 KB
ID:	1782759


    This is captured with the Unreal's Panoramic Capture Tool and the same encoding process :

    Click image for larger version

Name:	UnrealNatif-360Capture-NoIssueVisible.JPG
Views:	79
Size:	53.5 KB
ID:	1782760
    (But it takes 1min to capture one frame ... so not suitable for production)
    Good afternoon, corentin-dpt!
    I am currently working on fixing this problem.
    This is not related to the post-process.

    As a temporary solution:
    1.you can blur the lower part of the background in any video editor program;
    2. Place a sphere or object with a blur material at the bottom, or darken the area.

    Leave a comment:


  • replied
    Hi, we have a stitching issue.

    We've captured using the CAMERA 360 System with :
    - Post-process Volume and Chameleon post-process
    - No vignette
    - No bloom
    - PNG format

    After capturing we've encoded the images using Adobe Media Encoder to H264 then we used Spatial Media Metadata Injector to play the video in 360 mode using common video players.
    But we have this issue with almost all tested video players : GoPro VR Player 2.3, VLC 3.0.11 and Vimeo (Only "Movies & TV" from Windows have a different result)

    Click image for larger version

Name:	360Addon-360Capture-IssueVisible.JPG
Views:	110
Size:	53.8 KB
ID:	1782759


    This is captured with the Unreal's Panoramic Capture Tool and the same encoding process :

    Click image for larger version

Name:	UnrealNatif-360Capture-NoIssueVisible.JPG
Views:	79
Size:	53.5 KB
ID:	1782760
    (But it takes 1min to capture one frame ... so not suitable for production)

    Leave a comment:


  • replied
    Hi, All!
    Information for those who use stereo panoramic mode for create stereo images. A small error was detected with the number of frames per second.
    Temporary solution:
    Change Max FPS for Editor , example 30. And the frame rate for the stereo panorama will change to the desired one. Recomended 60 fps and change in video editor to 30 fps.
    and to prevent frames from being skipped, the window must be active after rendering starts. You can't go to other Windows or use the computer. Otherwise, frames will be skipped.


    The fix has already.
    1. Please Restart Epic Games Launcher
    2. Update Camera 360
    3. Add and replace Camera 360 in your project..
    Last edited by ElizzaRF; 06-30-2020, 02:11 PM.

    Leave a comment:

Working...
X