Announcement

Collapse
No announcement yet.

CAMERA 360 System (Blueprints)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by yhsgoon View Post
    Hi.
    I used two computers. Winsows10.
    There was no shadow on both of them.

    I emailed two dxdiags.

    Click image for larger version Name:	20190704_154043.jpg Views:	1 Size:	232.0 KB ID:	1638272
    You have GTX 1070 installed on both computers.
    On two computers is not showing the shadow?

    I checked the computer.
    MyCom2 video driver 388.13 (Update your video driver just in case)
    MyCom1 - video driver 430.86

    1. Сan you check your settings in the Editor , changes to epic ?

    Click image for larger version

Name:	Settings_Epic.jpg
Views:	59
Size:	295.7 KB
ID:	1638281

    2. Can you check engine 4.20, 4.21 ?

    This is a known issue in Unreal Engine engines. https://answers.unrealengine.com/que...3995/view.html

    Here is my computer,
    Core i7700
    Video Card RTX2080 Ti
    Ram 16 gb.

    Comment


      Originally posted by yhsgoon View Post
      Hi.
      I found the number of cases when I was testing.
      DirectionalLight = Static or Stationary
      The shadow did not appear on the right
      DirectionalLight = Movable
      All the shadows came out the same.
      How about you?
      Hi!
      I installed the 4.22 engine on my computer.
      Q9400 Quad Core Processor
      GTX 770

      After a while, I can check.

      I was checked for 4.18-shadows didn't work.
      On 4.22 the shadows work I have.

      I don't know what the reason is. I need to look at a weak computer to reproduce the problem.

      Comment


        Thanks!
        You're right. I found a solution. As it turned out the shadow quality settings cinematic does not work in stereo mode. The solution is to change the shadow settings to Epic.
        https://i.yapx.ru/EfgrE.gif (gid animation)
        Shadow - Epic

        Click image for larger version  Name:	Shadow_Epic.jpg Views:	2 Size:	276.2 KB ID:	1638297

        Shadow - Cinematic

        Click image for larger version

Name:	Shadow_Cinematic.jpg
Views:	57
Size:	289.9 KB
ID:	1638299

        Comment


          Hi.
          I am sorry that I cannot speak English first.

          I post to share my symptoms.
          I shared a lot of information with the producer ElizaRF.

          My spec is Windows10. gtx1070, UE4 Engine 4.22.3
          I tested two computers.

          When using 2D stereo mode
          No direct sunlight shadows emerged from the right viewport.

          If the engine setting is changed to the EPIC or lower level, all light types are:
          The shadows come out well on both sides. Good!!!

          If the engine is set with Cineamtic, no shadow will appear in the right viewport.
          If you change the light type to moveable, both of them worked well.
          However, the light type Static or Stationary does not have a shadow on the right viewport.

          so
          I set up the engine and made a compromise by lowering the shadow to the epic.
          Click image for larger version  Name:	20190704_165841.jpg Views:	1 Size:	213.7 KB ID:	1638306



          I don't know the exact cause, but I've been doing many tests.
          I have found this issue.

          I'm going to keep testing.
          I wish you all good luck.

          Thank you ElizaRF, the producer who always answered my questions well.
          Great plug-in Camera360!!!
          .

          I uploaded this symptom to my YouTube.
          https://youtu.be/E3iXnq-A98k


          ★★★★★★★★★★★★★★★★
          ★★★★★★★★★★★★★★★★
          Additional Test Verification

          When you change the shadow to epic at engine setting, ((DirectionalLight = Static or Stationary)
          HighReshot system = Both sides of the shadow look good
          Sequencer systems = only one side is shaded.


          The recommended option was to change the direct sunlight to Movable.

          The cause is still unknown.
          Last edited by yhsgoon; 07-04-2019, 04:56 AM.

          Comment


            Originally posted by yhsgoon View Post
            Hi.
            I am sorry that I cannot speak English first.

            I post to share my symptoms.
            I shared a lot of information with the producer ElizaRF.

            My spec is Windows10. gtx1070, UE4 Engine 4.22.3
            I tested two computers.

            When using 2D stereo mode
            No direct sunlight shadows emerged from the right viewport.

            If the engine setting is changed to the EPIC or lower level, all light types are:
            The shadows come out well on both sides. Good!!!

            If the engine is set with Cineamtic, no shadow will appear in the right viewport.
            If you change the light type to moveable, both of them worked well.
            However, the light type Static or Stationary does not have a shadow on the right viewport.

            so
            I set up the engine and made a compromise by lowering the shadow to the epic.
            Click image for larger version Name:	20190704_165841.jpg Views:	1 Size:	213.7 KB ID:	1638306



            I don't know the exact cause, but I've been doing many tests.
            I have found this issue.

            I'm going to keep testing.
            I wish you all good luck.

            Thank you ElizaRF, the producer who always answered my questions well.
            Great plug-in Camera360!!!
            .

            I uploaded this symptom to my YouTube.
            https://youtu.be/E3iXnq-A98k


            ★★★★★★★★★★★★★★★★
            ★★★★★★★★★★★★★★★★
            Additional Test Verification

            When you change the shadow to epic at engine setting, ((DirectionalLight = Static or Stationary)
            HighReshot system = Both sides of the shadow look good
            Sequencer systems = only one side is shaded.


            The recommended option was to change the direct sunlight to Movable.

            The cause is still unknown.
            Thank you very much yhsgoon for the detailed description, I'm sure that it will help a lot!
            This problem only exists in actor Camera_2D in stereo mode. Because it uses a SplitScreen mode.
            There is no such problem in other actors camera.

            Comment


              I did everything for avoid seams. But there are some seams in the capture image already.

              Looking forward to your replay.Thank you.
              Last edited by Lucky2016; 07-08-2019, 04:48 AM.

              Comment


                Originally posted by Lucky2016 View Post
                I did everything for avoid seams. But there are some seams in the capture image already.
                This is my project:https://drive.google.com/file/d/1obx...ew?usp=sharing
                Looking forward to your replay.Thank you.
                Good day, Lucky2016!
                I downloaded a link to the project. You can remove the project reference. I'll check and text you.

                Please change Screen Space Reflection in Post Process scene (You can specify a value that is appropriate for You, example intencity = 0).
                Click image for larger version  Name:	ScreenSpace_Reflection.jpg Views:	1 Size:	290.3 KB ID:	1639635
                Last edited by ElizzaRF; 07-08-2019, 02:36 AM.

                Comment


                  Originally posted by ElizzaRF View Post

                  Good day, Lucky2016!
                  I downloaded a link to the project. You can remove the project reference. I'll check and text you.

                  Please change Screen Space Reflection in Post Process scene (You can specify a value that is appropriate for You, example intencity = 0).
                  Click image for larger version Name:	ScreenSpace_Reflection.jpg Views:	1 Size:	290.3 KB ID:	1639635
                  Thanks for your replay.
                  When the Camera_point_360 Actor location is (X=-840.000000,Y=190.000000,Z=120.000000) in my project. The seams are still there!

                  Comment


                    Originally posted by Lucky2016 View Post

                    Thanks for your replay.
                    When the Camera_point_360 Actor location is (X=-840.000000,Y=190.000000,Z=120.000000) in my project. The seams are still there!
                    Very strange. I made video. There is also one note, the actor who is affected by postprocessing is camera_rec_360 . All postprocess where is Camera rec 360 actor, you need to set all the values of the screen space reflection to 0
                    https://youtu.be/hgp5PHzSXuc

                    Examples render:
                    360 Mono mode + Post Processing (without screen space reflection) (the seams are not visible ) (target 2048 px rendering): https://youtu.be/LzgZWd1OP0M
                    360 Mono mode + Post Processing + reflection space of the screen (the seams visible) (render target of 2048 px): https://youtu.be/JPoE_r5r9AY

                    Comment


                      News 07/16/2019.Release new update 1.13 fix 3 .

                      Video update https://youtu.be/XAT3CwxCP08


                      Added the ability to use RayTracing using camera360.
                      Now You can get the final image in the usual way. All you need to do is activate the Raytracing value.
                      This mode allows a lower load on the video memory. I think this can solve the problem of artifacts on weak systems, You can also try to activate this function.

                      Added new properties of the actor camera_rec_360 is important:
                      Delay Next Frame.
                      This is a pause between shots, if it is increased, the load on the graphics card should be less.

                      Raytracing - activates the ability to reduce the load on the graphics card.

                      Click image for larger version  Name:	Raytracing_option.jpg Views:	1 Size:	49.3 KB ID:	1641993

                      Notice:
                      The system works only with HighResShot system. rendering using the Sequencer is not supported.
                      Raytracing system was tested on RTX 2080Ti video card. You will need a good graphics card to work.

                      At the moment, 360, 180 mono modes work well.
                      But in stereo mode you need more load.
                      Do not forget, if You have stereo mode, You need to reduce the resolution of the resulting image. Otherwise, there may be a lack of memory.

                      Also at the end of the rendering are automatically activated console command r.RayTracing.Reflections 0 and r.RayTracing.GlobalIllumination 0.
                      To activate the options in the Editor, you must enter the console commands r.RayTracing.Reflections 1 and r.RayTracing.GlobalIllumination 1.
                      This is done to reduce the load on the graphics card.

                      Because ray tracing is very expensive in performance, failures can occur because of lack of memory. Much depends on the quality and complexity of the scene. But I hope that with each version of the engine ray tracing will become more productive in relation to rendering.
                      Last edited by ElizzaRF; 08-06-2019, 12:09 PM.

                      Comment


                        I've been rendering 4096x2048 360 videos from a game un UE4.22.3 using sequencer. Please note the bug I'm experiencing with the latest version of 1.13 of the Camera360 plugin:

                        Comment


                          Originally posted by dgungadoo View Post
                          I've been rendering 4096x2048 360 videos from a game un UE4.22.3 using sequencer. Please note the bug I'm experiencing with the latest version of 1.13 of the Camera360 plugin:
                          Hi, dgungadoo!

                          Thanks for purchase. I am pleased to hear that You will need this plugin.

                          Try off post process

                          1. vignetee - https://forums.unrealengine.com/unre...69#post1598669

                          2. bloom - https://forums.unrealengine.com/unre...99#post1612799

                          3. Try off Atmospheric fog or heigh fog in scene.

                          4. https://forums.unrealengine.com/unre...54#post1613354
                          and dont forget change anti alising in project. To make the image clear.

                          Comment


                            Hi,

                            I Have a Problem with the sequencer. Maybe someone knew how to fix it.

                            I Can´t render my Movie in a resoulution higher then 4096x2048. Everytime i try to render 6000x3000 the movie is black and i cant use the play button.
                            Last edited by TFandrich; 08-12-2019, 05:53 AM.

                            Comment


                              Originally posted by TFandrich View Post
                              Hi,

                              I Have a Problem with the sequencer. Maybe someone knew how to fix it.

                              I Can´t render my Movie in a resoulution higher then 4096x2048. Everytime i try to render 6000x3000 the movie is black and i cant use the play button.
                              Good day!
                              can you record a video of the process?
                              To make it easier for me to understand the problem.

                              Maybe this can help?
                              Tutorial working in Sequencer youtube.
                              Please see https://forums.unrealengine....
                              Camera_Point_360 attached to Camera in sequencer.
                              Example youtube

                              Comment


                                Hello! I seem to not be able to activate the 360 Rec Camera. I follow your same steps as in the tutorial, and then in the preview window the angle of the camera view stays at 90 deg, and the 360 view that showd appear stays as if it were a normal camera. I cant seem to be able to fix it. Thank you!

                                Comment

                                Working...
                                X