Announcement

Collapse
No announcement yet.

CAMERA 360 System (Blueprints)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by YuCang View Post

    thanks for your answer!!
    And i have another problem,how to change the size to 3840X2160 in 360 stereo mode?like this video : https://ibb.co/SxCvZHV
    This is my screen now : https://ibb.co/687wrfM
    Hi, YuCang!
    Rendering must be 1:1. you need to change the size in any video editor. Example rendering in 4000x4000 resolution -> you need to convert it to 4000x2000 or 3840x2160 in any video editor.
    Look tutorial https://youtu.be/1UKh0bXI8GI

    Comment


      Hi ElizzaRF,
      I purchase your plugin sometimes ago, but dkidn't have time to try it till now.
      I follow your tutorial but i can't record 360 using the sequencer. It always record the camera actor which is in the sequencer.
      The HighResShot system do the same. When i hit play the sequence starts but not showing the Camera_Rec_360 result.
      I'm using the last version 4.25.3
      I record the procedure i've done..... but can't see what's wrong....

      https://vimeo.com/443186075

      can you help me?
      best regards

      stephane

      Comment


        So I have been trying to get higher resolution 360 images. while I can render out at 20,000 x 10,000 with movie queue and highres tiles. It doesn't seem to make my image look any better. I have been trying many different setting and options but again I am getting the same results every time when I compare the images. Is there something I am missing that will improve the quality of 360 image?

        Comment


          Originally posted by luigid View Post
          Hi ElizzaRF,
          I purchase your plugin sometimes ago, but dkidn't have time to try it till now.
          I follow your tutorial but i can't record 360 using the sequencer. It always record the camera actor which is in the sequencer.
          The HighResShot system do the same. When i hit play the sequence starts but not showing the Camera_Rec_360 result.
          I'm using the last version 4.25.3
          I record the procedure i've done..... but can't see what's wrong....

          https://vimeo.com/443186075

          can you help me?
          best regards

          stephane
          Hi, luigid!
          Thank you for your purchase. Yes, if you are using a sequencer, you need to make the track inactive.
          Look tutorial -> https://youtu.be/BO6LiAyHyaU?t=322
          You need select Camera Cut track in sequencer -> right mouse button -> and Deactivate.

          Comment


            Originally posted by Pulsestudio View Post
            So I have been trying to get higher resolution 360 images. while I can render out at 20,000 x 10,000 with movie queue and highres tiles. It doesn't seem to make my image look any better. I have been trying many different setting and options but again I am getting the same results every time when I compare the images. Is there something I am missing that will improve the quality of 360 image?
            Good afternoon, Pulsestudio!
            I wrote you an email, please contact me so I can check everything.

            Comment


              Hi,
              Do you have any solutions for removing noise when take 360-HighResShot with RTX-GI?
              Last edited by ACCADarioS; 07-31-2020, 06:08 AM.

              Comment


                Originally posted by ElizzaRF View Post

                Hi, luigid!
                Thank you for your purchase. Yes, if you are using a sequencer, you need to make the track inactive.
                Look tutorial -> https://youtu.be/BO6LiAyHyaU?t=322
                You need select Camera Cut track in sequencer -> right mouse button -> and Deactivate.
                A great thank you for your amazing support !!! it works fine !!
                i have two more question :
                1-I wonder what is the use of the spline_for_camera you provide? With your technique of "attaching camera_actor" to the camera_point_360 in the sequencer, the attached camera can be driven by a CameraRail....
                Is it
                2- Now, the PostProcess are directly in the Camera_Rec_360. You don't need to access the blueprint. Is it correct?

                Comment


                  Originally posted by ACCADarioS View Post
                  Hi,
                  Do you have any solutions for removing noise when take 360-HighResShot with RTX-GI?
                  Hi, ACCADarioS!

                  I am looking for a solution to remove noise if used HighResShot system. At the moment, to get a clean image with Raytracing, you need to use Movie Render Pipeline
                  https://www.youtube.com/watch?v=-8Aw...&index=19&t=5s or https://youtu.be/a_vp7b5Blyg

                  Comment


                    Originally posted by luigid View Post

                    A great thank you for your amazing support !!! it works fine !!
                    i have two more question :
                    1-I wonder what is the use of the spline_for_camera you provide? With your technique of "attaching camera_actor" to the camera_point_360 in the sequencer, the attached camera can be driven by a CameraRail....
                    Is it
                    2- Now, the PostProcess are directly in the Camera_Rec_360. You don't need to access the blueprint. Is it correct?
                    Hi, luigid!
                    Thank you very much, I try to devote a lot of time to technical support of this product.
                    Question 1. Look please this tutorial for spline -> https://youtu.be/ZCqrn3l1G_o?t=96 . Of course, the implementation is not very complex, but it can be useful.
                    Question 2. Yes, you can automatically apply post process to avoid seams, this is better used for the entry level.
                    In General, I recommend doing this manually.

                    Important/Additional Notes:
                    Some Post processing does not work, artifacts appear in the form of seams.
                    • Vignette = 0 (In Post Process);
                    • Bloom = 0 (In Post Process);
                    • ScreenSpace Reflection = 0 (In Postprocess);
                    • Atmospheric Fog - volumetric off;
                    • Exponecial Heigh Fog - volumetric off (working, but long rendering);
                    • Directional Light - Light Shafts Off;
                    • Exposure (Sometimes due to the uneven distribution of exposure occurs in the seam. Try to adjust the check Exposure method Manual and change Exposure value).
                    • Ambient Occlusion (Sometimes).
                    • DOF needs to be turned off;


                    Comment


                      well, in your video "Camera 360. PostProcessing 8k. 360 Mono mode OFF SSR_ScreenSpaceReflection", it looks like post process are rendering fine, like bloom...

                      Comment


                        Originally posted by luigid View Post
                        well, in your video "Camera 360. PostProcessing 8k. 360 Mono mode OFF SSR_ScreenSpaceReflection", it looks like post process are rendering fine, like bloom...
                        Hi, luigid!
                        Working all post process, but sometimes seams.
                        You can check if all the post processes are working, but seams may appear. if you can avoid getting into the seams, then you can use everything. Activate the debug border in the REC 360 camera actor, then you will see where the seam zones may appear. debug border does Not work in Mono 360 (use 1 camera)

                        Comment


                          Thanks for your answer. One last question for the general settings.
                          Do you recommend "forward shading" + MSAA?
                          Does "smooth framerate" in "project/general settings" should be turn off and set to "fixed framerate"?

                          Comment


                            Originally posted by luigid View Post
                            Thanks for your answer. One last question for the general settings.
                            Do you recommend "forward shading" + MSAA?
                            Does "smooth framerate" in "project/general settings" should be turn off and set to "fixed framerate"?
                            I recomended using TemporalAA, if used MSAA -> The image will be clearer, but without anti-aliasing. In this case, you will need to increase the resolution of the output image and the size of the texture.
                            Ty open Camera 360 actor -> Antialiasing value -> False and you see No Smoothness.
                            No, You don't need to change frame rate fixed in project settings. Fixed framerate in camera actor 360 actor -> frame rate (this for Hyresshot system https://youtu.be/J7uEiOhkH8o?t=30) . If using Sequencer or Movie Render Pipeline, change frame rate need in this system -> option frame rate.

                            Look forum theme https://forums.unrealengine.com/unreal-engine/marketplace/1595263-camera-360-system-blueprints?p=1793341#post1793341

                            Comment


                              At last i try the stereo360 (the first one) and i notice a discomfort, as if the right eye was a little different of the other eye...
                              I'm using a Pico G2 4K. Does the IPD (which is the distance beetween pupils, right?) need to be adapt? or is there an other trick. I'm very new to stereo !!

                              Comment


                                Originally posted by luigid View Post
                                At last i try the stereo360 (the first one) and i notice a discomfort, as if the right eye was a little different of the other eye...
                                I'm using a Pico G2 4K. Does the IPD (which is the distance beetween pupils, right?) need to be adapt? or is there an other trick. I'm very new to stereo !!
                                Please see information and video( stereo modes) https://youtu.be/SqQtM1xZFrE?t=377
                                Attention 360 stereo.Stereo 360 modes are experimental. (more information)

                                The 360 camera has 4 stereo modes.

                                1. 360 Stereo -has a problem with turning the head, but no seams. Before making the final rendering, check whether this method is suitable for you.(

                                2. 360 Stereo (experimental) -it has the correct stereo when you turn your head, but if objects are close, seams appear.

                                3. 360 Stereo(Omni) - (look video -> https://www.youtube.com/watch?v=SqQtM1xZFrE&t=377s)
                                You can render as usual using the 360 camera, rendering time fast. However, you must activate the Omni Directional in Project Settings function.
                                Notes:
                                1. Quality(Experiment) - not working for change texture size. Changes manual. If any question, contact to me.
                                Problems:
                                1. If you use tessellation in your material, objects in your right eye may move in the photo.
                                Possible solution: Disable the Tesselation function.
                                2. The shadows don't look right, they don't seem to be positioned correctly. Problem shadows.
                                Possible solution: You need to bake the shadows.
                                Unfortunately, dynamic shadows not always displayed correctly.

                                4. Stereo Panoramic (used standart free Stereo Panoramic Plugin).
                                This mode adds a simple interface for working with the Stereo Panoramic plugin.
                                This mod is best used only for rendering stereo images. The rendering time is long.
                                Problems:
                                Long rendering:
                                1. Change value Captures Speed
                                The number of scene captures to capture concurrently. Raising or lowering the value of Captures Speed (SP.ConcurrentCaptures) can greatly affect capture times. If you set this value too low, you will not be capturing the optimal number of scene captures for parallel processing. If you set this value too high, you will overwhelm the GPU.

                                An interface has been added for this mode in Camera Rec 360 actor, panel Stereo Panoramic System.
                                Everything is already set up to work and get a high-quality stereo image.

                                theme information https://forums.unrealengine.com/unre...16#post1768616
                                Last edited by ElizzaRF; 08-05-2020, 02:12 PM.

                                Comment

                                Working...
                                X