Announcement

Collapse
No announcement yet.

CAMERA 360 System (Blueprints)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Pulsestudio View Post
    thanks for the sequence video, I will look at this and see if it works for us. Another issue is that when I add your camera to my scene I get strange flickering on my glossy materials.
    Click image for larger version Name:	Screenshot_Before_Adding_Camera.jpg Views:	0 Size:	157.6 KB ID:	1785718Click image for larger version Name:	Screenshot_After_Adding_Camera.jpg Views:	0 Size:	152.8 KB ID:	1785717

    Any thoughts on why this is happening? It starts as soon as I add the 360 point camera to the scene. Working in 4.25.1 by the way
    Hi, Pulsestudio!
    I hope this helps you.
    I can't figure out what's going on from the picture ​ .
    Can you show your camera settings? It looks like the post process settings are being reset.
    If you use auto post-process configuration, then the all settings in post-process may be reset.
    Click image for larger version

Name:	image_197167.png
Views:	148
Size:	207.7 KB
ID:	1785751
    Note:
    -Planar Reflection - is not supported.
    -Sometimes seams may be visible. Not recommended to use ScreenSpaceReflection since the all camera's in unreal egnine used screen space.
    -Recomended use Raytracing reflection.


    Last edited by ElizzaRF; 07-08-2020, 12:29 PM.

    Comment


      Originally posted by ElizzaRF View Post
      Hi, Pulsestudio!
      I hope this helps you.
      I can't figure out what's going on from the picture ​ .
      Can you show your camera settings? It looks like the post process settings are being reset.
      If you use auto post-process configuration, then the all settings in post-process may be reset.
      Click image for larger version

Name:	image_197167.png
Views:	148
Size:	207.7 KB
ID:	1785751
      Note:
      -Planar Reflection - is not supported.
      -Sometimes seams may be visible. Not recommended to use ScreenSpaceReflection since the all camera's in unreal egnine used screen space.
      -Recomended use Raytracing reflection.


      Good afternoon!
      You're right, it's very strange. I'm thinking about a solution now. This problem is for some reason only in version 4.25, in the rest of this problem is not present.

      The good news is that if you run rendering, there will be no artifacts.

      The problem for some reason in Screen Space Reflection in in editor.

      There are two solutions so far:
      1. Add the 360 camera to the project later;
      2. Work as is, the 360 camera is not affected by this and the artifacts will not be on the final rendering.

      I think today I will find a solution to fix it or contact Epic Games for help.

      Comment


        Originally posted by ElizzaRF View Post

        Good afternoon!
        You're right, it's very strange. I'm thinking about a solution now. This problem is for some reason only in version 4.25, in the rest of this problem is not present.

        The good news is that if you run rendering, there will be no artifacts.

        The problem for some reason in Screen Space Reflection in in editor.

        There are two solutions so far:
        1. Add the 360 camera to the project later;
        2. Work as is, the 360 camera is not affected by this and the artifacts will not be on the final rendering.

        I think today I will find a solution to fix it or contact Epic Games for help.
        I found a problem in Unreal engine 4.25.
        Which causes artifacts to appear in the scene.
        For smoothing, I use the command
        r. PostProcessAAQuality 0-without smoothing,
        r.PostProcessAAQuality 2 - smoothing.
        So that's the problem with the engine.
        I will create a query in Epic Games.

        Temporary solution:
        If you are bothered by artifacts and don't need smoothing:
        1. Open Actor Camera Rec 360 and open Construction script and destroy line 1.

        1. If this doesn't bother you, you can still work like this: there are no flickering artifacts in the final render.
        2. i think Using Raytraysing. This error Screen Space Reflection

          When you disable the line, save the changes and restart the project. The problem will disappear

        Comment


          ElizzaRF
          Hello!

          We just purchased your plugin, and would like to capture a movie, but with no luck so far.

          We tried with an Emtpy Level, with a ground plane and background sky. Added a Camera Actor, animated it in the Sequencer, and followed the steps in the tutorial below with the Camera_Point_360 Camera_Rec_360 objects.
          https://www.youtube.com/watch?v=HXAD...QwBbyOb_YGDcy1

          - When trying Sequencer "Render Movie" option, only the original camera's view gets exported, with no panoramic projection.
          - When trying to use "Screen Shot System" "Screen Shot Rec" option in the Camera_Rec_360 object, a panoramic images get exported, but it does not match the animated camera's route. The camera position does not change, but on the animated background sky the movement of clouds is visible. But the camera does not move, so the same frame gets exported 150 times.
          - Sometimes we can see other frames appearing in the exported images, but they have no proper order. For example first and last frame gets exported, and then the last frame gets exported 150 times.

          We tried it on 2 different configs:
          - Ryzen Threadripper 1950X, 32 GB RAM, 2x Geforce GTX1080 Ti
          - Intel i7-5930K, 128GB RAM, 2x Geforce GTX 1070

          What could be the problem? Is the hardware not enough for the capturing?

          Is there maybe a sample scene available so we can try if the settings are messed up?

          Thank you!
          Last edited by Narmer Visual; 07-12-2020, 04:04 PM.

          Comment


            Originally posted by Narmer Visual View Post
            ElizzaRF
            Hello!

            We just purchased your plugin, and would like to capture a movie, but with no luck so far.

            We tried with an Emtpy Level, with a ground plane and background sky and. Added a Camera Actor, animated it in the Sequencer, and followed the steps in the tutorial below with the Camera_Point_360 Camera_Rec_360 objects.
            https://www.youtube.com/watch?v=HXAD...QwBbyOb_YGDcy1

            - When trying Sequencer "Render Movie" option, only the original camera's view gets exported, with no panoramic projection.
            - When trying to use "Screen Shot System" "Screen Shot Rec" option in the Camera_Rec_360 object, a panoramic images get exported, but it does not match the animated camera's route. The camera position does not change, but on the animated background sky the movement of clouds is visible. But the camera does not move, so the same frame gets exported 150 times.
            - Sometimes we can see other frames appearing in the exported images, but they have no proper order. For example first and last frame gets exported, and then the last frame gets exported 150 times.

            We tried it on 2 different configs:
            - Ryzen Threadripper 1950X, 32 GB RAM, 2x Geforce GTX1080 Ti
            - Intel i7-5930K, 128GB RAM, 2x Geforce GTX 1070

            What could be the problem? Is the hardware not enough for the capturing?

            Is there maybe a sample scene available so we can try if the settings are messed up?

            Thank you!
            Hi, Narmer Visual!
            Thank you for purchasing the 360 camera.

            [
            - When trying Sequencer "Render Movie" option, only the original camera's view gets exported, with no panoramic projection.
            Camera 360 and Camera Cut tutorial - https://youtu.be/BO6LiAyHyaU .
            Camera 360 and Master Sequencer tutorial - https://youtu.be/pHPKJRH7Uxw
            You Need select your Cut and right mouse button, next step select Deactivate track https://youtu.be/BO6LiAyHyaU?t=322

            - When trying to use "Screen Shot System" "Screen Shot Rec" option in the Camera_Rec_360 object, a panoramic images get exported, but it does not match the animated camera's route.
            - You Need select Camera Point 360 and Find Get Target All Transform and select your camera
            https://youtu.be/J7uEiOhkH8o?t=16
            https://youtu.be/XAT3CwxCP08
            - using HighResShot system.

            -What could be the problem? Is the hardware not enough for the capturing?
            No, this problem Camera Cuts. Don't worry. Deactivate Track. Don't delete.

            -Is there maybe a sample scene available so we can try if the settings are messed up?
            Demo maps in Camera_360/Maps/Demo_Scenes

            Comment


              Tell me, did the decision help you?

              Comment


                ElizzaRF Thanks a lot for the support, and quick reply!
                Before I posted my first comment, I used Get Target All Transformand to select the camera, but it didn't seem to recognize, or update the connection between the two objects. (By the way, I'm using 4.25.1 version).

                But anyways, I managed to get a capture working in the meantime by adding the "Camera_Point_360" object itself into the Sequencer like in the video link you provided, and managed to export a nice panoramic sequence. So this method seems to be working fine!
                The tutorial you linked, by attaching "Camera_Point_360" to a CineCameraActor in the Sequencer, and deactivating the Track also works. Regarding this method: is it possible to animate camera exposure? I can't add Camera Component to "Camera_Point_360", and it does not seem to adapt animated exposure from the CineCameraActor.
                Neither adding PostProcessVolumes to the level, seems to have effect on the rendered output.

                Also, a question: Is it possible to narrow the Field of View, for Dome Camera, or VR180_Stereo outputs?
                We are making a VR animation for Oculus Go, which seems to have an upper limit of video resolution 3840x3840 or 5760x2880, which does not seems to be enough for a VR180, so I'm thinking of projecting the rendered video on a smaller segment of a sphere (for example 135° by 135°), so like this we can make a better use of Oculus Go's maximal video resolution.
                Of course I can capture a full 180° at a higher resolution, and crop the image sequence afterwards in a video editing software to have a more narrow field of view, I'm just wondering if there is a more effective workflow for this.

                Thanks for the great plugin and for the support in advance!
                Last edited by Narmer Visual; 07-12-2020, 04:13 PM.

                Comment


                  Originally posted by Narmer Visual View Post
                  ElizzaRF Thanks a lot for the support, and quick reply!
                  Before I posted my first comment, I used Get Target All Transformand to select the camera, but it didn't seem to recognize, or update the connection between the two objects. (By the way, I'm using 4.25.1 version).

                  But anyways, I managed to get a capture working in the meantime by adding the "Camera_Point_360" object itself into the Sequencer like in the video link you provided, and managed to export a nice panoramic sequence. So this method seems to be working fine!
                  The tutorial you linked, by attaching "Camera_Point_360" to a CineCameraActor in the Sequencer, and deactivating the Track also works. Regarding this method: is it possible to animate camera exposure? I can't add Camera Component to "Camera_Point_360", and it does not seem to adapt animated exposure from the CineCameraActor.
                  Neither adding PostProcessVolumes to the level, seems to have effect on the rendered output.

                  Also, a question: Is it possible to narrow the Field of View, for Dome Camera, or VR180_Stereo outputs?
                  We are making a VR animation for Oculus Go, which seems to have an upper limit of video resolution 3840x3840 or 5760x2880, which does not seems to be enough for a VR180, so I'm thinking of projecting the rendered video on a smaller segment of a sphere (for example 135° by 135°), so like this we can make a better use of Oculus Go's maximal video resolution.
                  Of course I can capture a full 180° at a higher resolution, and crop the image sequence afterwards in a video editing software to have a more narrow field of view, I'm just wondering if there is a more effective workflow for this.

                  Thanks for the great plugin and for the support in advance!
                  Hi, Narmer Visual!

                  But anyways, I managed to get a capture working in the meantime by adding the "Camera_Point_360" object itself into the Sequencer like in the video link you provided, and managed to export a nice panoramic sequence. So this method seems to be working fine!
                  The tutorial you linked, by attaching "Camera_Point_360" to a CineCameraActor in the Sequencer, and deactivating the Track also works.
                  - I am glad that you managed to do everything!

                  The tutorial you linked, by attaching "Camera_Point_360" to a CineCameraActor in the Sequencer, and deactivating the Track also works. Regarding this method: is it possible to animate camera exposure?
                  -1. Open sequencer;
                  -2. Add in scene PostProcess and Add to sequencer;
                  Click image for larger version  Name:	Step2.jpg Views:	0 Size:	124.7 KB ID:	1787291
                  -3. Select PostProcessing -> Lens Exposure -> Exposure Compensation;
                  Click image for larger version  Name:	Step3.jpg Views:	0 Size:	197.3 KB ID:	1787292
                  -4. And add key in your timeline, try frame 1 = value 0, frame 10 = value 1.
                  Click image for larger version  Name:	Step4.jpg Views:	0 Size:	80.3 KB ID:	1787293
                  -5. Don't forget. Infinite Extent(Unbound) for apply the post process to the entire level. And all working. Or Actor camera rec 360 paste to post process zone.
                  Click image for larger version  Name:	Step5.jpg Views:	0 Size:	23.6 KB ID:	1787294
                  It is better to do this through the post process, so that all cameras that are used in camera 360 have the same exposure. And it's better to do the Manual method.

                  Also, a question: Is it possible to narrow the Field of View, for Dome Camera, or VR180_Stereo outputs?
                  We are making a VR animation for Oculus Go, which seems to have an upper limit of video resolution 3840x3840 or 5760x2880, which does not seems to be enough for a VR180, so I'm thinking of projecting the rendered video on a smaller segment of a sphere (for example 135° by 135°), so like this we can make a better use of Oculus Go's maximal video resolution.
                  Of course I can capture a full 180° at a higher resolution, and crop the image sequence afterwards in a video editing software to have a more narrow field of view, I'm just wondering if there is a more effective workflow for this.
                  I need to think about it. Thank you for the idea, but now unfortunately there is no such opportunity to reduce the field of view.
                  I am constantly working on improvements and always happy with new ideas.
                  Thank you for your kind words and purchasing the 360 Camera. I'm always ready to help
                  Last edited by ElizzaRF; 07-12-2020, 04:46 PM.

                  Comment


                    ElizzaRF Thanks a lot for the support, I managed to get it all working!

                    Comment


                      Originally posted by Narmer Visual View Post
                      ElizzaRF Thanks a lot for the support, I managed to get it all working!
                      Hi, Narmer Visual!
                      Thank you so much for your kind words

                      Comment



                        First, thanks for this plugin! I'm really excited about it.

                        I used the ArchViz Project from the Learn tab, but there is quite a bit of noise, especially on the ceiling and walls, but not so much in other places. I don't have a top of the line computer but is good. i9 processor and RTX 2080 max Q (MSI laptop).

                        My best guess is, is that I can't seem to put the Texture quality over 2048 without it crashing, I've tried changing AA, I've tried using the high-quality settings as well and those don't seem to make a difference.

                        Do you have some ideas?

                        Comment


                          Originally posted by michalex19 View Post
                          First, thanks for this plugin! I'm really excited about it.

                          I used the ArchViz Project from the Learn tab, but there is quite a bit of noise, especially on the ceiling and walls, but not so much in other places. I don't have a top of the line computer but is good. i9 processor and RTX 2080 max Q (MSI laptop).

                          My best guess is, is that I can't seem to put the Texture quality over 2048 without it crashing, I've tried changing AA, I've tried using the high-quality settings as well and those don't seem to make a difference.

                          Do you have some ideas?
                          Good afternoon, michalex19!
                          Thank you for your purchase. Email me Lenina62-ivan@mail.ru if you can't apply these settings.
                          You have a great computer, but since raytracing is very demanding, you need to set the settings very carefully.

                          You have several ways to create a rendering.

                          1. Movie Redner Pipeline (In Unreal Engine 4.25) (youtube tutorial)
                          Step:
                          1. Add in scene acotrs (content/Camera_360/Blueprints) : Camera Rec 360 and Camera point 360
                          2. Select Camera Rec 360 and change settings:
                          Click image for larger version  Name:	Step_1.jpg Views:	0 Size:	500.4 KB ID:	1790518
                          3. Change settings in Post Process:

                          Click image for larger version  Name:	Step_2.jpg Views:	0 Size:	168.8 KB ID:	1790519
                          4. Open Movie Render Pipeline
                          Click image for larger version  Name:	Step_4.jpg Views:	0 Size:	92.4 KB ID:	1790520
                          5. Select Master_Sequence . Don't forget attached your Camera Poin 360 to camera sequence (tutorial)
                          Click image for larger version  Name:	Step5.jpg Views:	0 Size:	69.3 KB ID:	1790521
                          6. Select New preset settings:
                          7.Add settings, Antialiasing (Sample count = 2) , High resolution (Tile count = 3), and output
                          Click image for larger version  Name:	Step6.jpg Views:	0 Size:	130.6 KB ID:	1790522Click image for larger version  Name:	Step7.jpg Views:	0 Size:	175.6 KB ID:	1790523
                          Click image for larger version  Name:	Step8.jpg Views:	0 Size:	147.1 KB ID:	1790524
                          8. Accept and Start Rendering.
                          This solution best clear image full raytracing used Movie Render Pipeline.
                          Example youtube tutorial.


                          2. HighResShot system (youtube tutorial) .
                          Not clear image GI.

                          Tell me, did the solution help you? If not, write to me personally, I will contact you online. Lenina62-ivan@mail.ru

                          I lost my project with settings. I will publish an accurate video lesson soon to avoid noise. Please waiting video tutorial.
                          Last edited by ElizzaRF; 07-22-2020, 02:43 AM.

                          Comment


                            Hi, I just wanted to be sure if the Camera 360 is guaranteed to be "frame lock". Means that the game-play fps is lock to the rendering fps (like 24 fps for instance) and it cannot have frame de-sync because of a game-play lag, ... So that two different rendering have the exact same frames and timing. Can you guarantee that ? Or you know it's not "frame lock" ?

                            Comment


                              Originally posted by corentin-dpt View Post
                              Hi, I just wanted to be sure if the Camera 360 is guaranteed to be "frame lock". Means that the game-play fps is lock to the rendering fps (like 24 fps for instance) and it cannot have frame de-sync because of a game-play lag, ... So that two different rendering have the exact same frames and timing. Can you guarantee that ? Or you know it's not "frame lock" ?
                              Hi, corentin-dpt!
                              The first 5-10 frames at the beginning of rendering may be black, as the 360 camera is activated.

                              There are 3 rendering methods in Camera 360.
                              1. Sequencer https://youtu.be/HXADxhSp0To ;
                              2. Movide Render Pipeline https://youtu.be/a_vp7b5Blyg
                              Here all frames correspond to the frequency specified in these systems. If 24 frames, it will do 24 frames per second. If 30 frames, it will do 30 frames per second and so on. Freeze frame is not used. There are no missing frames.

                              3. HighResShot system https://youtu.be/J7uEiOhkH8o and Custom Rendering https://youtu.be/eUlgjTN-4Qg
                              The timeframe may differ by several frames, since the game is suspended. But not much. If the window is not active, frames may be skipped. This is why the window must always be active. You cannot use other applications.

                              All systems there is no desynchronization. That's right, even if your scene is very heavy, only 5 frames per second, rendering will have a specified frame rate, such as 30.

                              Comment


                                NEWS 07/24/2020. DOF (Depth of Field) for UE4.23, 4,24 and 4,25.
                                I'm running depth-of-field tests. I'm still checking everything.
                                The good news is that the DOF will be supported.
                                Video: https://www.youtube.com/watch?v=TAB42FEFPwo
                                But there are some notes:
                                1. the color scheme will be slightly different from the standard one;
                                Click image for larger version  Name:	Standart_Color.jpg Views:	0 Size:	298.7 KB ID:	1792128 Click image for larger version  Name:	Dof_Test2.jpg Views:	0 Size:	186.9 KB ID:	1792130
                                2. since DOF is a screen space effect, there may be seams in the blur, but if you try, you can avoid them.
                                Click image for larger version  Name:	Dof_Test2.jpg Views:	0 Size:	186.9 KB ID:	1792127Click image for larger version  Name:	Dof_Test1.jpg Views:	0 Size:	163.2 KB ID:	1792126
                                The update has already been sent to the Marketplace for verification.

                                Added new function:
                                Click image for larger version  Name:	DOF.jpg Views:	0 Size:	210.2 KB ID:	1792140
                                1. You need select Mode -> example: 360 Mono (Use 6 cameras).
                                2. Custom Render -> True
                                3. FullPostProcess -> True
                                4. Change values for DOF.

                                Note: Not working in 360 Mono (Use 1 camera). DOF raytracing support, but for record you need used sequencer or movie render pipeline. I need to change the logic of creating screenshots for raytracing + custom render and dof.
                                Last edited by ElizzaRF; 07-25-2020, 02:57 AM.

                                Comment

                                Working...
                                X