Announcement

Collapse
No announcement yet.

CAMERA 360 System (Blueprints)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by alb3360 View Post
    Hi ElizzaRF, I have another question for you: During the calculated animation, I see the lines of the borders of the six faces that make up the image, can't I delete them? In particular with objects near the camera I have problems: in the previous frames it works correctly, but then it doesn't calculate the upper part .. how can I solve it? {"data-align":"none","data-size":"custom","height":"516","width":"1031","data-attachmentid":1708573} {"data-align":"none","data-size":"custom","height":"516","width":"1032","data-attachmentid":1708575}
    Hi, alb3360!

    You have enabled debug mode. Please look at the picture. You must uncheck.

    Click image for larger version

Name:	DebugBorder.jpg
Views:	141
Size:	171.6 KB
ID:	1708587

    Tell me, did this help you?

    Comment



      yes, I activated it to show you that the stick randomly disappears at the top for no reason.

      Comment


        Originally posted by alb3360 View Post
        yes, I activated it to show you that the stick randomly disappears at the top for no reason.
        Sorry. I did not immediately understand your question.
        It happens that the camera climbs into the object and can look through it.
        You can slightly change the position of the 360 point or Сamera_Rec_360, So that the object is a little further away from the camera?
        Can you send me the project by e-mail Lenina62-ivan@mail.ru?
        Last edited by ElizzaRF; 01-15-2020, 09:48 AM.

        Comment


          Originally posted by ElizzaRF View Post

          Hi, Z Production!

          If you record 360 video in stereo mode, it will work, but when you look back, the stereo effect will be reversed, the eyes will change places. I am now thinking about how to fix it.
          Look please video 360 stereo and head rotate back.
          https://youtu.be/EkltpX2SnJ0

          If you record 180 videos , in stereo mode, everything works
          correctly
          https://youtu.be/2kPHQzMHs8U

          ​​​​​​
          Hi there! Any luck about finding a solution for this? Many thanks!

          Comment


            Originally posted by Jose I Rodriguez View Post

            Hi there! Any luck about finding a solution for this? Many thanks!
            Hi!
            I'm working on it now. I have a few ideas, but I'm not ready to say that it works 100% yet.

            Comment


              Originally posted by ElizzaRF View Post

              Hi!
              I'm working on it now. I have a few ideas, but I'm not ready to say that it works 100% yet.
              Thank you! Please keep us updated!

              Comment


                Originally posted by Jose I Rodriguez View Post

                Thank you! Please keep us updated!
                Hi!
                Soon there will be news about 360 stereo.

                Comment


                  News 01/20/2020. Update sent to store. New update 1.13 Fix 6.

                  Please see new stereo image.

                  https://drive.google.com/open?id=1Qr...Cf8RsmxUEARRCa

                  In the new update, the stereo modes 180 and 360 are fixed.

                  1. Mode 180 stereo.
                  - Camera Left and Right now the eyes form a greater stereo effect.
                  - Camera Top and Bottom unchanged.

                  2. Mode 360 stereo.
                  - Fixed looks stereo for camera Front, Back, Left and Right cameras. Now the stereo effect does not break. When turning in 360, now the eyes are not inverted.
                  - Camera Top and Bottom - I had to remove the stereo for these cameras. To avoid problems with stereo and cornering.

                  I looked through many possible solutions, while this is more or less a working option for 360 video in stereo format.

                  I added a little debug mode. The display of the right and left eye in debug mode, starts when a simulation or game.

                  Click image for larger version  Name:	Devug_Stereo.jpg Views:	0 Size:	263.0 KB ID:	1710902

                  1. The red zone - if your object falls into the red zone, this is a very bad stereo for the eyes. Comfortable distance for stereo outside the red zone.
                  2. You can see, when debug is activated, see in which areas there may be problematic seams for the stereo mode.
                  Click image for larger version  Name:	Devug_Stereo2.jpg Views:	0 Size:	234.3 KB ID:	1710903

                  Result for stereo - RIGHT Eye:
                  Click image for larger version  Name:	Devug_Stereo3_seams.jpg Views:	0 Size:	234.7 KB ID:	1710904

                  This happens because all the cameras are shifted to display the stereo correctly, but a seam artifact appears in the right eye.
                  I think considering that the left eye without seams, to some extent with the help of video editors, you can gloss over the seam, but for now it's hard for me to say for sure.

                  Looking up and down, I ruled out stereo so that there was no problem with inverting the image until I came up with some new working way.

                  Please let me know if this update helps you. If there are errors, be sure to let me know.
                  Last edited by ElizzaRF; 01-20-2020, 10:43 AM.

                  Comment


                    Originally posted by ElizzaRF View Post

                    Hi, Jemstoo!

                    With the release of each unreal engine version, the brightness changes in different ways.
                    Starting from 4.22, 4.23, 4.24, the exposure setting is changed in Camera Iso. Be sure to specify a manual exposure mode.

                    1.Yes, there is a pixel distortion at the bottom and top, but this is not related to the operation of the panoramas of the plugin. I have a different approach and I plan to fix this in future updates.
                    As a solution, you can try to darken the area, put a logo under the camera, maybe use blur in this area.

                    2. Yes, you can resize to a higher resolution.
                    If you use the Sequencer Editor https://youtu.be/HXADxhSp0To in Unreal Engine, then there are image limitations at 7680x7680 or 7680x3840.
                    If you use the HighResShot system, you will not have a pixel limit.
                    Please see video tutorial HighResShotSystem.
                    Tutorial 1: https://youtu.be/XAT3CwxCP08?t=77
                    Tutorial 2: https://youtu.be/J7uEiOhkH8o

                    Do not forget to increase the size Render Target Texture - recomended 4096 px for best quality.


                    Description camera 360
                    Important/Additional Notes:
                    Sequencer Editor:7680x7680 px.
                    RenderTarget Texture: 2048, you can change the resolution of the render target Textures at higher resolutions (4096 and more).
                    HighResShot System- not limit px for sequence and screenshot. However, if you specify a very large size, the application may crash.This is enough for 4K, 8k video.
                    Hello ElizzaRF, many thanks for your advice. I managed to export 8k video with the HighResShotSystem. I have one more problem: it take a long time to do it. My computer need one hour to export 160 .png picture. Could you have a look to my setting please ? (see photo in attachment) I think several paramater can be optimize.

                    See below more setting which doesn't appears in the picture :

                    - I changed the resolution of each render target Textures to 4096 px (12 pictures). I don't know if this setting is the same as "Quality (Texture Size)" appearing in Camera_Rec_360 properties. May one of this setting have priority to the second ? Or they don't do the same thing maybe ?
                    - I have 8GB of graphic card memory
                    - My goal is to have the most accuracy aliasing. Indeed, the project I am working on is like vector picture. Line must be as clear as possible
                    - below the link to the export video test

                    https://youtu.be/YxZZ9Z7_1HM

                    Have a good day

                    Comment


                      ElizzaRF oh my, so volumetric 360 is finally fixed? Amazing! It will work with previous pre-rendeed videos used by the plugin, or those needs to recorded again?
                      Last edited by Jose I Rodriguez; 01-21-2020, 06:33 AM.

                      Comment


                        Originally posted by Jemstoo View Post

                        Hello ElizzaRF, many thanks for your advice. I managed to export 8k video with the HighResShotSystem. I have one more problem: it take a long time to do it. My computer need one hour to export 160 .png picture. Could you have a look to my setting please ? (see photo in attachment) I think several paramater can be optimize.

                        See below more setting which doesn't appears in the picture :

                        - I changed the resolution of each render target Textures to 4096 px (12 pictures). I don't know if this setting is the same as "Quality (Texture Size)" appearing in Camera_Rec_360 properties. May one of this setting have priority to the second ? Or they don't do the same thing maybe ?
                        - I have 8GB of graphic card memory
                        - My goal is to have the most accuracy aliasing. Indeed, the project I am working on is like vector picture. Line must be as clear as possible
                        - below the link to the export video test

                        https://youtu.be/YxZZ9Z7_1HM

                        Have a good day
                        Hi, Jemstoo!

                        Properties: Quality (Experimental) = Texture Size 12 textures.
                        This is the same property if you do it manually for 12 textures. You can always use this property, except when you need to adjust the focus for each camera, the depth, or a custom post-process, then you need to do everything manually.

                        I noticed that you set the texture quality to 7680 (Quality (Experimental) = 7680 ). This is a lot, so rendering takes longer.
                        I recommend that you just disable the anti-aliasing property, and then all the borders will be very clear.
                        Set the texture quality to 4096 and compare it with the 7680 you made earlier.Then try 5000 and compare with 7680. I think the boundaries will be very clear.

                        Please write to me, does the solution help you?

                        I noticed that there is a small seam at the bottom, I think in the post process you have the bloom = 0675 or vignette = 0.4 parameter.
                        To reduce the seam or remove it, you can set the value to 0.
                        bloom = 0 or vignette = 0.
                        https://forums.unrealengine.com/unre...93#post1660593

                        Last edited by ElizzaRF; 01-21-2020, 09:27 AM.

                        Comment


                          Originally posted by Jose I Rodriguez View Post
                          ElizzaRF oh my, so volumetric 360 is finally fixed? Amazing! It will work with previous pre-rendeed videos used by the plugin, or those needs to recorded again?
                          Hi, Jose I Rodriguez!

                          If you recorded a video in stereo format, you can only record the right eye and replace it in your video=) the changes touched the right eye for stereo.

                          However, it's not 100% pure high-quality stereo yet, as you can see the seams in your right eye. Additional video processing may be required to erase the seams, if possible.

                          I would also recommend using debag, for example, to track areas where there may be seams, and, for example, to prevent objects from falling into them.

                          In any case, I will still think about how to fix the seams, but this option is really better and gives the right solution even for some seams.

                          You can see an example here (debug seams).

                          Click image for larger version  Name:	Debug_Seams.jpg Views:	0 Size:	457.6 KB ID:	1711347
                          Result:
                          Click image for larger version  Name:	360_Seams.jpg Views:	0 Size:	288.8 KB ID:	1711348

                          These are stitches in the right eye. As you can see, if the object falls into the suture area, there will be artifacts in the right eye.
                          I noticed that the farther away the objects are, the less visible these seams are. But this solution works and the 3D is displayed correctly, but with seams.

                          Now I will work on removing stitches, I have ideas on how to fix this, but you need to wait.
                          Last edited by ElizzaRF; 01-22-2020, 05:40 AM.

                          Comment


                            News 01/21/2020. Update released. New update 1.13 Fix 6.
                            https://forums.unrealengine.com/unreal-engine/marketplace/1595263-camera-360-system-blueprints?p=1710901#post1710901​​​​​​​

                            Please Exit Epic Launcher and restart. Chose Camera 360 in library products and update button.

                            Comment


                              Originally posted by ElizzaRF View Post

                              Hi, Jemstoo!

                              Properties: Quality (Experimental) = Texture Size 12 textures.
                              This is the same property if you do it manually for 12 textures. You can always use this property, except when you need to adjust the focus for each camera, the depth, or a custom post-process, then you need to do everything manually.

                              I noticed that you set the texture quality to 7680 (Quality (Experimental) = 7680 ). This is a lot, so rendering takes longer.
                              I recommend that you just disable the anti-aliasing property, and then all the borders will be very clear.
                              Set the texture quality to 4096 and compare it with the 7680 you made earlier.Then try 5000 and compare with 7680. I think the boundaries will be very clear.

                              Please write to me, does the solution help you?

                              I noticed that there is a small seam at the bottom, I think in the post process you have the bloom = 0675 or vignette = 0.4 parameter.
                              To reduce the seam or remove it, you can set the value to 0.
                              bloom = 0 or vignette = 0.
                              https://forums.unrealengine.com/unre...93#post1660593
                              Hello, I did not understand your explanation about Quality(Experimental)= Texture Size 12 textures, and its link with all Render Target Texture. However, I downloaded your latest version and I used it to do some test so, the 12 render target texture have 2048 px texture size by default and I didn't change their settings this time.
                              In the image attached to this message, you can see 4 settings and their result. I need the best quality so, the fourth is better than the other (May I didn't explained you correctly: I need anti-aliasing)
                              I also checked bloom and vignette. You was right and I disabled this two settings
                              Have a nice day
                              Attached Files
                              Last edited by Jemstoo; 01-23-2020, 05:18 AM.

                              Comment


                                Originally posted by Jemstoo View Post

                                Hello, I did not understand your explanation about Quality(Experimental)= Texture Size 12 textures, and its link with all Render Target Texture. However, I downloaded your latest version and I used it to do some test so, the 12 render target texture have 2048 px texture size by default and I didn't change their settings this time.
                                In the image attached to this message, you can see 4 settings and their result. I need the best quality so, the fourth is better than the other (May I didn't explained you correctly: I need anti-aliasing)
                                I also checked bloom and vignette. You was right and I disabled this two settings
                                Have a nice day
                                =))) Hi!

                                I wanted to say that this is the same =)
                                Previously, you had to change the texture quality manually, it was solution 1.

                                Click image for larger version

Name:	RenderTargetTexture_Default.png
Views:	103
Size:	125.6 KB
ID:	1712232
                                Please see video:
                                https://youtu.be/7EMAmT572w0?t=274

                                Then I released a new update new solution 2 and added a button Quality(Experimental).

                                Click image for larger version

Name:	RenderTargetTexture1.png
Views:	89
Size:	86.0 KB
ID:	1712233

                                Now you can just click the checkmark and change the resolution of the textures automatically.
                                Both methods are the same.

                                I see 7936 and 8192 quality experimental.
                                Have you checked, with activated Quality Experimental and smoothing, 4096, 5000, Is this quality still much inferior?

                                My Test image:

                                Quality Experimental = 4096 and 8000.
                                Antialiasing = true.

                                Click image for larger version

Name:	Image360_RQ_Comprassion.png
Views:	97
Size:	191.0 KB
ID:	1712234

                                Of course you have more vector graphics and maybe the difference is more noticeable.

                                Try the Raytracing checkmark? And check if the rendering time changes.

                                Click image for larger version

Name:	Raytracing.png
Views:	73
Size:	71.6 KB
ID:	1712235

                                In any case, I am always happy to help you. Thanks!




                                Comment

                                Working...
                                X