Announcement

Collapse
No announcement yet.

CAMERA 360 System (Blueprints)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    News 11/30/2019. Tutorial. Master Sequencer.

    You can use Your customized cameras using the Master Sequencer
    https://youtu.be/pHPKJRH7Uxw

    Opened Unreal Engine Assets 360 used Camera 360. On this channel you will find information on how much time it took to render frames, what settings are applied when rendering the camera as well as colorful presentations of unreal engine martetplace assets.
    https://www.youtube.com/channel/UC-65FNFxz31v8xDtz-Je3cw

    Click image for larger version

Name:	Assets.jpg
Views:	81
Size:	231.3 KB
ID:	1692712

    Comment


      Originally posted by ElizzaRF View Post

      Thank you, I'm glad you like the plugin. Do you have an example scene? It would help me a lot and I would check everything.
      If you set the temporary AA mode, your picture will be blurred.
      MSAA allows you to get a clear picture.

      You can try to use Temporal AA, but with the HighResShot System, I added a new feature in it.
      You need to tick raytracing.
      Please see tutorial https://www.youtube.com/watch?v=XAT3CwxCP08



      hello, I followed your instructions and activated raytracing.
      I use an RTX 2080 but I still have the cartoon effect using the temporalAA filter.


      I am attaching two partial screenshots of the image at 100% of the size:


      1.TEMPORAL AA:





      2. MSAA:


      Thanks for your help
      Attached Files

      Comment


        Originally posted by alb3360 View Post




        hello, I followed your instructions and activated raytracing.
        I use an RTX 2080 but I still have the cartoon effect using the temporalAA filter.


        I am attaching two partial screenshots of the image at 100% of the size:


        1.TEMPORAL AA:





        2. MSAA:


        Thanks for your help
        Good day, alb3360!

        I can’t see the images, maybe they were downloaded with an error.

        Can you repeat and attach the images?

        Comment


          Originally posted by ElizzaRF View Post

          Good day, alb3360!

          I can’t see the images, maybe they were downloaded with an error.

          Can you repeat and attach the images?

          Sorry...


          temporalAA:
          Click image for larger version

Name:	test-TemporalAA.JPG
Views:	58
Size:	139.1 KB
ID:	1693659



          MSAA:
          Click image for larger version

Name:	test-MSAA.JPG
Views:	52
Size:	199.4 KB
ID:	1693660

          Comment


            Originally posted by alb3360 View Post


            Sorry...


            temporalAA:
            Click image for larger version  Name:	test-TemporalAA.JPG Views:	0 Size:	139.1 KB ID:	1693659



            MSAA:
            Click image for larger version  Name:	test-MSAA.JPG Views:	0 Size:	199.4 KB ID:	1693660
            Do you have the opportunity to direct me a small scene so that I can conduct experiments to achieve the best smoothing quality? Link to the project, please send by personal mail. Mail: Lenina62-ivan@mail.ru Do not worry about confidentiality, after help, I delete projects.

            I would also like to see the settings of the 360 camera. Can you send me an image?

            I will find some resource to check possible anti-aliasing options. I will write to you later.
            Last edited by ElizzaRF; 12-03-2019, 09:17 AM.

            Comment


              Originally posted by alb3360 View Post


              Sorry...


              temporalAA:
              Click image for larger version

Name:	test-TemporalAA.JPG
Views:	58
Size:	139.1 KB
ID:	1693659



              MSAA:
              Click image for larger version

Name:	test-MSAA.JPG
Views:	52
Size:	199.4 KB
ID:	1693660
              Have you tried setting up the camera like in this video?

              https://youtu.be/LyFImwdKqME

              To avoid seams, Post Processing settings are applied.
              Settings Post Process for Camera 360:
              1. Vignete: 0
              2. Exponecial Heigh Fog : Volumetric Fog Off
              3. Ambient Occlusion: 0
              4. ScreenSpaceReflection: 0
              5. Bloom: 0

              Camera 360 settings: Aspect Ratio: 1:1
              Output: Frames: 3614 frames
              Rendering time: ~ 1 hour 33 minutes
              Rendering 1 frame: ~ 1-2 second
              Render Target Texture (Quality): 4096 Px.
              Size Output Image: JPG, 7680x7680

              I very often apply quality to get 8K and 4k video.

              Comment


                Originally posted by ElizzaRF View Post

                Have you tried setting up the camera like in this video?

                https://youtu.be/LyFImwdKqME

                To avoid seams, Post Processing settings are applied.
                Settings Post Process for Camera 360:
                1. Vignete: 0
                2. Exponecial Heigh Fog : Volumetric Fog Off
                3. Ambient Occlusion: 0
                4. ScreenSpaceReflection: 0
                5. Bloom: 0

                Camera 360 settings: Aspect Ratio: 1:1
                Output: Frames: 3614 frames
                Rendering time: ~ 1 hour 33 minutes
                Rendering 1 frame: ~ 1-2 second
                Render Target Texture (Quality): 4096 Px.
                Size Output Image: JPG, 7680x7680

                I very often apply quality to get 8K and 4k video.


                hello, thanks for the help! Yes I set these parameters but I still have that cartoon effect. if we solve it I would be very happy ... The scene is very light and changes from the images I sent you, but I have the same problems! I'm sending you the file with wetransfer. regards



                Comment


                  Originally posted by alb3360 View Post



                  hello, thanks for the help! Yes I set these parameters but I still have that cartoon effect. if we solve it I would be very happy ... The scene is very light and changes from the images I sent you, but I have the same problems! I'm sending you the file with wetransfer. regards


                  Hi! I understood you. I saw a letter. Now I’ll check everything and write to you later.

                  Comment


                    Originally posted by ElizzaRF View Post

                    Hi! I understood you. I saw a letter. Now I’ll check everything and write to you later.
                    Good day!
                    I managed to find a problem where TemporalAA smoothing did not work. Now I’ll check everything, if everything goes well, there will be anti-aliasing in the new update.

                    Click image for larger version

Name:	TemporalAA_Corrected.png
Views:	25
Size:	75.9 KB
ID:	1695140
                    Last edited by ElizzaRF; 12-06-2019, 03:51 PM.

                    Comment


                      News 12/09/2019. New update 1.13 fix 5.
                      Added the ability to use the correct anti-aliasing TemporalAA.

                      Click image for larger version  Name:	AntiAliasing_TemporalAA.png Views:	0 Size:	113.1 KB ID:	1695286

                      In the project settings (Edit -> Project Settings -> Rendering) , Anti-Aliasing the TemporalAA smoothing method should be selected.

                      Click image for larger version  Name:	AntiAliasing_ProjectSettings.jpg Views:	0 Size:	100.5 KB ID:	1695288

                      Now you can disable and enable anti-aliasing if required in option Camera_Rec_360 actor.

                      Click image for larger version  Name:	AntiAliasing_TemporalAA_Value.png Views:	0 Size:	12.4 KB ID:	1695287

                      This video - new corrected Anti-Aliasing TemporalAA method.
                      https://youtu.be/KU01Uy4n8wU
                      Last edited by ElizzaRF; 12-09-2019, 02:03 PM.

                      Comment



                        Good job! and great support! thank ... You solved my problems!


                        Comment


                          Originally posted by alb3360 View Post
                          Good job! and great support! thank ... You solved my problems!

                          Thanks!
                          Update is already available.You need to close Epic Launcher and update Camera 360!

                          Comment


                            News 12/11/2019.

                            I managed to automate the connection to the configured sequencer cameras.
                            This makes it easier for those who have configured the project with cameras in the sequencer.
                            Now I’ll check what errors may be fixes.
                            Click image for larger version

Name:	Sequencer_Fight_Scene.jpg
Views:	0
Size:	184.2 KB
ID:	1696831
                            360 3D video Fight Scene using automatic attached camera 360 in sequencer
                            https://youtu.be/b3VMr7So7XE

                            Comment

                            Working...
                            X