Announcement

Collapse
No announcement yet.

[SUPPORT] Advanced Mission And Notification System V3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by LordEggi2 View Post

    Thanks for the answer and i kinda solved the issue now but only kinda. I used the Create Mission UI in the Level Blueprint and now it works but it doesnt work in my player bp because i posses my player in the BP. So my question now would be, does it work to let the Create Mission UI be created in the Level BP or does it have to be the Player Bp
    You can try to get your character's reference in level blueprint and get component's reference from that character reference. I'm not sure if it's a good thing to do but worth to try. Just an idea
    Advanced Mission And Notification System V3 - Advanced Inventory And Weapon System - Advanced Safe Zone - Root Motion Controller Framework

    Comment


      #32
      I was being stupid xD I didnt know, there was a Auto Possess Player in the third person character lmao and since i make a singleplayer game this works just fine thanks for the effort to help ^^

      Comment


        #33
        Hey Nocte! Hope all is well, thank you for such a wonderful tool for us creators to use! A few simple questions for you:

        How do I go about enabling and disabling an actors quest, as well as giving an actor multiple quest. Thank you so much in advance.

        Comment


          #34
          What i need to add on my monster BP to integrate on this system?

          Comment


            #35
            Originally posted by Dread_Fort View Post
            Hey Nocte! Hope all is well, thank you for such a wonderful tool for us creators to use! A few simple questions for you:

            How do I go about enabling and disabling an actors quest, as well as giving an actor multiple quest. Thank you so much in advance.
            Hey! I'm glad you like it. Actor's can be enabled after specific missions in current setup. All you have to do is adding that actor you want to enable to your mission's 'On Mission Finished' part in data table. You will see 'Actors To Enable'. All same with in character BP. And for multiple missions all you have to do is enabling the Multi Mission Actor boolean inside of your NPC then you can set the mission count to show at one time via integer variable.

            Originally posted by Golskila View Post
            What i need to add on my monster BP to integrate on this system?
            There are only couple of nodes that you need to move to your Monster BP. Such as 'Assign Monster' on begin play, 'Send Killed Monster Info' when you killed your monster. And you need to send reference of that actor like i did when you apply damage to your monster. The important part is that you need to create the same Monster Info variable in yours and set it as the same with BP_MasterMonster blueprint's construction script. These are all should be fine.

            Let me know if you guys any other questions and please feel free to join to discord channel to get faster support.

            Thanks!
            Advanced Mission And Notification System V3 - Advanced Inventory And Weapon System - Advanced Safe Zone - Root Motion Controller Framework

            Comment


              #36
              Hi, I recently integrated this kit into a project I had already been working on and have run into a few, hopefully small problems. Everything seems to work with my character except for the widgets I had already set up. For example, when I open the save game menu, my widget opens and I can move the mouse cursor, but I cannot click or use any of the buttons in my menu. If looked around the mission component a little but figured I would ask first.

              Comment


                #37
                Do the quests and state/data save between sessions?

                Comment


                  #38
                  Hello!
                  Thank you for that great tool. I have a question.
                  I want to interract your tool with my dialogue system:
                  1. Delete the text "Press E to interact"
                  2. Activate your dialogue system and mission widget after choosing the right option in my dialogue, not after pressing E.
                  3. In the "interaction" mission - I want to set character as interacted after a dialogue with him, not pressing E.
                  Can you tell me how to do that, please?
                  I am waiting for your anwser. Sorry for my fatal english

                  Comment


                    #39
                    Hi !
                    I have this error, can you help me ? Thx

                    Blueprint Runtime Error: "Accessed None trying to read property MasterManager". Blueprint: BP_ObjectivesComponent Function: Execute Ubergraph BP Objectives Component Graph: EventGraph Node: Branch
                    Blueprint Runtime Error: "Accessed None". Blueprint: BP_ObjectivesComponent Function: Execute Ubergraph BP Objectives Component Graph: EventGraph Node: Branch
                    Blueprint Runtime Error: "Accessed None trying to read property MasterManager". Blueprint: BP_ObjectivesComponent Function: Execute Ubergraph BP Objectives Component Graph: EventGraph Node: Add
                    Blueprint Runtime Error: "Accessed None". Blueprint: BP_ObjectivesComponent Function: Execute Ubergraph BP Objectives Component Graph: EventGraph Node: Add
                    Play in editor start time for /Game/UEDPIE_0_NewWorld 0,677

                    Comment


                      #40
                      I've merged this 2 times, one implementation with a fresh Third Person Template and one with a new AdvancedLocomotion System V3 template and in both versions the framerate keeps slowly dropping to below 10fps. Before implementing the framerate was at a steady 100fps. I did it multiple times so I'm not sure what goes wrong, any Idea's?

                      Comment


                        #41
                        Originally posted by FenetreXxMagique View Post
                        Hi !
                        I have this error, can you help me ? Thx

                        I Got the same error, figured it out already?

                        Comment


                          #42
                          Everytime I change something in the Datatable I have to restart the project to see the changes, does anyone else has the same issue? And how to fix it, because this way it is really annoying to change anything...

                          Comment


                            #43
                            Hey so a few people have been getting accessed non errors. I am getting them too. I have tried setting the CompassReference default to something, however there is nothing to set it to. Here are my errors:
                            1.
                            Blueprint Runtime Error: "Accessed None trying to read property CompassReference". Blueprint: BP_Mission_Component Function: Update Monster Markers Graph: ForEachLoop Node: Branch

                            2.
                            Blueprint Runtime Error: "Accessed None". Blueprint: BP_Mission_Component Function: Update Monster Markers Graph: ForEachLoop Node: Branch

                            and these errors repeat hundreds of times for everything in the BP_Mission_Component


                            I really don't know how to solve this.

                            Comment


                              #44
                              Originally posted by Techdeath666 View Post
                              Hi, I recently integrated this kit into a project I had already been working on and have run into a few, hopefully small problems. Everything seems to work with my character except for the widgets I had already set up. For example, when I open the save game menu, my widget opens and I can move the mouse cursor, but I cannot click or use any of the buttons in my menu. If looked around the mission component a little but figured I would ask first.
                              I'm having the same problem, after integrating this system, none of my existing UI works (inventory etc). All of the UI used by advanced mission and notification works fine, it just seems to disable input (tested using mouse/keyboard) altogether when I'm in my existing UI. e.g if I open inventory, I can't navigate through it or close it.

                              Any help would be much appreciated. Thanks

                              Comment


                                #45
                                Techdeath666 it turns out the z order of the AMNS UI widget is being set to 0, I fixed it by going to BP_MissionComponent, Set Default Arrays function, look for Add Viewport node, click the arrow at the bottom which will reveal the z order pin. Set it to -1 and you should be good to go, if not, keep lowering the number to see if it eventually works.

                                Comment

                                Working...
                                X