Announcement

Collapse
No announcement yet.

Smooth Sync: Sync your Transforms Smoothly across the network

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    GuacFrog
    The new version is now on the Marketplace so you won't need to copy over the files like described above any more.
    Let me know if that helps or not.

    Leave a comment:


  • replied
    Aeromir ojl10
    Hmm. I thought Unreal rejected that release because of the new things they are checking. Weird. Anyway..

    Version 1.31 is now (or the official version will be in a few days?) available on the Marketplace!

    Change Log:
    Memory usage more efficient.
    Added null checks to reduce errors.
    Exposed interpolationTime variable so people can line up their animations with the time that Smooth Sync is using. (which uses UGameplayStatics::GetRealTimeSeconds)
    Fixed divide by zero issue on extrapolation and interpolation.
    Last edited by fuestrine; 10-04-2020, 08:42 PM.

    Leave a comment:


  • replied
    as above ^ Any notes on the new update?

    Leave a comment:


  • replied
    Hey guys,

    Are there changelog notes for the latest update?

    Leave a comment:


  • replied
    GuacFrog
    Hmm. I'm not getting the issue on my end.
    I'll PM you the code and you can see if it's fixed or not.

    If that doesn't fix it, we'll have to see if we can get it to happen in one of the templates so we can isolate that Smooth Sync is the issue.
    Do you know if this happens in one of the blank templates?
    Last edited by fuestrine; 09-24-2020, 05:48 PM.

    Leave a comment:


  • replied
    fuestrine Any updates on the issue?

    Leave a comment:


  • replied
    fuestrine I did not end up editing SmoothSync. Although, if the newer files do indeed fix this glitch, I'l gladly install them manually.

    Leave a comment:


  • replied
    The error doesn't look like it has to do with smooth sync to me, but I have isolated the EnableSmoothSync(true) function to ensure it is the culprit.

    Leave a comment:


  • replied
    This crash does not occur every time smooth sync is enable during runtime. Around 1/2 of the time.
    Attached Files

    Leave a comment:


  • replied
    GuacFrog
    Can you paste me the whole error?

    I just released a fix that fixed up some similar issues so it may be covered already too. It takes Unreal about 5 days to accept something so I'd expect it by mid next week.

    Did you ever end up editing Smooth Sync from before? If you did, let me know and I can send you the new files and you can check it out sooner.
    If not and you want to know how, check this out: https://forums.unrealengine.com/unre...13#post1777913

    Leave a comment:


  • replied
    Smooth sync crashes the editor when I call "EnableSmoothsync". It is a null pointer exception. Any ideas?

    Leave a comment:


  • replied
    Hmm. I'll have to take a look into that. I'll get back to you. Sorry about the issues.

    Yes, print out all the different velocities and see if any of them line up to what you want. Then maybe you could even alter this code to set the velocity to the thing you want.
    Maybe also check out SmoothSync.getLinearVelocity() and maybe it's trying to send something you aren't expecting.

    Leave a comment:


  • replied
    Originally posted by fuestrine View Post
    FAXCORP
    Are you adding a second SmoothSync component to a single object?

    Are you using SmoothSync.SetSceneComponentToSync()?

    Maybe check out the setLinearVelocity() method in SmoothSync.cpp and see if that looks like it's setting velocity to something different than expected.
    Yes, Im adding a second smoothsync component to a single object. First one is not using SetSceneComponentToSync as its for the actor itself, second one is set to sync camera

    What exacly do I check in the cpp? Print out the velocity?

    Leave a comment:


  • replied
    FAXCORP
    Are you adding a second SmoothSync component to a single object?

    Are you using SmoothSync.SetSceneComponentToSync()?

    Maybe check out the setLinearVelocity() method in SmoothSync.cpp and see if that looks like it's setting velocity to something different than expected.

    Leave a comment:


  • replied
    Hi. I am encountering an issue where if I add a second SmoothSync component (to sync camera rotation on my character), the animations for running stop working (in animation blueprint controlled using velocity). Is this a bug? (First smooth sync component replicates actor transforms)

    Leave a comment:

Working...
X