Announcement

Collapse
No announcement yet.

[Personal Opinion] Why I'll never buy Marketplace content again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [Personal Opinion] Why I'll never buy Marketplace content again

    Ok as the title says this is my personal opinion but i hope it points out one of the biggist gripes i have about marketplace content.

    the issue i have is UPDATING, i like to keep the engine in its newest form so that i get all the new shinny stuff, this causes an issue if your project relies on MP content, as you can only install the content on a correct install version, to put it plain if you MP content hasn't been updated for a few builds then your stuck, yes you can migrate to a newer build but you still have to have the older version of the engine installed just in case you need to replace the older mp content.

    now just imagine you have MP content since the start of the Marketplace that hasn't been updated and you decide you what to use it in a new project, how many versions of the engine do you want to dl/install or are you happy to migrate if you still have a project with the content in.

    Thankfully UE4 is just a hobby so i can say sod it, and wasted my cash.

    the option would be to allow the end user to re-validate the content for the current engine build
    UT40K:The Chosen - Warhammer 40,000 for UE4
    ut40kgeodav - UE4 Tutorials

    #2


    The compatibility issues is an Epic Games design problem that can be solved by them only. At this point maybe Unreal Engine 5 when it will happen maybe will have some automatic compatibility layers conversions to ensure that any asset could keep working on any engine version. Until Epic Games does anything like that there is no real way to fix the compatibility problem.
    Many free UE4 assets don't get updated too but with some effort they can still be used on the newest engine release, still it requires some work. Not buying MarketPlace content is not a real option for anyone developing a game or something else with the engine that is not a large software house with its own employees for everything. Most indie games made with Unity and Unreal Engine are using assets bought on the respective stores and other stores too. Otherwise single freelancers and very small software houses wouldn't be able to deliver games in a few months or a few years released on Steam or elsewhere.

    Comment


      #3
      Not a big problem. You can choose the build components (by pressing the settings tab) while you install engine. Therefore it will not have a big size.

      Comment


        #4
        Regarding Marketplace and Launcher Updates:

        A. Having to keep 5-10 engine versions is a necessary evil but it eats disk space. That means you often have to Delete an engine version or two even temporarily. However, the Launcher often prevents you from downloading Updates, if you don't have a matching version of the engine installed locally.... So how about an Advanced option, that lets you download to a side folder anyway? (Patches especially etc). Add-To-Project is also a PITA sometimes. Please just give us the option to place downloaded files in an isolated folder of our choosing.... Other important reasons for this request:

        B. Constant patching of Windows machines against Malware eats into precious development time. Its often easier to develop offline on air-gapped machines and leave sacrificial boxes connected to the net. Thankfully, UE4 Launcher Binary-Builds / Marketplace-packs can be copied between machines with ease... But not, if the Launcher bombs out by doing local version checks first!

        C. How many devs get to enjoy the benefits of Windows 10 LTSB??? Not me for sure! Microsoft's insistence on forcing updates onto development machines is unacceptable. Plus paying to be slurped by Windows Telemetry??? Would you please f'off MS! So having a Launcher that recognizes this, and offers more flexibility would be greatly appreciated Epic!

        D. Linux users have no choice but to use the windows Launcher. Allar once offered an alternative script-based-downloader, but it no longer works iirc. Since a Linux Launcher isn't likely any time soon, please build in some added flexibility and consider the wider applications here. Overall, stop making unhelpful assumptions about the local machine. Hopefully you can see, it doesn't offer a complete picture!

        Comment


          #5
          Geodav

          Not to side-track the thread or get a bottle smashed over my head by asking, BUT:

          What if we had an optional TRY BEFORE YOU BUY model on the Marketplace???

          For starters, it would probably need to be long-term subscription based. Plus setting Piracy issues aside for a moment, lets accept that this could only ever be offered to a select few with a proven track record and a permanent balance or float on the marketplace (something not practical right now with all the security issues etc).

          As an idea, it would help deal with a lot of Marketplace BS, and cut down on some of the goodwill lost from packs that look great, but get lost in translation... By that I mean, packs that don't easily integrate into your own project (for all the reasons outlined here or in other threads so as not to repeat). Overall, the MP refund policy is not that consumer friendly. Of course this is the challenge of Digital goods versus Physical, which we all know already (the risks / rewards are different). But to MP vendors, YOU ARE LOSING SALES because of this. Personally, I find its easier to look around for a free template or example and customize that instead, as the integration workload is often the same. Either way, maybe when UE5 arrives there will be more MP options...

          Comment


            #6
            I believe a lot of problems come from the idea of having a separate team of programmers working on the Launcher only.
            They aren't involved with engine development at all.
            ​​​​​
            | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

            Comment


              #7
              Originally posted by Geodav View Post
              You still have to have the older version of the engine installed just in case you need to replace the older mp content.
              No? Why do you think this?



              Check out my discord -> https://discord.gg/kQdVwJ3

              Follow us on twitter to get updates on new products and special offers -> https://twitter.com/BlackFangTech

              Black Fang Technologies' products -> https://www.unrealengine.com/marketp...20Technologies

              Comment


                #8
                If there's a product that was released since the start of the marketplace, and it hasn't been updated then that product should no longer be available on the store as that's against the terms.

                That being said, a lot of content (particularly when it comes to environments, music, materials and textures) do not require any special work, simply a checkbox on the seller portal. But in those cases it shouldn't take long to have them marked for compatibility.

                I am sorry to hear this has been your experience with the marketplace though. =/

                Simulacrum Game | Play The Alpha | Caldera Entertainment | Twitter | ArtStation

                Comment


                  #9
                  BlackFangTech interesting but the content i use is a base project eg i can't add it to another project, i have to build the base and add my stuff to it, in my case the author said he uploaded a 4.19 version a month ago but still no show on the launcher, yes i've asked on his discord channel but waiting for Epic !!!.

                  tbh not to bothered as my project is pretty much on hold till i can be bothered, but if this happens with a reknown author how do people deal with the not so good guys.

                  i just wish we had an option to self authorise older content with newer engine builds
                  UT40K:The Chosen - Warhammer 40,000 for UE4
                  ut40kgeodav - UE4 Tutorials

                  Comment


                    #10
                    I don't understand why you have to reimport something instead of simply upgrading existing project.

                    Even plugins can be easily manually rebuilt for different major engine version, if you have visual studio and C++ Compiler, instead of waiting for Marketplace team to update it.
                    | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

                    Comment


                      #11
                      Originally posted by Geodav View Post
                      BlackFangTech interesting but the content i use is a base project eg i can't add it to another project, i have to build the base and add my stuff to it, in my case the author said he uploaded a 4.19 version a month ago but still no show on the launcher, yes i've asked on his discord channel but waiting for Epic !!!.

                      tbh not to bothered as my project is pretty much on hold till i can be bothered, but if this happens with a reknown author how do people deal with the not so good guys.

                      i just wish we had an option to self authorise older content with newer engine builds
                      Oh, that makes sense. Products that are distributed as projects are so inconvenient that I don't buy or use them, so I wasn't thinking of that.

                      Check out my discord -> https://discord.gg/kQdVwJ3

                      Follow us on twitter to get updates on new products and special offers -> https://twitter.com/BlackFangTech

                      Black Fang Technologies' products -> https://www.unrealengine.com/marketp...20Technologies

                      Comment

                      Working...
                      X