Announcement

Collapse
No announcement yet.

Snappy Roads Blueprint Tool: Announce and Support Thread

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    jedellvc Thank you for the feedback. I'll look into it. Does it only happen with a certain Distribution Method?

    Wallenstein Thank you for helping people out in this thread. But please don't post whole chunks of code in a forum thread, you can send PM instead. I've added your fix to the project it will be in the next update.

    Comment


      Originally posted by GlimpseOfDawn View Post
      Thank you for helping people out in this thread. But please don't post whole chunks of code in a forum thread, you can send PM instead. I've added your fix to the project it will be in the next update.
      It's a small snippet highlighting the location of an issue - it has little value out of context, so I wouldn't be worried about it.

      As an aside, I don't think that's fixing the bug, just removing the error message by causing potentially different problems. The bug is caused by that loop trying to iterate over indices that don't exist.

      Comment


        In a first test, I tried placing a barrier (offset=0) and a guardrail (offset=800). In the attachment, you can see that the barrier is fine, but the guardrail follows the road in x and y, but not always in z. Is this expected behavior. Any work arounds?
        Attached Files
        Last edited by FriedOkra; 02-07-2019, 02:16 PM. Reason: added attachment

        Comment


          FriedOkra That's probably caused by some of the spline points not having a rotation vector set to zero. To fix this select a closest point on a spline, go to Details Tab (Components view) -> Scene (Inherited) -> Spline (Inherited) -> Selected Points (Category) and make sure Rotation property is set to (0.0,0.0,0.0). Repeat for other points if needed.

          ambershee I think this bug appears when using Single(Legacy) mode. This mode was left only with backwards compatibility in mind and should not be used. It will be removed in the next update to avoid confusion.

          Comment


            GlimpseOfDawn I am having trouble with this asset. I follow the tutorial and it aligns with the terrain however the road dissappears. The wording on some of the settings in the Details pane is different than your tutorial.

            Below is what my roads look like after following tutorial:
            Click image for larger version

Name:	Image-4.png
Views:	2
Size:	231.4 KB
ID:	1590646
            How do I raise the road or allow the road to show through?

            Thanks,
            Attached Files

            Comment


              It's been a while for me but I remember thhere was a "Z-Offset" field somewhere, look for it and rise your road a few cm above the 0 point with it

              Comment


                Wallenstein I don't see a Z-Offset, I only see a Pivot Offset and I tried modifying that but it looks like nothing was changed. Even if I was to raise the roads manually and try to have the terrain meet the road on the edges it doesn't work like how the tutorial is showing it worked. Maybe I am doing something wrong?

                Comment


                  Sir_Slopolot The road should look like this when you check Align To Surface(ATS) checkbox. The next step is to press "Apply Spline To Landscape" button (Defaults category). This will make the road visible again. You may need to adjust parameters under Landscape category like Landscape->"Deform Width". Make sure Landscape->Landscape variable is set to the Landscape you are using.

                  Comment


                    Thanks for Snappy Roads! Please help me, how can I add collisions in traffic spawner? Although, the player's car seems to have collision attributes, those spawned from traffic spawner always ignore collisions. Please help me. Thanks

                    Comment


                      GlimpseOfDawn , it looks like it tried to "Apply Spline To Lanscape", but only did a small spot. Modifying the parameters for "Deform Width" doesn't seem to make anything happen. My landscape is set in the variable dropdown.
                      Click image for larger version

Name:	image_159209.png
Views:	1
Size:	233.9 KB
ID:	1592778

                      Comment


                        lalas-laz Unfortunately traffic blueprint doesn't support player car interaction yet (and collision detection in general). It is for visualization/decoration purposes only.

                        Sir_Slopolot What size is your landscape's single quad (distance between two adjacent landscape vertices)? It needs to be smaller than width of road's sidewalk.

                        Comment


                          Any recent updates we should be expected anytime soon? I am just wondering. Perhaps there will be more features added or in progress and we going to get a discount as existing users, how much discount?.
                          I f you don't know just ask!...

                          Comment


                            Originally posted by Wallenstein View Post

                            I reported the same earlier but no answer. The author stated in an earlier post that he will not update for a while, presumably he has some issues in life. However, I did some research and found a way to get rid of this. I don't know if this is the correct way but I think it is the least intrusive way and it seems to cause no side effect. Add the red circled part to the construction script of the Snappy Road BP with "MeshSegmentIndexes add 0"
                            I had to download Snappy Road again and ran into the same problem. I would like to ask the creator to add this change to the next version.

                            Comment


                              Thank you for your patience. Today new update has been published on the marketplace.

                              Update summary:
                              • added lots of new and improved road and intersection models
                              • custom collision meshes
                              • photo scanned 2k road textures
                              • new realistic layered road material
                                • dynamic or painted road damage/dirt/tar/puddles (red,green,blue,alpha=0)
                                • puddles with depth map (vertex paint with alpha = 0)
                              • road banking(rotation/roll) is now supported
                              • you can now distribute blueprints along roads (under "Mesh Extra" category)
                              • you can now snap two roads together without intersection
                              • other improvements
                              • improved vehicle blueprint
                              Notes:

                              I will later update marketplace page to reflect the changes.
                              I'm also planning to increase price a little.
                              If you notice after update that some of your road meshes have been reset to single lane road, then use "FixLegacy" button under Default category.

                              I'd like to thank everyone for your support and inspiration. Without your continuous support this project wouldn't have been possible.
                              Attached Files

                              Comment


                                Is there an updated docuemntation how to use the new features? I am especially interested in the damage overlay

                                Comment

                                Working...
                                X