Announcement

Collapse
No announcement yet.

Snappy Roads Blueprint Tool: Announce and Support Thread

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    NewmanCostanza

    How are you importing these meshes? It looks like your axes may be wrong.

    When exporting from Blender, I use FBX, and I set the Forward Axis to X, and the Up Axis to Z.

    Comment


      I'm getting bumps at intersections. I've tried adjusting the sockets and even the spline slopes. Has anyone seen this? Any suggestions? I would try and replace the connected road-sections, but unfortunately, I don't have the schedule for that.

      EDIT: I solved the problem. The roads had their collision set to [Complex Collision as Simple], while the intersection's collision was set to [Project Default]. The 'Bump' that I was seeing was the car hitting the simple collision box of the intersection. Changing the intersection's collision to [CCaS] fixed the issue.
      Last edited by Doctor_Kannon; 11-01-2018, 11:14 PM.

      Comment


        Excellent package and your kindness to give back to the community. I mean you are not greedy the price is fair to all. You will realize [if you haven't already] the more you give back to the community the more love you receive plus reward of purchasing all your products.This is the time period we are living. I wish you the best. I purchased today and looking forward to implement to my on-going projects.
        I f you don't know just ask!...

        Comment


          Originally posted by Doctor_Kannon View Post
          Hello,

          Great tool!

          I've been getting a lot of these Warnings:

          LogScript: Warning: Script Msg: Attempted to access index 0 from array 'MeshSegmentIndexes' of length 0 in '/Game/SnappyRoads/Blueprints/BP_SnappyRoad.BP_SnappyRoad_C:UserConstructionScript'!
          LogScript: Warning: Script Msg: Attempted to access index 1 from array 'MeshSegmentIndexes' of length 0 in '/Game/SnappyRoads/Blueprints/BP_SnappyRoad.BP_SnappyRoad_C:UserConstructionScript'!
          LogScript: Warning: Script Msg: Attempted to access index 2 from array 'MeshSegmentIndexes' of length 0 in '/Game/SnappyRoads/Blueprints/BP_SnappyRoad.BP_SnappyRoad_C:UserConstructionScript'!

          And I have over 200 indices.

          How to fix?

          Thanks!

          Dr K.
          I reported the same earlier but no answer. The author stated in an earlier post that he will not update for a while, presumably he has some issues in life. However, I did some research and found a way to get rid of this. I don't know if this is the correct way but I think it is the least intrusive way and it seems to cause no side effect. Add the red circled part to the construction script of the Snappy Road BP with "MeshSegmentIndexes add 0"

          Comment


            Hello everyone
            i purchase this stuff and it s very good and optimyze.
            One question is it possible to Banking the road ? When i turn the vertice only extras meshes turn not the road itself.
            I m working on a race game and i need some Banking in curves.
            Thanks

            Comment


              is it at all possible to use this to generate roads on the fly? Or can this only be used to place roads ahead of time?

              Comment


                Hey, how would I make the sidewalk/pavement bigger?

                Comment


                  Hi .. purchased your plugin but I do need some help here.

                  in your quick tutorial video, on time 1:15 " Place custom sections.... " (replace road section) seen like does not work in my side.

                  I tried using all the meshes in your assets and does not seen to work. Please help, thanks.

                  Comment


                    Hello, can you please tell me how to properly Merge the SplineMesh Components to a Static Mesh? Everytime I Right-Click and "Convert to Static Mesh" all the Road pieces are overlapped....

                    Comment


                      You can not do that. None of the Spline based apps can be turned into a static mesh, I tried that before with the Impromptu stairs for example and the procedural house front generator. It is an Unreal problem. You will have to leave the roads as splines in the world

                      Comment


                        I'm trying to rotate along the X axis for specific spline points. Is there a way I can do this to make different spline points have different rotations?
                        Last edited by General1337; 12-25-2018, 02:44 AM.

                        Comment


                          Hi, Just bought this product, Nice product, but road don't show from a distance in Game play. Pease tell me how to avoid this

                          Comment


                            Originally posted by Wallenstein View Post
                            You can not do that. None of the Spline based apps can be turned into a static mesh, I tried that before with the Impromptu stairs for example and the procedural house front generator. It is an Unreal problem. You will have to leave the roads as splines in the world
                            Indeed you can. But you must use the merge actors tool as explained here:

                            https://answers.unrealengine.com/que...ml?sort=oldest

                            and here

                            https://answers.unrealengine.com/que...ge-result.html

                            Comment


                              Good to know, thanks, I check it with the merge actor tool

                              Comment


                                Great product, having lot's of fun with it! Makes prototyping a lot easier. I am having one issue though at the moment. I have a large network of roads and when I load my level many of the spline tangents are not quite where i left them which leads to roads not quite in the shape i left them. See the images below for before and after reloading the level. This happens on both short and long roads and on both curvy and straighter roads. It happens on some roads and not others. It only affects the start and end points of each spline, never intermediate points. I have to go through each point and Reset to Automatic Tangent > Automatic Tangent to get them back where I want them. Is there a way to lock them?

                                Comment

                                Working...
                                X