No announcement yet.

Snappy Roads Blueprint Tool: Announce and Support Thread

  • Filter
  • Time
  • Show
Clear All
new posts

    Right click on landscape -> Transform -> Uncheck 'Lock Actor Movement' - Works for me, but you have to do it every time you want to move your landscape. I don't know why.

    Best Regards


      How do I stop my car from falling through the road?


        This happens because Road Actor's Spline->CollisionPreset property is set to "OverlapAll" by default. Set it to "BlockAll" to enable collision. You may also want to set "Use Complex Collision As Simple" in Static Mesh Editor for road and intersection meshes as a temporary workaround. Many new intersections with custom collision meshes are going to be added soon.

        Best Regards


          Hey GlimpseOfDawn. First of all, awesome work with the tool, I really enjoy working with it.
          Maybe a stupid question, but I haven't found anything on this topic yet.
          Is there a way to prevent the vehicles from colliding into each other?
          Is there perhaps a collision setting that I overlooked or can I define a MinDistance between the vehicles somewhere?
          In the TrafficSpawner I have already tried to set the Min and Max Speed values to the same value to test if I can prevent the cars from colliding with each other, but without success.


            PyromanGER Thanks! There is no collision detection implemented for vehicles at the moment.

            Best Regards
            Last edited by GlimpseOfDawn; 09-15-2018, 09:06 AM.


              Hello everybody,
              I apologize, but unfortunately promised update wont be ready in time. It's almost complete, but due to circumstances I wont be able to complete it for a while. I may also not be able to reply to you in a timely fashion for the time being.

              Thank you for your patience,
              Best Regards

              Here are work in progress pictures:


                Beautiful pictures,don't worry with the delay.


                  we can wait a little longer!


                    I have made several child BPS from the Snappy Road with my own default meshes for other road types etc. Not sure if the following is due to that or not, but I'm getting a lof of warnings like this:

                    LogScriptCore: Warning: Script Msg: Attempted to access index 5 from array 'MeshSegmentIndexes' of length 0 in '/Game/SnappyRoads/Blueprints/BP_SnappyRoad.BP_SnappyRoad_C:UserConstructionScript'!

                    with all sorts of indices, presumably these are indices for the road segments that have been created with spline points.
                    Any idea what could cause this, more importantly, how to get rid of this?

                    Last edited by Wallenstein; 09-23-2018, 08:04 PM.


                      Originally posted by florinversus View Post
                      Tell me if i'm doing something wrong!

                      The main LANDSCAPE the Lock Actor Movement is Uncheck, also the LandscapeStreamingProxy from that section where is the road is Uncheck but i still get the prohibited icon, just on the Main Lanscape it apear as usable, but nothing is set/ selected.
                      I'm also having this issue. I cannot get my world composition levels to show up the landscape selector. What am I doing wrong?

                      Even if skip the persistant level and open up the individual tile it still does not show up in on landscape section drop down. Using 4.20.3

                      Last edited by KernalPanic; 09-26-2018, 03:27 AM.


                        I'm having some trouble importing my own Blender meshes to use with the tool.

                        Whenever I spawn End mesh children, they always generate with sideways rotation, and are facing back-to-front. I'm pretty new to UE4 and all this stuff, so perhaps the solution is simple. Nevertheless, after a while of troubleshooting with correcting rotation, pivot points and sockets, I still can't figure out what's wrong.

                        Here's a screenshot of the problem:
                        Attached Files



                          Great tool!

                          I've been getting a lot of these Warnings:

                          LogScript: Warning: Script Msg: Attempted to access index 0 from array 'MeshSegmentIndexes' of length 0 in '/Game/SnappyRoads/Blueprints/BP_SnappyRoad.BP_SnappyRoad_C:UserConstructionScript'!
                          LogScript: Warning: Script Msg: Attempted to access index 1 from array 'MeshSegmentIndexes' of length 0 in '/Game/SnappyRoads/Blueprints/BP_SnappyRoad.BP_SnappyRoad_C:UserConstructionScript'!
                          LogScript: Warning: Script Msg: Attempted to access index 2 from array 'MeshSegmentIndexes' of length 0 in '/Game/SnappyRoads/Blueprints/BP_SnappyRoad.BP_SnappyRoad_C:UserConstructionScript'!

                          And I have over 200 indices.

                          How to fix?


                          Dr K.



                            I'm getting gaps at the intersections.

                            Click image for larger version

Name:	snappygaps.jpg
Views:	142
Size:	142.1 KB
ID:	1540768

                            What am I missing? Is there a fix?


                            Dr. K.
                            Last edited by Doctor_Kannon; 10-17-2018, 02:49 PM. Reason: Attachment fail.


                              Two possibilities:
                              1) check that the textures don't have a transparent edge. I had textures that had a road marker on the edge that was supposed to be worn out and they did it by adding a transparent mask that made the edge look torn with little cracks
                              2) Check the position of the sockets. I don't know if the collision boxes play a role here at all but you can also check them that they don't stand out too much



                                It was the sockets.

                                The sockets were positioned at the edges of the SM. I simply moved them in from the edges.

                                Thank you so much!