Announcement

Collapse
No announcement yet.

Node graph assistant

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by DavidHuizingh View Post
    Looking forward to the 4.20 release!
    You can rebuild plugins quite easily (usually) to work with newer engine versions (useful while waiting for official release).
    Use this write up for orientation.

    Leave a comment:


  • replied
    Looking forward to the 4.20 release!

    Leave a comment:


  • replied
    Ad 1. The way Unreal shows tooltips on nodes, is pretty annoying - if the plugin could hide them regardless of "Auto Connect", that would be cool.

    Leave a comment:


  • replied
    Originally posted by Cpt.Trips View Post
    Issues (tested with 4.19):
    - Hiding Tooltip while Panning only seems to work when "Auto Connect" is enabled.
    - When Plugin is active, "Add Pin To Node" doesn't work anymore (e.g. inside a function, drag any wire onto the input or output node's label, "Add Pin To Node" tooltip will appear, but releasing wire will not create a new pin).
    - After highlighting a wire (or wires) by (shift) clicking, the selection can be released by clicking on any empty space in the graph (expected behavior), it will however not unselect the wires when a node has been selected.
    I am not sure if this is by design, but it causes a problem when adding a reroute node by double-clicking on a wire: it will highlight a section of the wire leading to the new reroute node.

    Suggestions:
    - Add Node Tooltip Delay (configurable in settings): when moving cursor over a node, tooltip will not show instantly but rather after the set amount of time (should not appear if cursor leaves node before that).
    1.Yes,hiding tool tip is for auto connect, because it makes wire easy to see,maybe it can be also useful when dragging a node?
    2.I really didn't know engine has drop on node operation,guess it was blocked by lazy connect,I'll add fix in the future.
    3.This doesn't happen to material graph,I might need to see how blueprint does it,also I see highlight wire with reroute node only highlight a section,I'll add it to future improvement.
    4.I know it's a minor improvement but its kind of cumbersome to do inside a plugin cause it need to track ui info, and Its best that epic implements it.

    again,thanks for your findings, it will certainly helps this plugin grow!

    Leave a comment:


  • replied
    Issues (tested with 4.19):
    - Hiding Tooltip while Panning only seems to work when "Auto Connect" is enabled.
    - When Plugin is active, "Add Pin To Node" doesn't work anymore (e.g. inside a function, drag any wire onto the input or output node's label, "Add Pin To Node" tooltip will appear, but releasing wire will not create a new pin).
    - After highlighting a wire (or wires) by (shift) clicking, the selection can be released by clicking on any empty space in the graph (expected behavior), it will however not unselect the wires when a node has been selected.
    I am not sure if this is by design, but it causes a problem when adding a reroute node by double-clicking on a wire: it will highlight a section of the wire leading to the new reroute node.

    Suggestions:
    - Add Node Tooltip Delay (configurable in settings): when moving cursor over a node, tooltip will not show instantly but rather after the set amount of time (should not appear if cursor leaves node before that).
    Last edited by Cpt.Trips; 07-15-2018, 09:52 PM.

    Leave a comment:


  • replied
    Originally posted by Cpt.Trips View Post
    Feature Requests / Ideas:

    - When dragging a Node, allow to init panning by holding also the right mouse button (same as with connection wires) - currently holding both mouse buttons triggers zooming (which is useless anyways to anyone with a mouse wheel).

    - Material editor doesn't have a "Jump to" option on pins. Would that be possible to add with a plugin?
    Ok, I'll put these features into the future feature plan.
    You can check them in the second reply in this post.

    Leave a comment:


  • replied
    Feature Requests / Ideas:

    - When dragging a Node, allow to init panning by holding also the right mouse button (same as with connection wires) - currently holding both mouse buttons triggers zooming (which is useless anyways to anyone with a mouse wheel).

    - Material editor doesn't have a "Jump to" option on pins. Would that be possible to add with a plugin?

    Leave a comment:


  • replied
    Originally posted by Cpt.Trips View Post
    I came here to suggest that feature, then realized it already does that.

    But I noticed it doesn't correctly re-enable the tooltip once I release the node and then hover over that same node again.
    I have to hover over any other node (hovering over a pin of the previous node also works).

    What does "lazy connect" and "auto connect" do?

    PS: link to git readme goes to 404
    I fix the link to the user guide,check that out.
    It seems that except material graph,disable and reenable tool tip wont show up tool tip unless tool tip content changed.I'll put that into future fix, thanks for pointing it out!

    Leave a comment:


  • replied
    Originally posted by yangxx View Post

    I added 3 brand new features.
    Yes I hide the tool tip when moving a node,this helps seeing the connection more clearly, did you find any unexpected behavior?
    I came here to suggest that feature, then realized it already does that.

    But I noticed it doesn't correctly re-enable the tooltip once I release the node and then hover over that same node again.
    I have to hover over any other node (hovering over a pin of the previous node also works).

    What does "lazy connect" and "auto connect" do?

    PS: link to git readme goes to 404

    Leave a comment:


  • replied
    Originally posted by Cpt.Trips View Post
    I see at least 2 new features. Sweet!
    Does the plugin also change the default behavior of tooltips on nodes?
    I added 3 brand new features.
    Yes I hide the tool tip when moving a node,this helps seeing the connection more clearly, did you find any unexpected behavior?

    Leave a comment:


  • replied
    I see at least 2 new features. Sweet!
    Does the plugin also change the default behavior of tooltips on nodes?

    Leave a comment:


  • replied
    Tested update, everything seems to work as advertised. Great work!

    Leave a comment:


  • replied
    Originally posted by Cpt.Trips View Post
    Awesome! Looking forward to it.

    check out the new user guide:
    https://github.com/pdlogingithub/UE4...ster/README.md

    it may take a while before epic approve my submit and update the market place.

    Leave a comment:


  • replied
    Awesome! Looking forward to it.

    Leave a comment:


  • replied
    Originally posted by Cpt.Trips View Post
    Really useful plugin! Solves at least one major issue that always irked me in UE4: not being able to drag the screen while holding a wire.
    Though, the Undo issue is a bit troublesome, Alt+Click and Alt+Drag are too similar to comfortably use the one without worrying about invoking the other by mistake.

    A different combo or a config/toggle would be highly welcome.
    Maybe Alt+Shift+Drag or Alt+RMB/drag?
    Thank you for the positive reply !
    And for your information,there is one major update coming to node graph assistant,which, fix all the problems you mentioned,stay tuned.

    Leave a comment:

Working...
X