Announcement

Collapse
No announcement yet.

Node graph assistant

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by IntervideoFilm View Post
    I just had an update for this plugin, are there any patch notes?
    no,I didnt make any changes.

    Leave a comment:


  • replied
    I just had an update for this plugin, are there any patch notes?

    Leave a comment:


  • replied
    I'm really impressed with what your work.
    I hope to have options for toggling multi-connect function key.
    Left click multi-connect is uncomfortable. It need to click once more to cancel the command.
    It would be nice to have multi-connect only with the Shift key.

    Leave a comment:


  • replied
    Originally posted by Cpt.Trips View Post

    Would really like to see this fixed, as it's quite a common action (double clicking a wire to create a reroute node).

    Other than that, everything is top notch, am really impressed with what you have built here.
    Thanks,will look into that.

    Leave a comment:


  • replied
    Originally posted by DasMatze View Post
    Hi! Thanks for this neat plugin! Is it possible to disable the feature of wires keep getting dragged even when the LMB is not pressed anymore? I keep missing fields for literal values with my cursor and it starts dragging a wire instead which is a little annoying.
    I notice that too,will try to find a solution(without disable it ,since its one of the main feature of the plugin),now you just have to click more precisely on the text part of the pin.

    Leave a comment:


  • replied
    Originally posted by yangxx View Post
    3.This doesn't happen to material graph,I might need to see how blueprint does it,also I see highlight wire with reroute node only highlight a section,I'll add it to future improvement.
    Would really like to see this fixed, as it's quite a common action (double clicking a wire to create a reroute node).

    Other than that, everything is top notch, am really impressed with what you have built here.

    Leave a comment:


  • replied
    Hi! Thanks for this neat plugin! Is it possible to disable the feature of wires keep getting dragged even when the LMB is not pressed anymore? I keep missing fields for literal values with my cursor and it starts dragging a wire instead which is a little annoying.

    Leave a comment:


  • replied
    Originally posted by Cheshire Dev View Post
    yangxx I noticed the plugin is missing small toolbar icons. Check "Use small toolbar icons" in Editor Preferences and open blueprint or material editor.

    And thanks for the plugin!
    Thanks for noticing,it will be fixed in next update.

    Leave a comment:


  • replied
    yangxx I noticed the plugin is missing small toolbar icons. Check "Use small toolbar icons" in Editor Preferences and open blueprint or material editor.

    And thanks for the plugin!

    Leave a comment:


  • replied
    Originally posted by DavidHuizingh View Post
    Looking forward to the 4.20 release!
    You can rebuild plugins quite easily (usually) to work with newer engine versions (useful while waiting for official release).
    Use this write up for orientation.

    Leave a comment:


  • replied
    Looking forward to the 4.20 release!

    Leave a comment:


  • replied
    Ad 1. The way Unreal shows tooltips on nodes, is pretty annoying - if the plugin could hide them regardless of "Auto Connect", that would be cool.

    Leave a comment:


  • replied
    Originally posted by Cpt.Trips View Post
    Issues (tested with 4.19):
    - Hiding Tooltip while Panning only seems to work when "Auto Connect" is enabled.
    - When Plugin is active, "Add Pin To Node" doesn't work anymore (e.g. inside a function, drag any wire onto the input or output node's label, "Add Pin To Node" tooltip will appear, but releasing wire will not create a new pin).
    - After highlighting a wire (or wires) by (shift) clicking, the selection can be released by clicking on any empty space in the graph (expected behavior), it will however not unselect the wires when a node has been selected.
    I am not sure if this is by design, but it causes a problem when adding a reroute node by double-clicking on a wire: it will highlight a section of the wire leading to the new reroute node.

    Suggestions:
    - Add Node Tooltip Delay (configurable in settings): when moving cursor over a node, tooltip will not show instantly but rather after the set amount of time (should not appear if cursor leaves node before that).
    1.Yes,hiding tool tip is for auto connect, because it makes wire easy to see,maybe it can be also useful when dragging a node?
    2.I really didn't know engine has drop on node operation,guess it was blocked by lazy connect,I'll add fix in the future.
    3.This doesn't happen to material graph,I might need to see how blueprint does it,also I see highlight wire with reroute node only highlight a section,I'll add it to future improvement.
    4.I know it's a minor improvement but its kind of cumbersome to do inside a plugin cause it need to track ui info, and Its best that epic implements it.

    again,thanks for your findings, it will certainly helps this plugin grow!

    Leave a comment:


  • replied
    Issues (tested with 4.19):
    - Hiding Tooltip while Panning only seems to work when "Auto Connect" is enabled.
    - When Plugin is active, "Add Pin To Node" doesn't work anymore (e.g. inside a function, drag any wire onto the input or output node's label, "Add Pin To Node" tooltip will appear, but releasing wire will not create a new pin).
    - After highlighting a wire (or wires) by (shift) clicking, the selection can be released by clicking on any empty space in the graph (expected behavior), it will however not unselect the wires when a node has been selected.
    I am not sure if this is by design, but it causes a problem when adding a reroute node by double-clicking on a wire: it will highlight a section of the wire leading to the new reroute node.

    Suggestions:
    - Add Node Tooltip Delay (configurable in settings): when moving cursor over a node, tooltip will not show instantly but rather after the set amount of time (should not appear if cursor leaves node before that).
    Last edited by Cpt.Trips; 07-15-2018, 09:52 PM.

    Leave a comment:


  • replied
    Originally posted by Cpt.Trips View Post
    Feature Requests / Ideas:

    - When dragging a Node, allow to init panning by holding also the right mouse button (same as with connection wires) - currently holding both mouse buttons triggers zooming (which is useless anyways to anyone with a mouse wheel).

    - Material editor doesn't have a "Jump to" option on pins. Would that be possible to add with a plugin?
    Ok, I'll put these features into the future feature plan.
    You can check them in the second reply in this post.

    Leave a comment:

Working...
X