Announcement

Collapse
No announcement yet.

Loading Screen System (Level Transitions w/ Progress)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How does this work with Navmeshes? We have had a tough time using level streaming because it screws up the Navmeshes -- the recast actor must be in the persistent level, and opening up sublevels on their own causes a new recast actor to be generated automatically, which fouls things up when the persistent level is reopened, etc. Does LSS not have this issue?

    Comment


      Originally posted by sabibo67 View Post
      How does this work with Navmeshes? We have had a tough time using level streaming because it screws up the Navmeshes -- the recast actor must be in the persistent level, and opening up sublevels on their own causes a new recast actor to be generated automatically, which fouls things up when the persistent level is reopened, etc. Does LSS not have this issue?
      Unreal is able to consolidate Nav Meshes from streaming levels.
      You need Nav Mesh Volumes both, in the Streaming Level as well as in the Persistent map. It shouldn't mess up anything.

      Preferably, the Nav Mesh in the Persistent Level should only serve as a dummy, preventing the system from deleting navigation when all levels are unloaded.
      [Marketplace] Loading Screen System (ᴘʀᴏᴘᴇʀ ʟᴏᴀᴅɪɴɢ sᴄʀᴇᴇɴs, ɴᴏᴡ ᴡɪᴛʜ ᴘʀᴏɢʀᴇss ʙᴀʀs)
      [Free][Script] Automate Download of Mixamo Animations
      [VłĐɆØ] Performance: BP vs C++ vs Blueprint Nativization

      Comment


        There seems to be a packaging bug with the 4.23 version of the plugin in 4.23.1.

        I'm currently getting this error:
        Code:
        UATHelper: Packaging (Windows (64-bit)):   ERROR: Missing precompiled manifest for 'LoadingScreenSystemPlugin'. This module was most likely not flagged for being included in a precompiled build - set 'PrecompileForTargets = PrecompileTargetsType.Any;' in LoadingScreenSystemPlugin.build.cs to override.
        3D Artist & Virtual Reality Specialist

        Comment


          Originally posted by BryanChrisBrown View Post
          There seems to be a packaging bug with the 4.23 version of the plugin in 4.23.1[/CODE]
          If the Plugin is located in "Engine/Plugins" try moving it to your project's "Plugins" directory instead.
          [Marketplace] Loading Screen System (ᴘʀᴏᴘᴇʀ ʟᴏᴀᴅɪɴɢ sᴄʀᴇᴇɴs, ɴᴏᴡ ᴡɪᴛʜ ᴘʀᴏɢʀᴇss ʙᴀʀs)
          [Free][Script] Automate Download of Mixamo Animations
          [VłĐɆØ] Performance: BP vs C++ vs Blueprint Nativization

          Comment


            Originally posted by Cpt.Trips View Post
            If the Plugin is located in "Engine/Plugins" try moving it to your project's "Plugins" directory instead.
            this fixed the issue Thanks!
            3D Artist & Virtual Reality Specialist

            Comment


              I'm currently getting an error in my project once the levels are loaded to 100%. This didn't occur in the previous version of my project before I added the LSS
              plugin. Click image for larger version  Name:	LSSCrash..JPG Views:	0 Size:	14.7 KB ID:	1693861

              This is occurring in a packaged build.
              Last edited by BryanChrisBrown; 12-03-2019, 12:17 PM. Reason: Edit: Add more details
              3D Artist & Virtual Reality Specialist

              Comment


                Originally posted by BryanChrisBrown View Post
                I'm currently getting an error in my project once the levels are loaded to 100%.
                I'm unable to reproduce the issue on my end in 4.23.1.
                Try the following to narrow it down:
                1. Disable "Enable Progress" and see if error still occurs.
                2. If error still occurs, disable the code plugin entirely.
                3. Try to reproduce the issue in a blank project (with Plugin and Progress enabled).
                4. If you have Blueprint Nativization enabled, try with it disabled.
                Last edited by Cpt.Trips; 12-03-2019, 12:53 PM.
                [Marketplace] Loading Screen System (ᴘʀᴏᴘᴇʀ ʟᴏᴀᴅɪɴɢ sᴄʀᴇᴇɴs, ɴᴏᴡ ᴡɪᴛʜ ᴘʀᴏɢʀᴇss ʙᴀʀs)
                [Free][Script] Automate Download of Mixamo Animations
                [VłĐɆØ] Performance: BP vs C++ vs Blueprint Nativization

                Comment


                  Originally posted by Cpt.Trips View Post
                  I'm unable to reproduce the issue on my end in 4.23.1.
                  Try the following to narrow it down:
                  1. Disable "Enable Progress" and see if error still occurs.
                  2. If error still occurs, disable the code plugin entirely.
                  3. Try to reproduce the issue in a blank project (with Plugin and Progress enabled).
                  4. If you have Blueprint Nativization enabled, try with it disabled.
                  I resolved the issue, it was unrelated to your plugin, apologies for misdiagnosing the issue.
                  3D Artist & Virtual Reality Specialist

                  Comment


                    Originally posted by BryanChrisBrown View Post
                    I resolved the issue, it was unrelated to your plugin, apologies for misdiagnosing the issue.
                    No worries, glad it's resolved.
                    [Marketplace] Loading Screen System (ᴘʀᴏᴘᴇʀ ʟᴏᴀᴅɪɴɢ sᴄʀᴇᴇɴs, ɴᴏᴡ ᴡɪᴛʜ ᴘʀᴏɢʀᴇss ʙᴀʀs)
                    [Free][Script] Automate Download of Mixamo Animations
                    [VłĐɆØ] Performance: BP vs C++ vs Blueprint Nativization

                    Comment

                    Working...
                    X